mediatomb should not depend on www-browser

Bug #963713 reported by Richard Eames on 2012-03-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mediatomb (Ubuntu)
Undecided
Unassigned

Bug Description

Since mediatomb is a media "server", it should not depend on gui components like a browser being installed on the local machine.
I have mediatomb installed on a very low spec headless server on which I'm trying to free some resources, which means firefox. Mediatomb should recommend instead of depend on a browser, since it's not really a dependency of the machine it's actually running on.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mediatomb (Ubuntu):
status: New → Confirmed
Mattias Holmlund (u219) wrote :

From "apt-cache show mediatomb"

 This package contains the desktop file needed to access the web ui using a
 system's default web browser. This package also acts as a virtual package to
 install all other mediatomb packages.

You don't need this package on your server. You only need mediatomb-daemon. It does not depend on firefox.

I have marked this bug as Invalid. I hope I am allowed to do that...

Changed in mediatomb (Ubuntu):
status: Confirmed → Invalid
Justin Buser (justin-buser) wrote :

See this is the problem with Ubuntu, and one of the reasons why I and many others run Arch and other distros. Regardless of the semantics involved in the description we really need to stop treating people like idiots and shoving software down their throat.

I have Google Chrome installed, which provides www-browser, but since it's not part of Canonical the Ubuntu Software Center doesn't recognize that fact. Ergo when I someone tries to remove Firefox using that method it will remove Mediatomb as well. On top of which it removes ALL of Mediatomb, not just the virtual package.

The bottom line is that a web browser is a common enough thing that people don't need to be forced to install one. In essence the only thing a virtual package should require are packages that are all components of the same application, not some arbitrary external application that may or may not have designated itself as a web browser.

Mediatomb does NOT "depend" on Firefox, or www-browser for that matter, following that logic you might as well also require linux-generic, x-window-system, gnome-desktop | kde-plasma-desktop | xfdesktop4 | desktop-base, etc...

In short, this dependency should not be there, simply because this package includes a desktop shortcut to a web page, a recommendation should be MORE than sufficient. In what universe will a situation arise where someone knows what a web page is and want's to load it but doesn't have a browser installed or know where to get one?

Changed in mediatomb (Ubuntu):
status: Invalid → Opinion
Justin Buser (justin-buser) wrote :

See http://www.debian.org/doc/debian-policy/ch-relationships.html, which clearly states that a dependancy should only be declared when a package cannot be installed and configured without it.

Changed in mediatomb (Ubuntu):
status: Opinion → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers