[FFe][needs-packaging] MediaTomb 0.12.1

Bug #553269 reported by Anders
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mediatomb (Debian)
Fix Released
Unknown
mediatomb (Ubuntu)
Wishlist
Unassigned

Bug Description

Reason for FFe:
We have an svn snapshot where the full release was done 5 months ago.

v0.12.1 08.04.2010
        * fixed YouTube service support (got broken after they updated their
          website)
        * fixed a problem in soap response http headers (solves "access error"
          on Yamaha RX-V2065)
        * turned out the change log for 0.12.0 was not complete (various
          closed bugs were not mentioned)
        * fixed automatic id3lib detection when taglib is not available

v0.12.0 25.03.2010
        * added video thumbnail generation using libffmpegthumbnailer
        * added configure settings which allow to enable sqlite backups by
          default
        * added cross compile defaults for the inotify check to configure
        * added configure check for broken libmagic on Slackware
        * added libmp4v2 metadata handler to get tags and cover art from mp4
          files
        * got rid of several compiler warnings
        * added storage cache
        * added storage insert buffering
        * fixed mysql "threads didn't exit" issue
        * implemented YouTube service support which allows to watch YouTube
          videos on your UPnP player (in combination with transcoding)
        * added fixes to allow PCM playback on the PS3 and other devices,
          thanks to mru for his findings. This allows streaming transcoded
          OGG and FLAC media to the PS3.
        * added option to enable tooltips for the web UI, thanks to cweiske
          for the patch
        * fixed bug #1986789 - Error when renaming a playlist container
        * added parameter -D/--debug (enable debug output)
        * closed feature request #1934646 - added parameter --version
          (prints version information
        * added parameter --compile-info (prints compile information)
        * fixed problem "Negative duration in .m3u files" (SF forum)
        * fixed bug #2078017 - Playlist inital import fails in autoscan
          directories
        * fixed bug #1890657 - transcoding tmp file using 2 //
        * fixed bug #1978210 - compile error with newer libcurl
        * fixed bug #1934649 - typo in --help text
        * fixed bugs #1986709 and #1996046 - cannot rename item with & in name
        * fixed bug #2122696 - build error with MySQL 5.1
        * fixed bug #1973930 - Incorrect UPnP class assigned to Vorbis and
          Theora items
  * fixed bug #1934659 - unspecific error message when db is not available
        * fixed bug #2904448 - memset with number of bytes set to 0 in
          array.cc
        * added a "Directories" view in the default layout for Photos and
          Video, the feature is still somewhat experimental
        * added a feature that allows to mark played items
        * improved inotify check which was failing with 2.4 kernels
        * added support for lastfmlib, thanks to Dirk Vanden Boer vor the
          patch
        * increased buffer length for the exif field following the request
          from one of our users
        * fixed a problem where the upnp-string-limit function was not
          correctly truncating UTF-8 strings
        * fixed a bug where --enable-id3lib did not turn off the automatic
          enabling of taglib, which then resulted in an error message saying,
          that both libraries are enabled
        * implemented feature request #2833402 - ability to change
          ffmpegthumbnailer param "image quallity"
        * fixed bug #2783557 - Mediatomb always flags file as chunked output,
          thanks to Michael Guntsche
        * fixed bug #2804342 - wrong namespace in <serviceId>
        * added a fix for glibc 2.10, thanks to Honoome for the patch
        * added patches for NetBSD, thanks to Jared D. McNeill
        * fixed bug #2944701 Adding comment in config as last line yields
          segfault
        * fixed bug #2779907 SQLITE3: (1) cannot start a transaction within a
          transaction
        * fixed bug #2820213 build broken with libmp4v2-1.9.0
        * fixed bug #2161155 inotify thread aborts
        * fixed bug #2011296 SVN rev 1844 doesn't show more than 10 files on
          PS3
        * fixed bug #1988738 web ui docs miss note how to access web ui
        * fixed bug #1929230 invalid XML in UPNP messages
        * fixed bug #1865386 autoscan dir already exists error
  * implemented feature request #2313953 support for forked libmp4v2
          project
        * implemented feature request #1955192 flag/mark watched video files
        * implemented feature request #1928580 better logging/tracing support
        * implemented feature request #1754010 m4a metadata extraction

MediaTomb 0.12.0 was released 26 March 2010. It'd be great to see it included in time for Lucid (or, as this is an LTS, in Lucid-backports).

Release info:
http://mediatomb.cc/news?item=55
http://mediatomb.cc/pages/download#debian_ubuntu

Related branches

Revision history for this message
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in mediatomb (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Anders (andersja+launchpad-net) wrote :
Micah Gersten (micahg)
Changed in mediatomb (Debian):
importance: Undecided → Unknown
status: New → Unknown
summary: - [needs-packaging] MediaTomb 0.12.0 (just released)
+ [needs-packaging] MediaTomb 0.12.1
Changed in mediatomb (Debian):
status: Unknown → New
Revision history for this message
Micah Gersten (micahg) wrote : Re: [needs-packaging] MediaTomb 0.12.1

Gonna try to get this in before feature freeze

Changed in mediatomb (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
Revision history for this message
Micah Gersten (micahg) wrote :

Eh, this didn't go too well, might try later if I have time

Changed in mediatomb (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → New
Revision history for this message
Micah Gersten (micahg) wrote :

Packaging done, built in pbuilder.

summary: - [needs-packaging] MediaTomb 0.12.1
+ [FFe][needs-packaging] MediaTomb 0.12.1
description: updated
Revision history for this message
Jason 'vanRijn' Kasper (vr-movingparts) wrote :

Hey Micah, is there a ppa repository we can add to get 0.12.1? Thanks very much for working on this! =:)

Revision history for this message
Colin Watson (cjwatson) wrote :

Fine to go ahead with this from the FFE point of view, although I'd strongly prefer it if we could do this in sync with Debian to avoid later problems merging etc.

Changed in mediatomb (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediatomb - 0.12.1-0ubuntu1

---------------
mediatomb (0.12.1-0ubuntu1) maverick; urgency=low

  * New upstream release (LP: #553269)
    + Drop patches applied upstream:
      - drop debian/patches/service-id_fix.patch
      - drop debian/patches/ffmpegthumbnailer-2.0.patch
      - drop debian/patches/autoreconf_-fi.patch
    + Refresh patch due to upstream changes
      - update debian/patches/const_char_conversion.patch

  * Merge from debian unstable. Remaining changes:
    - debian/control:
      + Don't depend on libmozjs-dev
      + Add OR depends on abrowser
    - debian/rules: Disable js support
    - fix LP: #569763 - mediatomb allows anyone to browse and export the whole
      filesystem

mediatomb (0.12.0~svn2018-6.1) unstable; urgency=low

  * Non-maintainer upload.
  * Disable user interface (Closes: #580120)
 -- Micah Gersten <email address hidden> Wed, 25 Aug 2010 17:07:03 -0500

Changed in mediatomb (Ubuntu):
status: Confirmed → Fix Released
Changed in mediatomb (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.