mediatomb unable to create config file on start-up

Bug #501932 reported by Ben James on 2009-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mediatomb (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mediatomb

On a fresh install of mediatomb on Ubuntu 9.10 server (minimal install) the daemon is unable to create the config.xml file (and hence doesn't allow configuration via the web interface).

Manually attempting to start the daemon (sudo /etc/init.d/mediatomb start) shows a failure; the log file shows that the daemon appears not to be able to generate the required config file:

2009-12-31 16:52:30 INFO: Loading configuration from: /etc/mediatomb/config.xml
2009-12-31 16:52:30 ERROR: read_text_file: could not open /etc/mediatomb/config.xml

This is _after_ I manually modified the directory ownership to mediatomb:mediatomb:

sudo chown -r mediatomb:mediatomb /etc/mediatomb

In short, the instructions on the following wiki page don't work:

http://mediatomb.cc/dokuwiki/faq:faq#how_do_i_make_mediatomb_start_automatically

In addition, the install package is broken (this should work out-the-box).

ProblemType: Bug
Architecture: amd64
Date: Thu Dec 31 16:37:46 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: mediatomb (not installed)
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: mediatomb
Uname: Linux 2.6.31-17-generic x86_64

Note: This bug was submitted on a machine that differs from the machine that shows the bug - the bug was seen on a virtual machine running on the above machine.

aTc (atc-lp) wrote :

I tried it with a clean install of ubuntu server 9.10 64 bit version in VirtualBox, and it had no problems whatsoever with the config file.
It did fail to launch because of the network not beeing ready when Mediatomb is started, but starting it manually later (/etc/init.d/mediatomb restart) worked like it should.

I'll try and reproduce the bug again with another clean install...

Hmm - I can't seem to reproduce this on a completely clean system. It might be something to do with Samba (that's that only difference I can remember between the clean install and the system where the bug was seen.

Stranger and stranger - mediatomb now appears to work out the box.

I think this bug should be marked as "unable to reproduce" for now - if I manage to find out what went wrong before (and it wasn't just user error), I'll update the bug report with more details.

Thanks for the help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers