Cannot play symlinks

Bug #1475417 reported by Christopher Baines
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Music App
New
Undecided
Unassigned
mediascanner2 (Ubuntu)
New
Undecided
Unassigned

Bug Description

I am using the following setup, the files in the Music directory (name.ogg) are symlinks to files in a hidden directory (also in the Music folder). I am using this setup as I keep my music in a git-annex repository.

The music app does not show any of the tracks.

When you select a symlink in the file browser, you can open it with the Music app, but it gives a "Failed to move file" error. If you navigate in to the hidden directory, and select the file, it plays correctly, and appears in the Music app, however it may have copied it to another directory in the Music folder.

The behavior I would like, is for the music app to be able to index the files (dereferencing the symlinks as it goes), and also support selecting a symlink in the file browser to be played (again, dereferencing the file). As the content is also in the Music directory, it does not need to be copied or moved, however this issue may go away if the others are resolved.

Let me know if I can help in any way.

Revision history for this message
Christopher Baines (3-mril-x) wrote :
Revision history for this message
Christopher Baines (3-mril-x) wrote :

Getting mediascanner to pickup the symlinks might be as simple as adding another condition to this if.

https://bazaar.launchpad.net/~mediascanner-team/mediascanner2/trunk/view/head:/src/daemon/Scanner.cc#L97

I am not sure how to crosscompile the deb, so have not tested this myself.

Revision history for this message
Victor Thompson (vthompson) wrote :

Thanks for filing this bug, Christopher! I've adding the mediascanner2 project as affected by this issue.

affects: mediascanner2 → mediascanner2 (Ubuntu)
Revision history for this message
James Henstridge (jamesh) wrote :

We used to follow symlinks, but stopped doing so when we ran into problems when people used them to create cycles (e.g. "ln -s .. foo") that caused the scanner to go into a loop. Ignoring all symlinks avoided this problem but is a problem for your use case.

It will index your media if you use a bind mount instead (which doesn't have the looping problems), but it might be a bit difficult to get that to survive reboots on the phone.

Revision history for this message
Michi Henning (michihenning) wrote :

I would have expected something or other to drop out with ELOOP?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers