/usr/bin/mediaplayer-app:11:__memcpy_neon:std::char_traits:std::basic_streambuf:std::basic_streambuf:std::__ostream_write

Bug #1524131 reported by errors.ubuntu.com bug bridge on 2015-12-09
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Thomas Voß
dbus-cpp (Ubuntu)
Critical
Thomas Voß
mediaplayer-app (Ubuntu)
Undecided
Thomas Voß

Bug Description

Top 3 over the past week on errors.u.c. mediaplayer has not been updated for a while and the frequency increased significantly around mid-december, probably due to a change in an underlying component (gstreamer has been updated on Dec. 12th or it could be the major dbus match rules changes as the stacktrace would suggest)

The Ubuntu Error Tracker has been receiving reports about a problem regarding mediaplayer-app. This problem was most recently seen with version 0.20.5+15.04.20150701-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/a649a8d64746c3cce478208950c51611a06323cb contains more details.

Related branches

Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
description: updated
description: updated
no longer affects: gstreamer1.0 (Ubuntu)
description: updated
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
tags: added: regression-release
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Voß (thomas-voss)
Jean-Baptiste Lallement (jibel) wrote :

Setting to critical as the app cannot be relaunched until apport is done wroting the crash file when is it enabled.

Changed in canonical-devices-system-image:
importance: High → Critical
Jean-Baptiste Lallement (jibel) wrote :

another frequent case, play a video, tap of the 'left arrow' at the bottom of the screen, mediaplayer crashed.

Alberto Aguirre (albaguirre) wrote :

The stack trace points to:

ss << "type='" << lut.at(d->type) << "'" << comma;

where lut is a static const std::map<Message::Type, std::string>. So perhaps the dbus::Object instance is destroyed after unloading the libdbus-cpp.so.

Is libdbus-cpp.so being loaded dynamically? Or I guess a library linking to libdbus-cpp is loaded dynamically.

Jean-Baptiste Lallement (jibel) wrote :

Another case when an app is launched from another app eg the camera app launched from the messaging app.
In this case the camera app crashes when the user goes back to the gallery app and leave a non functional camera app in the spread for a moment until it finishes crashing (lp:1533292)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus-cpp (Ubuntu):
status: New → Confirmed
Changed in mediaplayer-app (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) wrote :

marking the media-player task as invalid because this is a system level issue that occurs across multiple apps, not specific to mediaplayer

Changed in mediaplayer-app (Ubuntu):
status: Confirmed → Invalid
Changed in dbus-cpp (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
Changed in mediaplayer-app (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
Changed in dbus-cpp (Ubuntu):
importance: Undecided → Critical
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in dbus-cpp (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers