Cannot transfer video files to iPod (Touch, 2nd gen)

Bug #685545 reported by _blue on 2010-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
media-player-info
Fix Released
High
media-player-info (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: media-player-info

I decided to try out banshee (default in 11.04) and was pleasantly surprised to find out it supports video syncing. I tried it out and kept getting the error message "mp4 format is not supported by the device". Same for .m4v files, although the problem has to do with the file's mime type and not the file extension.

The problem turned out to be that my iPod is using an incorrect media-player-info file that doesn't allow the "video/mp4" mime type to be transferred. There are 2 mpi files for iPods in /usr/share/media-player-info: apple-ipod.mpi and apple-1261_1262.mpi. The first is a catch-all for any "Apple" and "iPod" device and specifies only audio mime formats.

The second file seems to be for iPods that support video and adds the "video/mp4" mime type, but restricts it's matching to just two product ids, 0x1261 and 0x1262. In order to solve this problem, I had to add my iPod Touch 2nd gen product id, 0x1293. Once that was done, everything worked just fine. This will probably need to be done for other iPods that support video as well. I found a list of devices here: http://www.linux-usb.org/usb.ids

This is my first foray into udev, so I'm not sure exactly what to update. I saw a couple of things that hinted about updating mpi files and then compiling those to udev rules. In order to get my system to work, I updated both. To apple-1261_1262.mpi, I added ";usb:05ac:1293" to the end of the DeviceMatch line to add my product id. Next, I edited /lib/udev/rules.d/40-usb-media-players.rules and added "|1293" to the ATTRS{idProduct} that uses apple-1261_1262. Once that was done, I just had to restart udev.

This probably isn't the correct way. It looks like the apple-1261_1262.mpi should be changed to an apple-ipod-video.mpi file, and more device ids should be added.

_blue (blue) wrote :

I found the upstream bug tracker and submitted this there, along with a patch to fix it. Hopefully this will make it into ubuntu before Natty.

Changed in media-player-info:
status: Unknown → Fix Released
Dylan Aïssi (daissi) wrote :

Fixed in Natty (12-1)

Changed in media-player-info (Ubuntu):
status: New → Fix Released
Changed in media-player-info:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.