No sound notification for new SMS (Ubuntu Touch)

Bug #1544477 reported by Anupam on 2016-02-11
150
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
indicator-sound (Ubuntu)
Undecided
Unassigned
media-hub (Ubuntu)
Undecided
Alfonso Sanchez-Beato
pulseaudio (Ubuntu)
High
Hui Wang
qtmultimedia-opensource-src (Ubuntu)
High
Unassigned
telephony-service (Ubuntu)
High
Alfonso Sanchez-Beato
unity8 (Ubuntu)
High
Alfonso Sanchez-Beato

Bug Description

I noticed for last 2-3 days there is no sound notification for a new SMS, but there's a blinking green LED notification. Also in the indicator menu the envelope icon turns green and the new SMS is listed as usual. Things are working alright for Telegram, Gmail etc. (sound+LED+indicator menu).

Device: bq Aquaris E5 HD, Ubuntu 15.04 (OTA-9)

UPDATE: Screenshots get silent too.

Related branches

Anupam (anupam207) on 2016-02-11
summary: - No sound and LED notification for new SMS Ubuntu Touch
+ No sound notification for new SMS (Ubuntu Touch)
description: updated
Geoff Lowther (r-ubuntuone-b) wrote :

On Meizu MX4 with OTA-9 installed, I have the green envelope OK, the vibration notification also works but there is no sound. Tried the following sounds; Amsterdam (Default), Mallet and Positive - all have the same outcome - no sound produced on a new SMS.

Pat McGowan (pat-mcgowan) wrote :

When you are in this state please check if other audio plays, like with the music app. If not this is probably bug #1542947 and a reboot should fix it.

Changed in indicator-messages (Ubuntu):
assignee: nobody → Pat McGowan (pat-mcgowan)
status: New → Incomplete
Geoff Lowther (r-ubuntuone-b) wrote :

On my MX4, then this is a permanent issue, that is, a reboot or forced-reboot (power button held for 10 seconds) does not clear it - opening Music and playing tracks, incoming calls and going into System Settings | Sound and selecting different sounds (Amsterdam, Positive, etc) all cause playing of the tune (with the stop icon at the bottom of the screen when in the System Settings | Sound screen).

It's just that when you leave the phone and an SMS comes in, it just vibrates and doesn't give any sound - it gives sound and vibration when a call comes in still.

Anupam (anupam207) wrote :

Thanks Pat McGowan (pat-mcgowan), other sounds (incoming call, music player, youtube on browser, notification from telegram, gmail etc.) were playing fine except the incoming SMS notification. Then I restarted the device and now sound notification for incoming SMS works again!
But I found something a bit abnormal. During these sound alerts (I tried SMS and Telegram for now), a very mild crackling noise is heard for a second (or a fraction of a second) before and after the actual alert tune. Something like Bug #1479758 . I don't remember hearing this noise previously.

Pat McGowan (pat-mcgowan) wrote :

The volume for notifications is currently separate from the ringtone (default) setting. I suspect yours is at the lowest setting. Try turning up the volume as soon as an incoming notification is on screen. And yes this is rather tricky to do and we will modify this behavior in the future

Alternately from the command line you can remove all the current settings and go back to defaults:
rm /home/phablet/.config/pulse/ubuntu-phablet-stream-volumes.tdb
and restart the phone.

Pat McGowan (pat-mcgowan) wrote :

Actually my comment previously is not correct, the alerts seems to be following the multimedia volume level used for music playback so at this point I am not sure why you have no audio for text messages.

Please attach the pulse config file from the previous comment to the bug.

Pat McGowan (pat-mcgowan) wrote :

also please attach the log file from /home/phablet/.cache/upstart/media-hub.log

Anupam (anupam207) wrote :

As I mentioned in comment #4 sound alert for new SMS is working again after reboot. Nevertheless I deleted (from file browser, not using terminal) the ubuntu-phablet-stream-volumes.tdb file and rebooted as suggested in comment #5. Sound alert for text, call, Telegram - all working fine now. The new ubuntu-phablet-stream-volumes.tdb file is attached herewith.

Anupam (anupam207) wrote :

here's the media-hub.log file

Geoff Lowther (r-ubuntuone-b) wrote :

here's the ubuntu-phablet-stream-volumes.tdb file from my mx4

Geoff Lowther (r-ubuntuone-b) wrote :

and also the media-hub.log file (again from my mx4) as requested.

Many thanks for your help so far.

Geoff Lowther (r-ubuntuone-b) wrote :

ah, just deleted the ubuntu-phablet-stream-volumes.tdb file and rebooted the mx4 - sound is back - great, thanks for the suggestion.

Volume (in System Settings | Sound) never made a difference when I tried to adjust before.

thx again.

Pat McGowan (pat-mcgowan) wrote :

While I am glad that fixed it for you I am not yet sure how it came to be in that state. Will keep the bug open for now.

Geoff Lowther (r-ubuntuone-b) wrote :

OK, thx, I also raised a question https://answers.launchpad.net/ubuntu/+source/ubuntu-settings/+question/285197 (but may have posted into the wrong place) asking if there's any apps or methods of changing the volumes independently as on Android as I hadn't found anything when searching the web, however there were no suggestions given.

Wonder if you could share some light - at present if this happens again is the only way forwards to delete the file again. As with any issue, it isn't a solution but a usable workaround currently.

Pat McGowan (pat-mcgowan) wrote :

Dump of the bad config

key 30 bytes
sink-input-by-media-role:phone
data 18 bytes
[000] 42 01 31 6D 01 00 76 01 00 00 F0 A0 30 30 30 4E B.1m..v. ....000N
[010] 30 4E 0N

key 38 bytes
sink-input-by-media-role:feedbacksound
data 23 bytes
[000] 42 01 31 6D 02 01 02 76 02 00 01 00 00 00 01 00 B.1m...v .......
[010] 00 31 30 30 4E 30 4E .100N0N

key 30 bytes
sink-input-by-media-role:alert
data 18 bytes
[000] 42 01 31 6D 01 00 76 01 00 00 19 99 30 30 30 4E B.1m..v. ....000N
[010] 30 4E 0N

key 35 bytes
sink-input-by-media-role:multimedia
data 18 bytes
[000] 42 01 31 6D 01 00 76 01 00 00 2E 14 31 30 30 4E B.1m..v. ....100N
[010] 30 4E 0N

key 38 bytes
source-output-by-media-role:multimedia
data 13 bytes
[000] 42 01 30 6D 00 76 00 30 30 30 4E 30 4E B.0m.v.0 00N0N

key 30 bytes
sink-input-by-media-role:alarm
data 18 bytes
[000] 42 01 31 6D 01 00 76 01 00 00 BC 53 30 30 30 4E B.1m..v. ...S000N
[010] 30 4E 0N
tdb>

no longer affects: indicator-messages (Ubuntu)
tags: added: audio
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → Medium
milestone: none → backlog
status: New → Confirmed
Changed in media-hub (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
1 comments hidden view all 124 comments
Geoff Lowther (r-ubuntuone-b) wrote :

I believe that it is inconsistent (more than just putting into silent and back out).
I had my MX4 in silent on Friday evening then back to normal
Saturday seemed OK
Sunday morning I thought the SMS sound notification wasn't working (vibration still good) - I had to hard reset my phone 2-3 times to get bluetooth working again to my headset and phone app crashed as locked up the screen (bluetooth kept connecting but no voice transferred, then after 2-3 hard resets (power button for 10 secs) all came good again).
Sunday evening SMS notifications all ok for multiple texts from multiple people, sent various SMS's and a single MMS, again OK
received SMS after this, sound still good
Something happened (unknown what though)
now sound failed again on SMS...

Would you like a copy of the ubuntu-phablet-stream-volumes.tdb file again or anything else I can provide to assist?

Jim Hodapp (jhodapp) wrote :

Anupam: I don't see anything wrong from the media-hub.log, at least with this portion of the media stack. I'm thinking it may be an issue with pulseaudio but this bug will require deeper investigation to really know for sure. Anupam, which of the .ogg files listed in your media-hub.log do you currently have set for playing for SMS notifications?

Geoff: Can you please attach your media-hub.log file right after this occurs for you as well? I'd like to double check.

Changed in media-hub (Ubuntu):
status: New → Incomplete
Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
Anupam (anupam207) wrote :

Hello Jim. the log file I attached before was from the time when every sound notification was working fine right after a reboot. But I'm seeing this issue every now and then. Usually deleting ubuntu-phablet-stream-volumes.tdb file, rebooting device for once (sometimes twice) etc. make things normal again. I'll try to get the log file when there's no SMS sound next time.

Meanwhile, I'm not sure whether it's a mere coincidence or the causality, but I noticed the issue after these steps for the last 2-3 times:
1. Toggle the "Silent Mode" on from the indicator menu
2. Keep the device in "Silent Mode" for 2-3 hours
3. Deactivate "Silent Mode" from the indicator menu

I mostly use Mallet.ogg files as SMS tone, sometimes switch to Positive.ogg

Geoff Lowther (r-ubuntuone-b) wrote :

here's a zip of the media hub files before and after it going wrong (I'm assuming that this is what the .gz files are). I don't recall changing the volume or silent status until after it went wrong yesterday apart from on Friday evening when it was on silent for around 1-2 hours. Media-hub-7.gz should show when it was in silent mode (Friday evening). Hope this info is useful - if not and you need something else please holla.

Geoff Lowther (r-ubuntuone-b) wrote :

I did change the sounds from the default to positive the other week as I thought I was missing text messages due to not hearing them - then I did the tests and found it was due to only the vibration working - before it was left on the Amsterdam default.

Jim Hodapp (jhodapp) wrote :

Thanks for the info and logs Geoff and Anupam. The first step will be to try and reproduce this issue locally and see if we can identify the root cause.

Anupam (anupam207) wrote :

Here's the media-hub.log file when there's no sound alert for new SMS. Sound alert for new Telegram message is working fine. Also I wanted to mention another fact in case it turns out helpful. Even when the sound alert is working for SMSs, new Telegram message alert is significantly louder than new SMS alert although both play the same tone (chosen in System Settings > Sound > Message received).

Anupam (anupam207) wrote :

also the aforementioned tdb file when there's no sound alert

1 comments hidden view all 124 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Anupam (anupam207) wrote :

Just noticed something, when this issue appears, taking screenshots also doesn't produce any sound.

SB (emehntehtt) wrote :

I noticed this bug for a while now, SMS sounds get muted for no apparent reason (while other sounds work) and they arent back unless I reboot the phone. This persists for a long time now, so far after OTA-11 I didnt experience the issue, but I didnt receive many SMS messages since OTA-11 so it may not mean anything, as most people send me a Telegram message. I will monitor the situation further.

1 comments hidden view all 124 comments
SB (emehntehtt) wrote :

Then probably I just didnt encounter it yet, strange that all other sounds continue working normally but SMS does not. I hope developers will be able to discover what is causing this issue.

Jim Hodapp (jhodapp) wrote :

Continue to see if you can find a definite pattern to what's causing this. It's indeed a tricky issue and your patience on this is greatly appreciated.

1 comments hidden view all 124 comments
SB (emehntehtt) wrote :

@Anupam I will see next time sound gets muted, didnt try screenshots before when it happened.

SB (emehntehtt) wrote :

It happened again and neither SMS nor screenshot sound is heard.

Jim Hodapp (jhodapp) wrote :

Seems to me like that audio role's volume is getting set to 0%. If I remember right, SMS alerts and the screenshot sound both use the same audio role. One way to check this is to watch the media-hub log from a shell by doing "tail -f /home/phablet/.cache/upstart/media-hub.log" You'll be looking for a line that details the audio role and match the filename to the one you're expecting (SMS being one, screenshot sound being another). If you then validate that they're listed as the same roles that will be a first step. Next step would be to try other things that might be the same role type and verify again in the media-hub.log that they are the same role. Lastly, begin to verify that only this audio role type sounds are the ones that aren't playing.

Anupam (anupam207) wrote :

@Jim could you please have a look at my media-hub log file:
https://launchpadlibrarian.net/243178199/media-hub.log
(This is an old log from a time when the issue was present. Alert tone for SMS was Mallet.ogg)
Also ubuntu-phablet-stream-volumes.tdb file from the same time is here:
https://bugs.launchpad.net/ubuntu/+source/media-hub/+bug/1544477/comments/24

Jim Hodapp (jhodapp) wrote :

@Anupam: can you get a latest media-hub.log when this bug happens to you again? I want to trace that knowing that you have the latest stable code.

Anupam (anupam207) wrote :

@Jim I'm experiencing the issue again. Here's the latest media-hub.log file (June 12, '16). Do you want me to upload the ubuntu-phablet-stream-volumes.tdb file too?

Jim Hodapp (jhodapp) wrote :

@Anupam: sure that certainly couldn't hurt to have.

Anupam (anupam207) wrote :

@Jim here you are

Jim Hodapp (jhodapp) on 2016-06-13
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
assignee: David Henningsson (diwic) → Anthony Wong (anthonywong)
Changed in media-hub (Ubuntu):
status: Incomplete → Invalid
Changed in pulseaudio (Ubuntu):
assignee: Anthony Wong (anthonywong) → Hui Wang (hui.wang)
Anupam (anupam207) on 2016-06-22
description: updated
Jim Hodapp (jhodapp) on 2016-06-29
Changed in canonical-devices-system-image:
importance: Medium → High
Changed in pulseaudio (Ubuntu):
importance: Medium → High
Hui Wang (hui.wang) on 2016-07-05
Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Jim Hodapp (jhodapp) on 2016-08-16
Changed in media-hub (Ubuntu):
assignee: Jim Hodapp (jhodapp) → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
44 comments hidden view all 124 comments
Jim Hodapp (jhodapp) wrote :

Marked this bug as incomplete. If anybody sees this issue with OTA-12 and can reliably reproduce the issue, we'll reopen this bug.

Changed in canonical-devices-system-image:
status: In Progress → Incomplete
Changed in indicator-sound (Ubuntu):
status: Confirmed → Incomplete
Changed in media-hub (Ubuntu):
status: Invalid → Incomplete
Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete

It is still broken on my BQ E4.5 with OTA-12 but I don't know how to
make it break.
The only reliable sms sound alert is the first one after a restart so if
I think I am going to get more sms I need to know about I now restart
phone after receiving each one.

On 18/08/16 14:46, Jim Hodapp wrote:
> Marked this bug as incomplete. If anybody sees this issue with OTA-12
> and can reliably reproduce the issue, we'll reopen this bug.
>

Anupam (anupam207) wrote :

I'm having this issue as frequently as before even after OTA-12, but I couldn't find steps to reproduce the issue reliably. What happens is usually after 1-2 days after a reboot, this issue appears out of nowhere. Also deleting ubuntu-phablet-stream-volumes.tdb file is redundant, a reboot only makes things normal again.

@John, @Anupam: could you try to follow steps described by Alfonso in comment #82? I would also try to enable pulseaudio logging.

How to enable pulseaudio logging (looks like wiki instructions don't work for Ubuntu Touch, IIRC these are the right steps):
- set device to writable mode
As root:
- create backup file: cp /usr/share/upstart/sessions/pulseaudio.conf /usr/share/upstart/sessions/pulseaudio.conf.bkp
- edit in file /usr/share/upstart/sessions/pulseaudio.conf
  line:
      exec pulseaudio --start
  to:
      exec pulseaudio -vvvv --start --log-target=newfile:/tmp/pulseverbose.log --log-time=1
- restart device

Please do not restart your phone after you reproduce the issue or log files will be lost (copy them in another directory first so you can upload them later)

(from wiki) The log files are in the /tmp directory. You might see more than one file (pulseverbose.log, pulseverbose.log.1, pulseverbose.log.2, etc). In case you don't know which file is the right one, please attach all files to the launchpad bug.

1 comments hidden view all 124 comments
John (john-a-barnes) wrote :

I'd like to help but I really don't know anything about delving into the
phone software at present I am just using it as a phone with browser
access.

I have not dared set it to writeable mode (which I assume is Developer
Mode) I don't know how to access root on it, also the chances of me
typing those strings accurately on the touch keyboard are not high. Or
can I access it via my computer if I go to Developer Mode? I can't see
the directories you mention. Wrong place for these questions. Is there
an idiots guide somewhere?

On 18/08/16 17:46, Devid Antonio Filoni wrote:
> @John, @Anupam: could you try to follow steps described by Alfonso in
> comment #82? I would also try to enable pulseaudio logging.
>
>
> How to enable pulseaudio logging (looks like wiki instructions don't work for Ubuntu Touch, IIRC these are the right steps):
> - set device to writable mode
> As root:
> - create backup file: cp /usr/share/upstart/sessions/pulseaudio.conf /usr/share/upstart/sessions/pulseaudio.conf.bkp
> - edit in file /usr/share/upstart/sessions/pulseaudio.conf
> line:
> exec pulseaudio --start
> to:
> exec pulseaudio -vvvv --start --log-target=newfile:/tmp/pulseverbose.log --log-time=1
> - restart device
>
> Please do not restart your phone after you reproduce the issue or log
> files will be lost (copy them in another directory first so you can
> upload them later)
>
> (from wiki) The log files are in the /tmp directory. You might see more
> than one file (pulseverbose.log, pulseverbose.log.1, pulseverbose.log.2,
> etc). In case you don't know which file is the right one, please attach
> all files to the launchpad bug.
>

Michal Predotka (mpredotka) wrote :

I was happy to early 😊 The bug just happened to me. Log as instructed in comment #82 attached

1 comments hidden view all 124 comments
Jim Hodapp (jhodapp) wrote :

@Michal: can you reproduce it reliably? What were you doing when you noticed it wasn't working? Are Telegram notifications working for you right now? How about alarms in the clock app? Can you play music from the music-app?

Michal Predotka (mpredotka) wrote :

I've noticed the green led when I took the phone out of my pocket. I didn't hear the sound but wasn't sure if that's due to the bug or because I was in noisy surroundings. I asked someone to send me a message to check if this is due to the bug and the message arrived without the sound notification.
Few hours before I was listening to a podcast using Podbird app. Not sure if that could be related as I every day without issues since OTA-12.

Telegram notifications work fine with the sound. Music app plays songs fine. I can hear alarms in the clock app too. Screenshots, on the other hand, _do not_ make a sound.

Jim Hodapp (jhodapp) wrote :

@Michal: which device are you using?

Michal Predotka (mpredotka) wrote :

bq e4.5 OTA-12

Anupam (anupam207) wrote :

@Michal Looks like you just jinxed it (by your comment #83)! 😉

@mpredotka thanks for the logs, will be useful.

GTriderXC (gtriderxc) wrote :

I haven't rebooted my bq 4.5 yet if anyone has any more questions so the bug is still active on my phone with OTA-12. As I wrote several times this bug has nothing to do with anything: not a music player, not a game, it just comes out of the sky as many things in this phone. You will not reproduce it after reboot. The only possibility that comes to my mind is that sound disappears after becoming some count of messages or after a certain uptime of the device.

As I wrote above the phone can be as overloaded that You won't be able to start any app but the sms sound work. On the other way, You can leave Your phone untouched after reboot for a several days and suddenly the green lamp starts to blink with no sound.

Anupam (anupam207) wrote :

I concur with @GTriderXC. Exactly the same behaviour! Many times I leave my phone untouched except a few calls, Telegram messages, and casual web-browsing sessions (can't avoid these, as I mentioned before this phone is my daily driver), but then 1-2 days later again the same no-SMS-sound-issue. I really hope fixes for bug #1506953 and bug #1596329 get rid of this nuisance.

Jim Hodapp (jhodapp) wrote :

@Anupam: with OTA-12 you already have the fix for bug #1596329. The other one will come with OTA-13. Until we know what the cause is though, which many people have been trying to identify, it'll be very difficult to make sure that it's fixed. I appreciate your patience as we try and figure this out though.

GTriderXC (gtriderxc) wrote :

Since a few days a Clock app (which I open everyday to set an alarm clock) needed to open itself something like 15 seconds so I decided to reboot the phone today. It helped. Also Sms sounds >were< :-) back. I killed them in something like 5-10 minutes. How: I used the phone with intensity of a whole week: received many messages, answered a phone call, listened to the radio, launched a movie, played a game, opened as many apps as possible and suddenly a sms message came without a sound. I reboot the phone again and perhaps it happens again. I attached a log file but I'm not sure if it is the one You need. The operation described in #82 perhaps succeeded but I can't find a tar file on the phone. Is there any possibility to browse root catalogues from a pc?

I was able to reproduce this finally. It is a matter of killing media-hub-server:

pkill -9 media-hub

(this has the same effect as a media-hub-server crash).

media-hub-server re-starts, but it looks like not all the system recovers and re-connects to dbus-interface. Voice calls ringing, telegram notifications and videos/music still sound, but SMS notifications and screenshots do not emit sound anymore.

So we have here:

* A media-hub-server crash (could somebody please check if they have crash files for media-hub-server in /var/crash?)

* An issue with reconnections to media-hub, for:
1. SMS notifications. telephony-service-indicator is the responsible for them
2. Screenshot sound. unity8 is the one emitting it

Recently there was an effort to make media-hub *client library* resilient to media-hub-server crashes, but it looks like that has not been enough for this case. However, I am not sure if we can completely restore transparently from the library or we need that indicator/unity8 to be ready for media-hub crashes and be able to re-connect.

Changed in media-hub (Ubuntu):
status: Incomplete → Confirmed

Note on comment #101: I have checked that the issue happens for both OTA12 and rc-proposed/bq-aquaris.en image #412, for BQ Aquaris 4.5

Jim Hodapp (jhodapp) wrote :

@Alfonso: well it is *a* cause but not necessarily all causes. I knew that this was reproducible if you killed media-hub-server or it crashed on its own and I did take care of several cases of unhandled exceptions that would cause media-hub-server to crash. Having said that, ahayzen is working on a QML wrapper that will automatically restore a new Player connection to media-hub-server after it has restarted along with some basic state such as the Playlist items. We might be able to create a similar thing in C++ that wraps QMediaPlayer so that it could be used by all platform supported playback sessions. Doing the restoration from qtubuntu-media just wasn't really possible given how QtMultimedia is written.

GTriderXC (gtriderxc) wrote :

@Alfonso, i have a media-hub-server crash file.

http://paste.ubuntu.com/23079628/

GTriderXC (gtriderxc) wrote :

I pasted a wrong link sorry but at the moment i have no time to find out how to copy the crash file not through a terminal. I asked for help in my last post but no response. I can provide you more info if You want if you help me to do it through a pc.

@GTriderXC, the easiest thing would be to enable developer mode and grab the crash file from a PC:

adb pull /var/crash/<media-hub crash file>

then you can upload to the bug.

GTriderXC (gtriderxc) wrote :
Changed in telephony-service (Ubuntu):
status: New → Confirmed
Changed in media-hub (Ubuntu):
status: Confirmed → Incomplete
Changed in unity8 (Ubuntu):
status: Incomplete → Confirmed
Changed in telephony-service (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Incomplete → In Progress
milestone: backlog → 13
Changed in telephony-service (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)

Branchs linked for telephony-service and unity8, which will solve this in case media-hub restarts.

@gtriderxc, thanks for the crash file, but unfortunately it misses the CoreDump field for some reason, not sure why yet.

Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Jim Hodapp (jhodapp) wrote :

Added qtmultimedia to the affected list to capture future effort to more permanently fix this bug. Recovery after a media-hub-server crash really belongs in qtmultimedia so that every supported client is able to continue playback even after a media-hub-server crash.

Changed in telephony-service (Ubuntu):
status: In Progress → Fix Committed
Changed in unity8 (Ubuntu):
status: In Progress → Fix Committed
Changed in qtmultimedia-opensource-src (Ubuntu):
status: New → Confirmed
Changed in telephony-service (Ubuntu):
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in qtmultimedia-opensource-src (Ubuntu):
importance: Undecided → High
Changed in indicator-sound (Ubuntu):
status: Incomplete → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.14+16.10.20160826-0ubuntu1

---------------
unity8 (8.14+16.10.20160826-0ubuntu1) yakkety; urgency=medium

  * Make sure we emit sounds when taking a screenshot even after media-
    hub (LP: #1544477)

 -- Alfonso Sanchez-Beato <email address hidden> Fri, 26 Aug 2016 08:14:14 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

@jibel we are fighting in the status :)
I think this is stuck in https://requests.ci-train.ubuntu.com/#/silo/098
The fix is not released to telephony service

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telephony-service - 0.1+16.10.20160909.1-0ubuntu1

---------------
telephony-service (0.1+16.10.20160909.1-0ubuntu1) yakkety; urgency=medium

  [ Tiago Salem Herrmann ]
  * Fix test failure with new libphonenumber release.
  * Move telepathy-ofono from "Depends" to "Suggests".

 -- Gustavo Pichorim Boiko <email address hidden> Fri, 09 Sep 2016 14:54:02 +0000

Changed in telephony-service (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
GTriderXC (gtriderxc) wrote :

So... the first step made. Now the second one please cause without fixing this bug:

https://bugs.launchpad.net/canonical-devices-system-image/+bug/1579570

all effort is in vain. I still can't hear anything.

GTriderXC (gtriderxc) wrote :

Sorry to say that guys, but... my phone (E4.5 under OTA13) doesn't give a sound any more. Do You want to see any logs before I reboot it?

GTriderXC (gtriderxc) wrote :
Marek Greško (mgresko8) wrote :

Not sure whether it is same bug, but today there was no ringing on incoming call. Just only seen incoming call on a display. BQ E4.5 with OTA13.

Anupam (anupam207) wrote :

@Marek that's bug #1612367

Jimbo G (jamespgilbert) wrote :

This bug still very much exists for me (E4.5, OTA 13) - with the added problem that I don't even get a vibration alert or the flashing green LED to let me know that an SMS has been received.

The phone remains totally silent until I press a button to unlock it, at which point it vibrates, plays the sound alert and the green LED starts flashing.

This happens even if I received the SMS several hours earlier and is making my life difficult.

Anupam (anupam207) wrote :

@Jimbo That's a separate issue I believe. See bug #1516696, a fix should arrive with OTA-14.

Anupam (anupam207) wrote :

I haven't experienced this issue after OTA-13 for a single time (Although I usually reboot my phone after 3-4 days for other things).

GTriderXC (gtriderxc) wrote :

@ Anupam
What I complained about at #114 happened to me only once or twice under OTA-13. I almost do not reboot my phone at all: for example my uptime at the moment is 9 days. I think the essence of this bug was fixed in OTA-13 and the whole bug can be closed and marked as fixed. If it happens that someone doesn't get a notification it seems to be a single time issue as many in Ubuntu that happen from time to time.

Jim Hodapp (jhodapp) wrote :

Reply back here if anything like this comes up again and we can discuss re-opening this bug.

Changed in media-hub (Ubuntu):
status: Incomplete → Invalid
Changed in pulseaudio (Ubuntu):
status: Incomplete → Invalid
Changed in qtmultimedia-opensource-src (Ubuntu):
status: Confirmed → Invalid
GTriderXC (gtriderxc) wrote :

Now this one please, cause we still can't hear anything:

https://bugs.launchpad.net/canonical-devices-system-image/+bug/1579570

Displaying first 40 and last 40 comments. View all 124 comments or add a comment.