/usr/bin/media-hub-server:6:__gnu_cxx::__verbose_terminate_handler:__cxxabiv1::__terminate:std::terminate:__cxxabiv1::__cxa_throw:core::ubuntu::media::HashedKeyedPlayerStore::player_for_key

Bug #1479036 reported by errors.ubuntu.com bug bridge on 2015-07-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
John McAleely
media-hub (Ubuntu)
Critical
Jim Hodapp
Nominated for Vivid by Alberto Salvia Novella
Nominated for Wily by Alberto Salvia Novella
media-hub (Ubuntu RTM)
Critical
Jim Hodapp

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding media-hub. This problem was most recently seen with version 3.1.0+15.10.20150522-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/9269cb1b44903be3d79848ebfcd6896556cceba9 contains more details.

Related branches

Jean-Baptiste Lallement (jibel) wrote :

Top 10 of crashes on meizu.en.

Changed in media-hub (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → John McAleely (john.mcaleely)
milestone: none → ww40-2015
Changed in media-hub:
status: New → Confirmed
Changed in media-hub (Ubuntu):
status: Confirmed → Triaged
Jim Hodapp (jhodapp) wrote :

Marking as confirmed only since I haven't had a chance at reproducing this issue yet.

Changed in media-hub (Ubuntu):
status: Triaged → Confirmed
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in media-hub (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
Jean-Baptiste Lallement (jibel) wrote :

This crash happened again to me during the week end which resulted in a hang of the system when I took a screenshot (bug 1508830)

Jim Hodapp (jhodapp) on 2015-11-09
no longer affects: media-hub
Changed in media-hub (Ubuntu RTM):
importance: Undecided → Critical
assignee: nobody → Jim Hodapp (jhodapp)
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Jim Hodapp (jhodapp) on 2015-12-16
Changed in media-hub (Ubuntu RTM):
status: New → Confirmed
Jim Hodapp (jhodapp) on 2015-12-17
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in media-hub (Ubuntu RTM):
status: Confirmed → In Progress
Jim Hodapp (jhodapp) on 2015-12-17
Changed in media-hub (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Committed
Changed in media-hub (Ubuntu RTM):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package media-hub 4.0.0+15.04.20151218-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

media-hub (4.0.0+15.04.20151218-0ubuntu1) vivid; urgency=medium

  * Fix bug #1479036 which prevents the out_of_range exception from
    causing media-hub-server from crashing when a player key is not
    found (LP: #1479036)

 -- Jim Hodapp <email address hidden> Fri, 18 Dec 2015 18:11:24 +0000

Changed in media-hub (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package media-hub - 4.1.0+16.04.20160104-0ubuntu1

---------------
media-hub (4.1.0+16.04.20160104-0ubuntu1) xenial; urgency=medium

  * Enable dual landings.

media-hub (4.1.0+16.04.20151221-0ubuntu1) xenial; urgency=medium

  * Fix bug #1479036 which prevents the out_of_range exception from
    causing media-hub-server from crashing when a player key is not
    found (LP: #1479036)

 -- Thomas Voß <email address hidden> Mon, 04 Jan 2016 08:30:37 +0000

Changed in media-hub (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers