Meanwhile user status detection broken

Bug #264752 reported by Eberhard Beilharz on 2008-09-04
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
meanwhile (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Eberhard Beilharz
Nominated for Intrepid by Eberhard Beilharz

Bug Description

Binary package hint: libmeanwhile1

The meanwhile plugin of Pidgin doesn't report the status of users correctly if the users have logged in before Pidgin was started (http://developer.pidgin.im/ticket/58). This has been fixed in Meanwhile 1.1.0 CVS branch.

Ubuntu should deliver a patched version of libmeanwhile that fixes this problem.

Environment:
Ubuntu 8.04.1
libmeanwhile1 1.0.2-3

description: updated
Changed in pidgin:
status: Unknown → Fix Released

This bug is still present in jaunty, karmic, lucid. It is also present in the corresponding Debian package.

The upstream bug is here:
http://sourceforge.net/tracker/index.php?func=detail&aid=1626349&group_id=110565&atid=656718

Changed in pidgin:
status: Fix Released → Unknown
Changed in pidgin:
status: Unknown → New
EclipseAgent (ben-kevan) wrote :

Come on guys.. seriously? Can't we get this fixed? It's fixed in openSUSE.

Attached it the patch for openSUSE.. Please can we get this fixed. This is a widely used enterprise application and having core functionality like this not working is unacceptable.

PLEASE can we get it resolved.

Changed in meanwhile (Ubuntu):
status: New → Confirmed
Iker Ramos Bilbao (ikerramos) wrote :

Could you include the presence patch, is working fine in natty as well.

http://www.lilotux.net/~mikael/pub/meanwhile/

Gbillou (gbillou) wrote :

Fixed in fedora, gentoo, even in windows.. What are you waiting to release this 1.1 version? or at least a patched 1.0.2 version (seems not logical to me, but would be better than nothing)?
It has been patched 2years1/2 ago!
https://bugzilla.redhat.com/show_bug.cgi?id=471489
https://bugs.gentoo.org/attachment.cgi?id=201611
http://developer.pidgin.im/ticket/58

Eugene Crosser (crosser) wrote :

This is also reported as Pidgin bug #272108
The problem still exists as of oneiric.
Can the patch attached to this ticket be included into the release please?

Eric Covener (covener) wrote :

FWIW, I needed just the patch from http://sourceforge.net/tracker/?func=detail&aid=1626349&group_id=110565&atid=656718 to resolve my status issue.

Changed in pidgin:
status: New → Fix Released
Matthias Klose (doko) on 2016-01-28
Changed in meanwhile (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.