me-tv-client doesn't interrupt screensaver

Bug #983673 reported by 8200 on 2012-04-17
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Me TV
Undecided
Unassigned
me-tv (Ubuntu)
Undecided
Unassigned

Bug Description

Hey,

I have now upgraded to the latest Me-Tv (1.4.0.6) at ubuntu 10.04 amd64.

When I watch TV with the me-tv-client the screensaver turns on after 5 minutes.

I think this is a bug because the screensaver should not turn on during watching me-tv-client in fullscreen-mode.

Regards,
Arthur

Related branches

Hi,

This is a known bug. Right now I don't have time to put on that. I'll look
into it as soon as I have spare time.

Cheers,
Frederic

On Tue, Apr 17, 2012 at 1:34 AM, 8200 <email address hidden> wrote:

> Public bug reported:
>
> Hey,
>
>
> I have now upgraded to the latest Me-Tv (1.4.0.6) at ubuntu 10.04 amd64.
>
>
> When I watch TV with the me-tv-client the screensaver turns on after 5
> minutes.
>
> I think this is a bug because the screensaver should not turn on during
> watching me-tv-client in fullscreen-mode.
>
>
> Regards,
> Arthur
>
> ** Affects: me-tv (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Me TV
> Development, which is subscribed to me-tv in Ubuntu.
> https://bugs.launchpad.net/bugs/983673
>
> Title:
> me-tv-client doesn't interrupt screensaver
>
> Status in “me-tv” package in Ubuntu:
> New
>
> Bug description:
> Hey,
>
>
> I have now upgraded to the latest Me-Tv (1.4.0.6) at ubuntu 10.04 amd64.
>
>
> When I watch TV with the me-tv-client the screensaver turns on after 5
> minutes.
>
> I think this is a bug because the screensaver should not turn on
> during watching me-tv-client in fullscreen-mode.
>
>
> Regards,
> Arthur
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/me-tv/+bug/983673/+subscriptions
>

--
"In a world without walls, who really needs Windows"
"Nothing is foolproof because fools are so ingenious"

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in me-tv (Ubuntu):
status: New → Confirmed
Daniel (hackie) wrote :

Same problem here: me-tv 1.4.0.10 (about dialog)=1.4.0-0~39~precise1 (deb package from ppa) under xubuntu (Ubuntu 12.04.1 LTS)

I think it's important to mention there are two other bug reports: Bug 459337 looks like a duplicate to this, but it is marked as a duplicate to Bug 428884 which seems to be too specific to gnome

fabioamd87 (fabioamd87) wrote :

same problem on ArchLinux with Me TV 1.4.0.12

Changed in me-tv:
status: New → In Progress
Vladyslav Shtabovenko (vl-sht) wrote :

I guess for Gnome 3 this should be relatively easy to implement via org.gnome.SessionManager->Inhibit. For Unity there is surely something in com.canonical.Unity.*. that can be revealed via d-feet.

instead of just implementing different calls ,.. it might be best to use

org.freedesktop.Screensaver dbus object

see http://foss-boss.blogspot.co.at/2008/11/ride-d-bus-control-your-linux-desktop.html for some details
also
http://lists.freedesktop.org/archives/xdg/2007-March/009187.html

maybe i'll write some code if i get a chance, but i'm not sure where in me-tv code this should go

Vladyslav Shtabovenko (vl-sht) wrote :

Good point.

According to comment 40 in
https://trac.videolan.org/vlc/ticket/4739
at least for Gnome org.freedesktop.ScreenSaver.Inhibit is a proxy org.gnome.SessionManager.Inhibit.

I guess it should be similar for KDE. What about Unity?

Russel Winder (russel) wrote :

I am working with a fork of the 1.3.7 codebase. The current code for attempting to inhibit screen save/screen lock is some low level dbus C code. I am looking to replace this with C++ Gio::DBus code given this is supposed to be a C++ application :-)

I am using GNOME Shell so the current org.gnome.ScreenSaver code is basically a no-op, even using the more general org.freedesktop.ScreenSaver. I am experimenting with org.gnome.SessionManager.Inhibit just now. I have no way of working on Ubuntu or any other system so someone else will have to drive experiments on those platforms.

Russel Winder (russel) wrote :

Calling org.gnome.SessionManager.Inhibit on org.gnome.SessionManager does indeed appear to stop the locking screen appearing on GNOME3 with GNOME Shell.

Christian (chk2k2) wrote :

tested with Kubuntu 14.04.2

Changed in me-tv:
status: In Progress → Fix Committed
Christian (chk2k2) on 2015-04-11
Changed in me-tv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.