Ubuntu

me-tv hangs during initialisation.

Reported by BertN45 on 2012-03-18
210
This bug affects 40 people
Affects Status Importance Assigned to Milestone
me-tv (Debian)
Fix Released
Unknown
me-tv (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

see next log from terminal. Note that there seems to be a problem with the database version.

bertadmin@Dell-Ubuntu:~$ me-tv -v -s
Me TV 1.3.6
03/18/2012 15:26:39: Application constructor
03/18/2012 15:26:39: sqlite3_threadsafe() = 1
03/18/2012 15:26:39: Database 'exists'
03/18/2012 15:26:39: Opening database file '/home/bertadmin/.local/share/me-tv/me-tv.db'
03/18/2012 15:26:39: Loading UI files
03/18/2012 15:26:40: Application constructed
03/18/2012 15:26:40: Initialising table 'version'
03/18/2012 15:26:40: Required Database version: 6
03/18/2012 15:26:40: Actual Database version: 0
03/18/2012 15:26:44: Dropping Me TV schema
03/18/2012 15:26:44: Dropping table 'channel'
03/18/2012 15:26:44: Dropping table 'epg_event'
03/18/2012 15:26:44: Dropping table 'epg_event_text'
03/18/2012 15:26:44: Dropping table 'scheduled_recording'
03/18/2012 15:26:44: Dropping table 'version'
03/18/2012 15:26:45: Vacuuming database
03/18/2012 15:26:45: Initialising table 'channel'
03/18/2012 15:26:45: Initialising table 'epg_event'
03/18/2012 15:26:45: Initialising table 'epg_event_text'
03/18/2012 15:26:45: Initialising table 'scheduled_recording'
03/18/2012 15:26:45: Initialising table 'version'

This is the point where the programs simply hangs.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11

[Impact]
Application is completely unusable.

[Test Case]
Make sure the following works and the user interface doesn't freeze:
Lauch me-tv, setup channels, restart me-tv.
Check that the channels are still there.

BertN45 (lammert-nijhof) wrote :
BertN45 (lammert-nijhof) wrote :

Exactly the same problem occurs on my P-IV 32-bit Ubuntu 12.04 desktop. as on my AMD 64-bit Ubuntu 12.04 desktop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in me-tv (Ubuntu):
status: New → Confirmed

I found the problem. I'll fix it in version 1.3.7 as soon as I have time.

This bug is probably fix (need testing) in version 1.4.0 from PPA

Changed in me-tv (Ubuntu):
assignee: nobody → Frédéric Côté (frederic-cote)
Russel Winder (russel) wrote :

I can confirm that lp:me-tv when compiled works fine as long as you delete ~/.local/share/me-tv/me-tv.db first and recreate all the channel information. I am having a small difficulty with the fact that the channel list generated during GNOME DVB setup appears not to be a well-formed XML document.

Timo Jyrinki (timo-jyrinki) wrote :

I encountered this as well. It'd be nice to have the fixed version (1.3.7) in 12.04 proper. If you're very quick, see https://lists.ubuntu.com/archives/ubuntu-devel/2012-April/035116.html ("Unseeded universe needs *you*"), and otherwise https://wiki.ubuntu.com/MOTU/Teams/SRU for a stable release update.

The version 1.3.7 is ready in launchpad but I didn't updated the package in the "universe" (main repository).

I'll do that as soon as I have some spare time.

Cheers,
Frederic

Changed in me-tv (Ubuntu):
status: Confirmed → Fix Committed
Micah Gersten (micahg) on 2012-04-26
tags: added: regression-release
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in me-tv (Ubuntu Precise):
status: New → Confirmed
CoudCoud (coudertmatthieu) wrote :

I installed the ppa version (sudo add-apt-repository ppa:me-tv-development/ppa).
It works for me.
If you want to launch it on a terminal, the command became "me-tv-client" instead of "me-tv".
The main problem I found with this version is you can't change the channels' order.
But it can be a temporary workaround.

On 29/04/2012 17:40, CoudCoud wrote:
> I installed the ppa version (sudo add-apt-repository ppa:me-tv-development/ppa).
> It works for me.
> If you want to launch it on a terminal, the command became "me-tv-client" instead of "me-tv".
> The main problem I found with this version is you can't change the channels' order.
> But it can be a temporary workaround.
>
Thanks for the suggestion.
At the moment I am using Windows as a dual boot with Ubuntu so at least
I can get use from the TV card on my computer. I like Ubuntu and Linux
but when it comes to hardware I have experienced a number of problems
and many problems seem to occur when the version number is changed.
Things that previously worked work no longer and sometimes things that
refused to work begin to work. In this case I wish that the old adage of
"If it ain't broke don't fix it" had been applied. As long as this sort
of thing happens very few people will have the confidence to rely on
Linux alone
But again thanks for your time it is appreciated
Alan Smith

lionslair (nathan-lionslair) wrote :

I have the same issue. I can start the program and TV plays but then immediately it is crashed however it keeps playing live tv. Resizing the window leaves the TV at the same size. Cant change channel or see the EPG. All menus are unresponsive. Trying to do anything with the TV just brings up the force close dialogue.

Worked 100% before I did the 12.04 upgrade. I am not sure if it is related but with the TV running it also causes the desktop / session (sorry trying to describe best I can ) to be automatically logged out. As if maybe a X-reboot has occurred. I am login and have to open up mail client and browser and TV (if I was watching) again. So its not a locked desktop / session it logs me out.

Changed in me-tv (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in me-tv (Ubuntu Precise):
status: Fix Committed → Fix Released
Alex Tasin (alextasin) wrote :

the bug still exist, the version in repository is 1.3.6

bluesky (f-a-b-i-o-99) wrote :

Bug still present in Precise. Why the new package doesn't get released?

Because I don't know how... and I'm very busy.

Timo Jyrinki (timo-jyrinki) wrote :

The needed things are listed in the "Notes for Contributors" at https://wiki.ubuntu.com/MOTU/Sponsorship/SponsorsQueue while the process to follow otherwise is https://wiki.ubuntu.com/StableReleaseUpdates

It among else states that the fixed version should be in the development release before SRU. I don't have upload rights to Ubuntu, but I do have to Debian via which 1.3.7 would reach Ubuntu 12.10 currently as well. I can poke first the maintainer of me-tv in Debian.

Meanwhile, would someone care to follow the StableReleaseUpdates page and update this bug's description as instructed in the "Update the bug report description and make sure it contains the following information:"? ie. add all the sections.

Changed in me-tv (Debian):
status: Unknown → New
Felix Geyer (debfx) on 2012-06-02
Changed in me-tv (Ubuntu Precise):
status: Fix Released → Triaged
Changed in me-tv (Ubuntu Quantal):
status: Fix Committed → Triaged
assignee: Frédéric Côté (frederic-cote) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package me-tv - 1.3.6-1ubuntu1

---------------
me-tv (1.3.6-1ubuntu1) quantal; urgency=low

  * Fix user interface freezing on startup. (LP: #958751)
    - Add fix_ui_freeze.diff, cherry-picked from upstream.
 -- Felix Geyer <email address hidden> Sat, 02 Jun 2012 09:48:12 +0200

Changed in me-tv (Ubuntu Quantal):
status: Triaged → Fix Released
Felix Geyer (debfx) wrote :

Uploaded to precise-proposed, waiting for approval.

description: updated
Russel Winder (russel) wrote :

Does the fix go to Debian as well as Ubuntu? I mention this as the Debian freeze for the next release is in about 2 weeks so it would be good to get a new package in sooner rather than later.

Felix Geyer (debfx) wrote :

Yes, there is a non-maintianer upload in the Debian delayed queue.

Timo Jyrinki (timo-jyrinki) wrote :

I uploaded the 1.3.7 release to Debian (in DELAYED/5). It's essentially the same but with additional translation updates.

Changed in me-tv (Debian):
status: New → Fix Released
Russel Winder (russel) wrote :

1.3.7 made it to Debian Unstable this afternoon, hopefully it gets into Debian Testing before the freeze!

Hello BertN45, or anyone else affected,

Accepted me-tv into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in me-tv (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Daniel Schürmann (daschuer) wrote :

Hello
I have tested the
me-tv_1.3.6 -1ubuntu0.1_i386.deb
and a source build from
me-tv-1.3.7.tar.gz
on Preciese.

Both are still effected by this bug.
The Gui is still not usable after start, sometimes.
But TV is playing (allways)

Somtimes the Gui works after start but get staled leater.
The over all GUI performance is alway worth at any time compared to ubuntu Oneiric.

Agent24 (tda7000) wrote :

Just tried 1.3.6 on a fresh install of Ubuntu 12.04 LTS

On first start, I get no GUI or anything, but the me-tv process is running in the background somewhere. I have to kill it manually.

When I start again, it complains that the database is an old incompatible version. If I tell it to delete the database, it freezes up and I have to kill it manually.

When is version 1.3.7 coming?

Felix Geyer (debfx) wrote :

Which version of me-tv have you installed? 1.3.6-1 or 1.3.6-1ubuntu0.1?

1.3.6-1ubuntu0.1 is basically identical to 1.3.7 except for translation updates.

I have the same problem of Agent24. Installed 1.3.6-1, so I think that's the problem. Is it possible to just install this package from proposed without activating all the proposed packages? Thanks...

Daniel Schürmann (daschuer) wrote :

I have tested a littel more with me-tv-1.3.7.tar.gz

Creating a fresh database did not solve the issue.

me-tv --disable-epg-thread
.. solves the issue, except that the channel puttes are blank and apearing about 1 minute after start.
When pressing "Jetzt" (Now) the buttons apears instantly.

By the way, is it possible to have the EPG Table alwas visible?
Or restore the last EPG position?

Alessio (alessio) wrote :

I updated to the version 1.3.6-1ubuntu0.1 on proposed repository, I also deleted me-tv.db file and rebuild channels list
now me-tv is usable, but it suffers of temporary lockups about every 3-10 minutes with high disk usage, during the lockups seems me-tv rebuild the me-tv.db file (on ~/.local/me-tv/ appears a file named me-tv.db-journal)

T. K. (stuttgart-live) wrote :

Can someone please release this fix for Precise? Thank you!

Daniel Schürmann (daschuer) wrote :

It seems the the current version in lp:me-tv/1.3 (1.3.8) solves the issue with the stalled GUI.
It works for me since two days without --disable-epg-thread.
I have successful build it with the instructions from
https://answers.launchpad.net/me-tv/+faq/352
using bzr branche lp:me-tv/1.3

Felix Geyer (debfx) on 2012-06-17
tags: added: verification-done
removed: verification-needed
Felix Geyer (debfx) on 2012-06-17
tags: added: verification-needed
removed: verification-done
Timo Jyrinki (timo-jyrinki) wrote :

FYI I uploaded 1.3.7-0.2 to Debian which has the "1.3.8" patch (one commit) included for the EPG problems. It should find its way to quantal in 24h or so since the Debian auto-sync is still in effect.

Brian Murray (brian-murray) wrote :

Hello BertN45, or anyone else affected,

Accepted me-tv into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/me-tv/1.3.6-1ubuntu0.2 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steffen Krumbholz (skrumbholz) wrote :

Hi,
installed the proposed package me-tv 1.3.6-1ubuntu0.2 and everything (start application, switching channels, epg, options window, quit application) works fine for me. It runs with no problems for over three hours now. \o/
Thank you.

Steffen Krumbholz (skrumbholz) wrote :

Sorry. I forgot to mention I'm running Ubuntu 12.04 (precise).

Steffen Krumbholz (skrumbholz) wrote :

...and here is my logfile (me-tv --verbose). Started me-tv, switched channels, quitted the application.

Felix Geyer (debfx) on 2012-06-29
tags: added: verification-done
removed: verification-needed

Bug #1005099
Bug #996684
Bug #958751
seem to relate to the same issue

I also used the proposed 0.2 32 bit binary and this fixed the Ubuntu 12.04 (precise) problem

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package me-tv - 1.3.6-1ubuntu0.2

---------------
me-tv (1.3.6-1ubuntu0.2) precise-proposed; urgency=low

  * Fix EPG thread related hangs.
    - Add fix_database_access_problem.diff, cherry-picked from upstream.

me-tv (1.3.6-1ubuntu0.1) precise-proposed; urgency=low

  * Fix user interface freezing on startup. (LP: #958751)
    - Add fix_ui_freeze.diff, cherry-picked from upstream.
 -- Felix Geyer <email address hidden> Sun, 24 Jun 2012 16:51:30 +0200

Changed in me-tv (Ubuntu Precise):
status: Fix Committed → Fix Released
no longer affects: me-tv
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.