existing RAID partitions not recognized by mdcfg

Bug #95987 reported by giuseppe on 2007-03-25
4
Affects Status Importance Assigned to Milestone
mdcfg (Ubuntu)
Medium
Unassigned
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

Binary package hint: mdcfg

using kubuntu 7.04 beta alternate CD:
I have three pre-existing RAID devices (created during a previous installation with the same CD)
each one a RAID 1 array of two disks.

When rebooting from CD to do a fresh install, the arrays are recognized during the partitioning task, but when trying to use them, the installation fails with message "cannot stat device /dev/md/2" (notice a slash before the digit. The correct name is /dev/md2).

How to repeat:

1) Using the alternate CD, create three arrays md1, md2, md3, mounted to "/", "/home" and "swap".
2) Finish the installation
3) check that the installation works
4) restart with the same CD in expert mode
5) accept defaults until "load installer components from cd"
6) load the "mdcfg" component
7) accept defaults until "partition disks"
8) within "partition disks", choose "manual"
9) the disks are recognized as "K raid". Select "configure software RAID"
10) when asked if you want to keep the current partition layout and configure RAID, say "yes"
11) after this, you can create a new RAID device, delete and existing one, or finish.
11a) choosing "create a new device" you are informed that no free partitions exist, meaning that the existing layout was recognized. You can use a separate console to verify this with mdadm -D /dev/md0 /dev/md1 /dev/md2
11b) choosing "finish" should then use the existing devices. But you get the "cannot stat device /dev/md/2" error

After this error shows up, any further operation results in the same error, and the installation cannot proceed.

Rod Roark (rod) wrote :

Similar experiences here. I had filled a pair of 320GB SATA drives with 5 RAID 1 partitions during an Ubuntu 6.10 install (ia32), then went to install 7.04 AMD64 Beta as an alternate boot option. When the partitioner loaded I selected manual partitioning.

At this point it would show only the physical RAID volumes, not the md* partitions. Selecting "Configure Software RAID" didn't seem to do anything interesting. Then selecting "Finish" produced "Could not stat device /dev/md/4 - No such file or directory.". That was with a plain text install, and as I recall it was the same if I chose an Expert install and loaded mdcfg, or if I tried to install the 32-bit beta.

It seems software raid is removed from desktop version and is only left for servers. Which is a pity,

Changed in mdcfg:
importance: Undecided → Medium
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers