Missing added utility 'mdmon'

Bug #957494 reported by Clint Byrum on 2012-03-16
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Medium
Dimitri John Ledkov
Precise
Medium
Dimitri John Ledkov
Quantal
Medium
Dimitri John Ledkov

Bug Description

[IMPACT]

 * Users cannot use mdmon - monitor MD external metadata arrays

 * Thus users cannot use Common raid Disk Data Format (DDF) and Intel Matrix RAID formats

 * This is hardware enableblement

 * This utility was excluded from installation into the deb package, which is now fixed in the packaging.

[TESTCASE]

 * $ which mdmon
 * Upgrade the package
 * $ which mdmon
   /sbin/mdmon

[Regression Potential]

 * Minimal, the utility was not previously shipped in Ubuntu, but was shipped in Debian

Related branches

John Center (john-center) wrote :

mdmon & its man page are included with the Oneiric mdadm package. It's only missing in the Precise package. Note that the mdmon page is missing from the online manpages, see http://manpages.ubuntu.com/manpages/precise/man8/mdmon.8.html.

Phillip Susi (psusi) wrote :

No, it isn't in the Oneiric package either. This new binary is required for using external metadata formats, including intel matrix raid, and DDF. The fact that it is missing appears to trigger a kernel OOPS with these formats.

Changed in mdadm (Ubuntu):
importance: Wishlist → Medium
status: Confirmed → Triaged
Phillip Susi (psusi) wrote :

It does appear to be in the debian package, so it appears the last merge from debian was messed up.

John Center (john-center) wrote :

You're right, I could have sworn that it was part of that package. I didn't have the "read-only" problem with 3.1.4, could it have been that mdmon wasn't needed in that version?

tags: added: rls-mgr-p-tracking
Changed in mdadm (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Phillip Susi (psusi) wrote :

Are you using mdadm to activate a DDF or intel array? Normally dmraid handles those.

Clint Byrum (clint-fewbar) wrote :

We have not shipped mdmon since intrepid from what I can tell. At that time, the blanket 'make install' was replaced with explicit installations of just mdadm into /sbin.

I'm looking at what effect putting the full 'make install' back will have.

John Center (john-center) wrote :

I'm using mdadm to activate an Intel array. Dmraid is disabled.

Phillip Susi (psusi) wrote :

Then I'm not sure how you got it working ( build mdadm from source? ). Apparently mdadm requires mdmon to do this correctly. Also while mdadm now has the capability to understand Intel arrays, Ubuntu is still built to have dmraid handle them, so there likely will be other problems trying to use mdadm to do so.

Also for what it's worth, unless you need to dual boot with Windows, it is best to avoid the fakeraid setup and just use native mdadm raid. It has much better support and features.

John Center (john-center) wrote :

I did build mdadm from source later & installed over top of the distribution copy of mdadm. But, I did have it working before I did this. I decided to do that because the later version did have better support for the Intel matrix storage BIOS. I do have Windows 7 running with IMSM, so I would like to have this working since there will be limited future support for dmraid. As you're aware, Intel recommends using mdadm with kernel v2.6.27 or later. I think it would be a good idea to include mdmon in future builds, especially 12.04, if possible.

Changed in mdadm (Ubuntu):
assignee: Clint Byrum (clint-fewbar) → Dmitrijs Ledkovs (dmitrij.ledkov)
status: In Progress → Fix Committed
Oliver Grawert (ogra) on 2012-05-22
Changed in mdadm (Ubuntu Quantal):
milestone: none → quantal-updates
milestone: quantal-updates → none
Changed in mdadm (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.2.3-2ubuntu2

---------------
mdadm (3.2.3-2ubuntu2) quantal; urgency=low

  * Minimizing the merge-diff from Debian:
    + debian/rules, debian/mdadm.udev, debian/mdadm.mdadm-blkid.udev:
      Drop our own udev rules in favour of upstream's. Debian did so in
      3.0~devel3-43-g2800528-1. Upstream's rules have everything we had.
      (LP: #1002357, LP: #968074)
    + debian/initramfs/hooks: Update to copy only the new/correct udev rules
      file.
    + debian/rules: Remove pointless diff against debian. And now mdmon
    installs itself (LP: #957494).

  * debian/patches/series: Remove `disable-udev-incr-assembly.diff' to
    enable incremental assembly, now that we are using upstream rules & we
    always had incremental assembly enabled.

  * Fixing lintian tags, that are introduced in Ubuntu:
    + debian/source_mdadm.py: fix executable-not-elf-or-script
    + debian/changelog: correct trailer formating of acient changelog entry
 -- Dmitrijs Ledkovs <email address hidden> Mon, 21 May 2012 20:48:10 +0100

Changed in mdadm (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mdadm (Ubuntu Precise):
status: New → Confirmed
Changed in mdadm (Ubuntu Precise):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Changed in mdadm (Ubuntu Precise):
importance: Undecided → Medium
description: updated
Sargun Dhillon (sdhillon) wrote :

This is related to bug #972960. Is there any way to test out the new mdadm with mdmon added on a Precise install CD to check if the bug is cured with this fix. I assume that the 12.04.1 installer will have this fix included?

Dimitri John Ledkov (xnox) wrote :

This SRU update has not been accepted into -proposed, so you cannot try with the CDs yet.

Which CD are you after? The desktop CD currently does not include mdadm - and therefore no software raid, IMSM, DFF.

Sargun Dhillon (sdhillon) wrote :

The Ubuntu server x86_64 CD. It does include mdadm, and dmraid, only no mdmon. This causes IMSM RAID to break.

Sargun Dhillon (sdhillon) wrote :

How would I be able to test in an actual precise system itself? Is there a bzr branch which I can build a mdadm deb for precise from, and test it out?

Stéphane Graber (stgraber) wrote :

Dmitrijs: What's the status of the SRU? are we still on target for the point release?

Changed in mdadm (Ubuntu Precise):
status: Confirmed → Triaged
Changed in mdadm (Ubuntu Precise):
status: Triaged → In Progress

Hello Clint, or anyone else affected,

Accepted mdadm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mdadm/3.2.5-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mdadm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Dimitri John Ledkov (xnox) wrote :

@Sargun Dhillon (sdhillon): The package is now available in precise-proposed. Now you can easily test this.

Sargun Dhillon (sdhillon) wrote :

The issue only happens during the installer (because dmraid grabs the array after boot, not mdadm since we don't install it by default). Is there any way to include this -proposed package during the install process (via preseed install)?

Dimitri John Ledkov (xnox) wrote :

@sdhillon: do you want to partition and install on to external metadata RAID? I am sorry to inform you, that this is currently not supported see: https://bugs.launchpad.net/ubuntu/+source/partman-md/+bug/1028677
Also this bug only includes mdmon in the normal deb package. Mdmon is still not included in the udeb, which would be required for the installer. Also I need to double check that mdmon is also available in the initramfs, cause otherwise it will not be possible to boot or have rootfs on the external metadata RAID.

Adam Conrad (adconrad) wrote :

Hello Clint, or anyone else affected,

Accepted mdadm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mdadm/3.2.5-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) on 2012-08-11
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.2.5-1ubuntu0.2

---------------
mdadm (3.2.5-1ubuntu0.2) precise-proposed; urgency=low

  * Patch udev-md-raid.rules to not auto-start arrays based on detection
    of ddf or isw (imsm) signatures; this conflicts with dmraid usage in
    precise and requires more analysis before it can be enabled in SRU.
    LP: #1030292.

mdadm (3.2.5-1ubuntu0.1) precise-proposed; urgency=low

  * Stable Micro Point Bug Fix release:
    - SRU master bug (LP: #1009973)
    - Fixes segfault upon update-initramfs (LP: #969384)
    - Fixes does not allow internal bitmap on version 1.2 arrays (LP: #1022915)
  * Preserved previous behaviour, by reverting:
    - bitmap chunk size of 0 will continue to mean 512B
    - Modify the below fix, to accept previous syntax
      "b10c663 config: fix handing of 'homehost' in AUTO line."
  * Use upstream version of udev rules, instead of three slightly
    different ubuntu udev rules (LP: #968074) (LP: #1002357)
  * Add missing mdmon utility. This enables external metadata RAID
    formats: DDF and Intel Matrix Storage Management (IMSM). (LP: #957494)
  * Copy udev rule from /etc/udev/rules.d/ as well as the
    /lib/udev/rules.d/, to allow local administrator to override mdadm
    rules file (LP: #1017407)
  * debian/initramfs/local-premount: add call wait_for_udev to wait a
    little longer for RAID devices to appear. This improves
    boot reliability. (LP: #942106)

mdadm (3.2.5-1) unstable; urgency=low

  [ Michael Tokarev ]
  * new upstream (bugfix) release, fixing regression when --add'ing
    device to an array, introduced in 3.2.4, plus other minor fixes
    (Closes: #673104, #673344)
  * new patch: sha1-includes.diff to fix #include mess in new sha1.h
  * added a check into debian/checkarray to skip checking arrays created
    less than 2 weeks ago (Closes: #624273)

  [ Dmitrijs Ledkovs ]
  * Remove obsolete documentation dating back to ~etch release
  * Remove reference to obsolete documention from debconf templates
  * Update debconf templates translations
  * Remove compatability with acient initramfs-tools
  * Remove debian-specific mdadm-startall.8 in clean target

mdadm (3.2.4-1) unstable; urgency=low

  * new upstream (bugfix) release (Closes: #664088, #661552)
  * removed debian-run-udev.diff (applied upstream), and
    all RUNDIR handling from debian/rules (it is the default now)
  * add build-arch and build-indep targets to debian/rules, and
    bump Standards-Version to 3.9.3

mdadm (3.2.3-3) unstable; urgency=low

  * switch from topgit to plain 3.0 (quilt) layout, creating
    debian/patches. Don't build-depend on quilt as patching
    is done automatically by dpkg-source.
  * debian/patches/debian-run-udev.diff by Roger Leigh (Closes: #644319, #627774)
  * update debian/mdadm.logcheck.ignore.server to recognize "k" in
    addition of "blocks" in kernel messages. Thanks to Frédéric Brière
    for the patch (Closes: #656038)
 -- Steve Langasek <email address hidden> Fri, 03 Aug 2012 23:08:39 -0700

Changed in mdadm (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers