Bitmap creation in 12.04 failed.

Bug #942275 reported by Mark on 2012-02-27
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
mdadm (Debian)
Fix Released
Unknown
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

Created a 4x3TB raid6 without bitmap. Regretted my error and afterwards tried to create the bitmap. Creation of bitmap failed.
(Yes its stupid with 4x3TB in RAID6 but it will be expanded in the futured with XFS).

I tried to create/delete and so on and so forth and noticed that I could never create a bitmap on 12.04 without updating to GIT-version "newest" (around 20-23feb-12) of MDADM. After using the GIT-version of mdadm and use that to create bitmap it went fine. No problems whatsoever. However when rebooting the array will autocheck. Probably because I didnt make install (wanted to keep the 12.04 "untouched") so it ran with older mdadm during boot. And bitmap was faulty again. Even reboot/shutdown didnt complete (froze) and even if I did "clean reboot" with alt-prntscrn-RSKINUT it wouldnt work.

Repeted this experience 2-3 times before I figured it wouldnt work. I can add/remove bitmap without any issues (with the GIT-version) as long as I dont reboot. As soon as I reboot it fails and it will recheck array again.

Leaving bitmap unset works fine. I can reboot loads of time without any issues whatsoever.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mdadm (Ubuntu):
status: New → Confirmed
Brian Candler (b-candler) wrote :

I think this is known bug in mdadm 3.2.3, fixed in git upstream:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664088

Changed in mdadm (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.