boot degraded question is asked twice

Bug #820111 reported by Clint Byrum on 2011-08-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
High
Clint Byrum
Natty
Undecided
Unassigned
Oneiric
High
Clint Byrum

Bug Description

When booting with a degraded array, and you answer yes, the boot degraded question is asked twice.

This was likely introduced in the bug fix for bug #778520

This only occurs when the disks are missing, not when member disks are present but un-synced from the array.

Answering yes does end up in the system booting normally.

tags: added: iso-testing
Changed in mdadm (Ubuntu):
importance: Undecided → High
description: updated
tags: added: oneiric
Changed in mdadm (Ubuntu):
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations-team)
Steve Langasek (vorlon) wrote :

Clint, Brian thinks this is a regression introduced by your fix for 778520, which seems to be in the midst of an SRU for natty. Could you take a look at this?

Changed in mdadm (Ubuntu):
assignee: Ubuntu Foundations Team (ubuntu-foundations-team) → Clint Byrum (clint-fewbar)
C de-Avillez (hggdh2) wrote :

Confirmed, marking Triaged.

Changed in mdadm (Ubuntu):
status: New → Triaged
C de-Avillez (hggdh2) on 2011-08-04
Changed in mdadm (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-1
Brian Murray (brian-murray) wrote :

Steve, it was actually Clint who said that is just that the assignment email from Launchpad included my name (and then the description) because I assigned it.

Brian Murray (brian-murray) has assigned this bug to you for mdadm in Ubuntu:

When booting with a degraded array, and you answer yes, the boot
degraded question is asked twice.

Excerpts from Steve Langasek's message of Thu Aug 04 04:12:15 UTC 2011:
> Clint, Brian thinks this is a regression introduced by your fix for
> 778520, which seems to be in the midst of an SRU for natty. Could you
> take a look at this?

Yes I'm 100% confident it was introduced by my fix. I think I know the
(trivial) fix too. Of course.. mdadm bugs always take 3 times longer to
test than they do to fix. ;)

I marked the SRU for bug 778520 as verification-failed to block it entering
-updates until we can get a new version out.

Steve Langasek (vorlon) wrote :

hah, sorry, was confused by the email generated when Brian assigned the bug... carry on :-)

Changed in mdadm (Ubuntu Natty):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.1.4-1+8efb9d1ubuntu6

---------------
mdadm (3.1.4-1+8efb9d1ubuntu6) oneiric; urgency=low

  * d/initramfs/mdadm-functions: Record in /run when boot-degraded
    question has been asked so that it is only asked once (LP: #820111)
  * d/control: add dependency on initscripts >= 2.88dsf-13.3 to ensure
    /run exists per http://wiki.debian.org/ReleaseGoals/RunDirectory
  * d/rules: fix FTBFS by adding -Wno-unused-but-set-variable to
    compiler flags until upstream solves the issue. (LP: #829463)
 -- Clint Byrum <email address hidden> Wed, 24 Aug 2011 08:40:12 -0700

Changed in mdadm (Ubuntu Oneiric):
status: Triaged → Fix Released

Hello Clint, or anyone else affected,

Accepted mdadm into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mdadm (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
dino99 (9d9) on 2013-05-18
Changed in mdadm (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers