raid1 boot degraded mode fails

Bug #728435 reported by Patrick Domack on 2011-03-03
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
High
Surbhi Palande
Natty
High
Surbhi Palande

Bug Description

Binary package hint: debian-installer

Doing the server default+raid1 test, disconnecting drive 2 causes boot to fail.

mdadm find the good drive, and detects the missing drive but doesn't create the md devices.

Screen dump:
Attempting to start the RAID in degraded mode...
mdadm: CREATE user root not found
mdadm: CREATE group disk not found
Could not start the RAID in degraded mode.
Gave up waiting for root device. Common problems:
...
...
ALERT! /dev/disk/by-uuid/1da...... does not exist.
Dropping to a shell!

Related branches

Dave Walker (davewalker) wrote :

Not quite sure if this is a d-i or mdad issue..

Changed in debian-installer (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
Changed in debian-installer (Ubuntu Natty):
importance: Undecided → High
Colin Watson (cjwatson) on 2011-03-03
affects: debian-installer (Ubuntu Natty) → mdadm (Ubuntu Natty)
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

The user and group messages suggest that perhaps mdadm now needs nss modules in the initramfs?

James Page (james-page) wrote :

Had the same issue with the i386 ISO as well.

Changed in mdadm (Ubuntu Natty):
status: Incomplete → Confirmed
assignee: nobody → Surbhi Palande (csurbhi)
Surbhi Palande (csurbhi) wrote :

The following workaround can be used for the time being:

1) mdadm -S /dev/<array that you want to start in degraded mode>
and then
2) mdadm --assemble --scan --run

This should start the array that you want in degraded mode (for now)

Surbhi Palande (csurbhi) wrote :

This is the first version of the patch. Also trying to figure out if an array can be simply started without stopping when there are no more member devices available.

Sander Tuit (avirulence) wrote :

mdadm doesn't find my disks when trying to boot after an upgrade to Natty. When dropping to the initramfs shell and try to assemble manually, I get this:

mdadm: CREATE user root not found
mdadm: CREATE group disk not found

When I boot the liveCD, mdadm doesn't find my disks at all, however, with the 9.04 liveCD, mdadm does find them. Is this related to this bug?

tags: added: patch
Sander Tuit (avirulence) wrote :

My problem turned out to be (probably) unrelated. For some reason dmraid got to the drives before mdadm (which didn't happen in 10.10). Booting with nodmraid solved my problem.

Surbhi Palande (csurbhi) on 2011-03-18
Changed in mdadm (Ubuntu Natty):
status: Confirmed → In Progress
Surbhi Palande (csurbhi) wrote :

After an email exchange with Neil Brown, identified that using mdadm -IRs instead of mdadm -Ars will fix this issue. So made the necessary change in the initramfs/init-premount/mdadm script - as a fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.1.4-1+8efb9d1ubuntu4

---------------
mdadm (3.1.4-1+8efb9d1ubuntu4) natty; urgency=low

  * mdadm udev rule incrementally adds mdadm member when detected. Starting
    such an array in degraded mode is possible by mdadm -IRs. Using mdadm -ARs
    without stopping the array first does nothing when no mdarray-unassociated
    device is available. Using mdadm -IRs to start a previously partially
    assembled array through incremental mode. Keeping the mdadm -ARs for
    assembling arrays which were for some reason not assembled through
    incremental mode (i.e through mdadm's udev rule). (LP: #728435)
 -- Surbhi Palande <email address hidden> Wed, 23 Mar 2011 18:28:55 +0200

Changed in mdadm (Ubuntu Natty):
status: In Progress → Fix Released
Francois du Plessis (fdup) wrote :

It got broken again by version mdadm - 3.2.5-1ubuntu0.2 , as described in (probably duplicate)
"booting from raid in degraded mode ends in endless loop" Bug #1077650

Thiago Martins (martinx) wrote :

Double posting here:

---
So, brand new Ubuntu 14.04 and, impossible to boot it in degraded mode...

---
I just install a server with:

/dev/sda1 = /dev/md0 = /boot
/dev/sda2 = /dev/md1 = LVM VG: vg01 = LVM LV: swap / LVM LV: root (ext4)

/dev/sdb not present.

Installation finishes without any problem, system doesn't boot.

--

If I do not use LVM, like this:

/dev/sda1 = /dev/md0 = /
/dev/sda2 = SWAP

Ubuntu also doesn't boot (in degraded)...

I also tried this:

/dev/sda1 = /dev/md0 = /boot
/dev/sda2 = /dev/md1 = /
/dev/sda3 = SWAP

Doesn't boot either.

---

This problem have nothing to do with LVM on top of raid1...

Come on guys, I'm a "Ubuntu Evangelist" but, problems like this are a shame. Sorry, I don't want to be rude... Sad, but true.

Regards,
Thiago
---

Dimitri John Ledkov (xnox) wrote :

Thiago Martins (martinx) please open new issues, and please do not post exactly the same comment in multiple old bug reports. You are causing valuable developer and bug trianger's time to be wasted.

Thiago Martins (martinx) wrote :

Okay, sorry...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers