mdadm cannot assemble array

Bug #599135 reported by Alvin
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
New
Undecided
Unassigned

Bug Description

Binary package hint: mdadm

See bug 27037. This is probably the same bug, but with a different reporter. The bug occurs from time to time after reboot.

From /var/log/daemon.log:
Jun 27 22:44:10 stilgar mdadm[1174]: DeviceDisappeared event detected on md device /dev/md0

$ cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md_d0 : inactive sdb[0](S)
      312571136 blocks

unused devices: <none>

$ sudo mdadm --assemble --scan
mdadm: no devices found for /dev/md0
/dev/md0: File exists
mdadm: /dev/md/0 assembled from 1 drive - not enough to start the array.

$ sudo mdadm -S /dev/md0
mdadm: error opening /dev/md0: No such file or directory
$ sudo mdadm -S /dev/md_d0
mdadm: stopped /dev/md_d0

$ sudo mdadm --assemble --scan
mdadm: no devices found for /dev/md0
mdadm: /dev/md/0 has been started with 2 drives.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mdadm 2.6.7.1-1ubuntu15
ProcVersionSignature: Ubuntu 2.6.32-22.36-server 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-server x86_64
Architecture: amd64
Date: Sun Jun 27 22:50:56 2010
MDadmExamine.dev.sda: Error: command ['/sbin/mdadm', '-E', '/dev/sda'] failed with exit code 1: mdadm: cannot open /dev/sda: Permission denied
MDadmExamine.dev.sda1: Error: command ['/sbin/mdadm', '-E', '/dev/sda1'] failed with exit code 1: mdadm: cannot open /dev/sda1: Permission denied
MDadmExamine.dev.sda2: Error: command ['/sbin/mdadm', '-E', '/dev/sda2'] failed with exit code 1: mdadm: cannot open /dev/sda2: Permission denied
MDadmExamine.dev.sdb: Error: command ['/sbin/mdadm', '-E', '/dev/sdb'] failed with exit code 1: mdadm: cannot open /dev/sdb: Permission denied
MDadmExamine.dev.sdc: Error: command ['/sbin/mdadm', '-E', '/dev/sdc'] failed with exit code 1: mdadm: cannot open /dev/sdc: Permission denied
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-22-server root=/dev/mapper/vg0-root ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
ProcMDstat:
 Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
 md_d0 : inactive sdb[0](S)
       312571136 blocks

 unused devices: <none>
SourcePackage: mdadm
dmi.bios.date: 02/23/2010
dmi.bios.vendor: Intel Corp.
dmi.bios.version: CBQ4510H.86A.0119.2010.0223.1522
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DQ45CB
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE30148-301
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrCBQ4510H.86A.0119.2010.0223.1522:bd02/23/2010:svn:pn:pvr:rvnIntelCorporation:rnDQ45CB:rvrAAE30148-301:cvn:ct3:cvr:
etc.blkid.tab: Error: [Errno 2] No such file or directory: '/etc/blkid.tab'

Revision history for this message
Alvin (alvind) wrote :
Revision history for this message
ceg (ceg) wrote :

May this be Bug #469574 or Bug #532960 ? They have workarounds.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers