[->Initramfs] no degraded boot (arbitrary lvm, luks, raid, auth, ... combinations)

Bug #488317 reported by ceg on 2009-11-25
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mdadm

The install followed https://wiki.ubuntu.com/HotplugRaid (but with a separate /boot partition plus the root fs and swap -> on lvm -> on crypt -> on raid1)

When a disk is disconnected and the system is powerd on it fails to boot.

Cryptsetup times out. Raid does not seem to get started. Cryptsetup will not retry. Minishell end.

ceg (ceg) wrote :

Current state of ubuntu systems with md raid: https://wiki.ubuntu.com/ReliableRaid

ceg (ceg) wrote :

Well the initramfs boot process needs to be (a state machine) capable of assembling the base system from devices appearing in any order and starting necessary raids degraded if they are not complete after some time.

Bug #491463 upstart init within initramfs
Bug #251164 boot impossible due to missing initramfs failure hook integration
Bug #247153 encrypted root initialisation races/fails on hotplug devices (does not wait)

ceg (ceg) on 2010-03-29
summary: - installed system fails to boot with degraded raid holding cryptdisk
+ [->Initramfs] boot fails with degraded raid
summary: - [->Initramfs] boot fails with degraded raid
+ [->Initramfs] no degraded boot lvm-luks-raid
ceg (ceg) wrote :

Solution found in comment #15 of Bug #251164

summary: - [->Initramfs] no degraded boot lvm-luks-raid
+ [->Initramfs] no degraded boot (arbitrary lvm, luks, raid, auth, ...
+ combinations)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mdadm (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers