MD not mounted

Bug #431064 reported by Iain Lane on 2009-09-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: mountall

Greetings,

After updating to the new boot crack, GDM fails to start. I'm attaching a log of mountall --debug, per slangasek's request.

I have / and swap on one drive and an MDADM array (degraded) on another, which should be mounted from fstab but isn't:

  /dev/md0p1 /media/storage ext4 errors=remount-ro 0 1

mountall.log attached

Iain

Iain Lane (laney) wrote :

Thanks for the report.

Could you provide the output of "blkid" please, if that doesn't include your RAID array, try "blkid -p /dev/md0p1"

with 0.1.6 gdm should no longer fail to start, but we should find out why your array isn't mounted

Changed in mountall (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Iain Lane (laney) wrote :

Here you go.

I don't know if I did anything but when I went to my computer this morning, the boot process didn't get as far as it did yesterday, so when I upgraded to mountall 0.16 it made no difference. I'll also attach a screenshot.

Thanks.

Iain Lane (laney) wrote :

And the output from "blkid" itself, showing other partitions.

Where does that bash shell come from?

Iain Lane (laney) wrote :

I just booted the system in recovery mode (but the same happens normally), and it dumped me there. blkid will follow shortly when I get home from work.

summary: - No gdm after upgrading to mountall 0.1.5, dbus 1.2.16-0ubuntu4
+ MD not mounted
Iain Lane (laney) wrote :

blkid attached.

Do you think me being kicked to this shell is a separate problem?

Iain Lane (laney) wrote :

Yes, it was because I put "bash" in mountall.conf for debugging. Sorry for the noise :) MD still not mounted.

On Thu, 2009-09-17 at 18:09 +0000, Iain Lane wrote:

> Yes, it was because I put "bash" in mountall.conf for debugging. Sorry
> for the noise :) MD still not mounted.
>
That's ok.

It's probably useful to have the shell.

Can you add the output of:

  mdadm -D /dev/md0

  mdadm --detail --export /dev/md0p1
  mdadm --detail --export /dev/md0p5

Also:

  ls /sys/block/md0
  ls /sys/block/md0/md
  ls /sys/block/md0/md0p1
  ls /sys/block/md0/md0p1/md
  ls /sys/block/md0/md0p5
  ls /sys/block/md0/md0p5/md

And:

  fdisk -l /dev/sda
  fdisk -l /dev/sdb

We're getting very close to the cause of this.

Scott
--
Scott James Remnant
<email address hidden>

Changed in mountall (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Scott James Remnant (scott)
tags: added: ubuntu-boot
Iain Lane (laney) wrote :

I ran this booted into my system, as rescue mode just started normally instead of giving me a console. Hope that's alright.

Changed in mountall (Ubuntu Karmic):
milestone: none → ubuntu-9.10-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.1.8

---------------
mountall (0.1.8) karmic; urgency=low

  [ Scott James Remnant ]
  * Further work on the fix from the previous version where the root
    filesystem would always be considered "local", retain that from the
    POV of the {virtual,local,remote}-filesystems events, but do mount
    the root straight away when it's virtual since there's no device to
    wait until it's ready. LP: #431204.
  * If a remote filesystem is already mounted and doesn't need a remount,
    don't wait for a network device to come up. LP: #430348.

  * Ignore single and double quotes in fstab device specifications, since
    mount -a used to. LP: #431064.
  * Never write mtab when mounting a mount with showthroughs (ie. /var)
    and instead update mtab once we've moved it into place
    later. LP: #434172.

  [ Kees Cook ]
  * src/mountall.c: rework nftw hooks to use a global for argument passing
    instead of using nested functions and the resulting trampolines that
    cause an executable stack. LP: #434813.
  * debian/rules: revert powerpc exception, since the cause is fixed by
    removing the nested functions.

 -- Scott James Remnant <email address hidden> Wed, 23 Sep 2009 14:19:01 -0700

Changed in mountall (Ubuntu Karmic):
status: In Progress → Fix Released

Sorry, that was a mis-file - this bug is not yet fixed, sorry

Changed in mountall (Ubuntu Karmic):
status: Fix Released → Triaged

I have uploaded a fix to this bug, however since we're in freeze it may take a while to show up so I've also uploaded it to the ubuntu-boot PPA. Please test.

affects: mountall (Ubuntu Karmic) → mdadm (Ubuntu Karmic)
Changed in mdadm (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 2.6.7.1-1ubuntu13

---------------
mdadm (2.6.7.1-1ubuntu13) karmic; urgency=low

  * Do not test array state for partitions, which won't exist if the
    array is inactive and don't have a state to test. LP: #431064.

 -- Scott James Remnant <email address hidden> Sun, 27 Sep 2009 14:39:39 -0700

Changed in mdadm (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers