{upstream} Raid10,o2 only reads from a single disk

Bug #320418 reported by Kenn on 2009-01-23
4
Affects Status Importance Assigned to Milestone
mdadm
Undecided
Unassigned
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

installed 8.04 64bit server from CD.
installed sysstat package.
mdadm --create /dev/md3 --level=10 --raid-devices=2 --chunk=512 --layout=o2 /dev/sdh1 /dev/sdd1

Det ser ud til at der kun læses fra een (1) disk i et RAID10,o2 array med 2 diske.
Eg:
 /dev/md3 = Raid10,o2 on 2 disks sdd1 and sdh1:

dd if=16GigaByte-FileOnRaidArray of=/dev/null
33554432+0 records in
33554432+0 records out
17179869184 bytes (17 GB) copied, 353,121 s, 48,7 MB/s

iostat during dd :
avg-cpu: %user %nice %system %iowait %steal %idle
           0,67 0,00 10,07 39,87 0,00 49,40

Device: tps MB_read/s MB_wrtn/s MB_read MB_wrtn
sdd 0,00 0,00 0,00 0 0
sdi 145,53 48,06 0,00 720 0
md3 11944,53 48,04 0,00 720 0

At no time is there read from /dev/sdd.
Repeating "dd if=16GigaByteFileOnRaidArray of=/dev/null"
Might result in iostat reporting:

avg-cpu: %user %nice %system %iowait %steal %idle
           0,47 0,00 9,27 40,87 0,00 49,40

Device: tps MB_read/s MB_wrtn/s MB_read MB_wrtn
sdd 120,67 39,16 0,00 587 0
sdi 0,00 0,00 0,00 0 0
md3 9751,67 39,21 0,00 588 0

At no time is there read from /dev/sdi.

--- 2nd. test
Booting on intrepid 64bit live-cd (desktop)
mdadm --assemble --scan /dev/md3
apt-get sysstat
dd if=16GigaByte-FileOnRaidArray of=/dev/null

And iostat reports that there is read from both disks.
And throughput seemed higher.

--- 3rd. test
Booting on Hardy 8.02-2 64bit live-cd (desktop)
mdadm --assemble --scan /dev/md3
apt-get sysstat
dd if=16GigaByte-FileOnRaidArray of=/dev/null

And iostat reports that there is only read from ONE disk.

Forcing sysstat to ver.8.1.2-2 from intrepid.
rerunning test
iostat _still_ reports that there is only read from ONE disk.

- Should be easily reproduceable.

/Kenn

David Tombs (dgtombs) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in mdadm.

For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → mdadm (Ubuntu)
ceg (ceg) on 2010-03-31
summary: - Raid10,o2 only reads from a single disk
+ {upstream} Raid10,o2 only reads from a single disk
David Tombs (dgtombs) wrote :

Can you reproduce this, then, ceg?

ceg (ceg) on 2010-04-01
Changed in mdadm (Ubuntu):
status: New → Invalid
David Tombs (dgtombs) wrote :

What is going on here? Please provide explanations for your status changes.

Changed in mdadm (Ubuntu):
status: Invalid → New
ceg (ceg) wrote :

I don't have the disks to reproduce raid10.

I went through the mdadm buglist that hasn't seen much caretaking for long, sorting dupes etc. As this is issue is genereal (not packaging related) I wanted to forward this to mdadm (not only mdadm in ubuntu). I tried to do a reassigning but obviously that didn't work as expected.

David Tombs (dgtombs) wrote :

Hi ceg, I appreciate your efforts, but we don't typically forward bugs upstream until we can confirm they exist in Ubuntu. (Otherwise, we might end up reporting lots of issues just due to bad configurations, etc.) Also, when forwarding a bug upstream we leave the (Ubuntu) bug in the Confirmed or Triaged state because even when it's fixed upstream, we might have to do some extra effort to bring the patch into Ubuntu.

So I'll invalidate upstream task until we can confirm the bug.

Please take a look at <https://wiki.ubuntu.com/Bugs/HowToTriage> for future reference.

Changed in mdadm:
status: New → Invalid
ceg (ceg) wrote :

I see, thanks for the pointer, David. Currently there isn't any real forwarding going on, anyway. The LP project mdadm is only a place to gather the upstream related things (no upstream bug tracker).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers