--incremental not creating device nodes

Bug #251663 reported by ceg on 2008-07-25
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)

Bug Description

Binary package hint: mdadm

ubuntu 8.04

When "mdadm --incremental /dev/sdXY" is used to incremantaly assemble an array (as udev is supposed to do instead of --assemble --scan), after a reboot that cleared device nodes from prior --assemblies, mdadm fails because of missing device nodes instead of creating them.

ceg (ceg) wrote :

To reproduce change /etc/udev/rules.d/85-mdadm* to do "mdadm --incremental /dev/%k" and reboot.

After initramfs drops you to a console try mdadm --incremental manually.

ceg (ceg) wrote :

Don't forget to "update-initramfs -k all -u" with the new udev rule before rebooting, though.

ceg (ceg) wrote :

Current state of ubuntu systems with md raid: https://wiki.ubuntu.com/ReliableRaid

ceg (ceg) wrote :

current releases are using --incremental

Changed in mdadm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers