raid config fails with debian-installer/mdadm

Bug #182376 reported by Hasse Hagen Johansen on 2008-01-12
2
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

Using the alternative cd I have been trying to install ubuntu on 2 disks in a raid 1 linux software raid configuration. I would like 1 raid device for boot and 1 for the rest(actually I would have the rest used by LVM, but haven't got that far)

Something is confusing the partitioner or mdadm about my disks. It is 2 maxtor Diamondmax plus 9 120GB disks.

I can create the partitions fine. But when I then enter the raid configuration. And choose to create a new raid 1...I get a message about that no raid are available. If I then go to the terminal I can see that it somehow has put all 4 raid partitions in one md device

I have 2 different controllers on my motherboard and have tried it on each of them...with the same result.

I have also tried to install just normally on one disk, and then convert it to raid...I cannot boot after I install mdadm

On the other hand I have tried the same alternate install cd on 2 old ibm disks I had around where it works perfectly

I don't know, but what I can imagine is that somehow maybe the kernel doesn't get the correct geometry of the disks? but that is just a wild guess

I can install fedora core9 in the same raid configuration which are failing with ubuntu. I have actually tried both 7.04,7.10,8.04 alfa 1 & 3 and also Debian etch. All of these versions fail with the maxtor disks

I will see if I can find out if there is any differences in kernel parameters at boot time and/or kernel configuration

Regards
Hasse

Ok. I have tried to see if I could find any differences in the kernel config, but haven't been very good at it. I have tried opensuse also. It also is creating Software raid successfully. I have attached then kernel config from Ubuntu 8.04 alpha 3 and fedora core8 if anyone have a good way to diff these

Hi

This problem seems to have been fixed in 8.04 alpha 4 - maybe the new kernel?

But Istill beleive that debian etch,7.04,7.10 has this error

Eric S. (estrand) wrote :

I ran into the same issues as you, and similarly was able to successfully create my RAID arrays using another Linux distro (Gentoo). I struggled with this for hours, and finally came to the realization that mdadm likes to auto assemble RAID arrays, whether during booting, or as part of the partitioning process during installation. Since my drives had been part of a past array (as entire disks) and part of several RAID setup attempts (using partitions) they were littered with data that mdadm used to create arrays that I did not want.

So during OS installation, the previous use of the entire disks in a RAID array caused the RAID portion of the partitioner to create the unwanted whole-disk array, and throw up the error that no "Linux RAID autodetect" partitions were available. Similarly, during booting, the whole-disk array, which was a hold over of the previous use of the drives, took over the whole disk and thus my boot partition (in my case not part of the RAID), could not be found. That is why reboots failed.

I ended up booting the liveCD, installing mdadm, and using mdadm --zero-superblock on my physical disk devices /dev/sda and /dev/sdb, and on each of the drives' partitions that previously had the "mdraid" partition type set. This removes the information mdadm uses to auto assemble RAID arrays.

From what I have read, but not tried myself, is that the mdadm --stop command will take partitions out of a raid array so that the partitions can be reused as other partition types (or in another RAID array).

--Eric S.

This bug report is being closed due to your comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in mdadm (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers