invalid udev rules shipped in mdadm-udeb

Bug #1705215 reported by Tomasz Majchrzak on 2017-07-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Status tracked in Cosmic
Bionic
Critical
Unassigned
Cosmic
Critical
Unassigned

Bug Description

[Impact]

 * Upon installation, RAID devices are not automatically assembled by default as they used to be. Instead of being presented with an assembled RAID array for installation, one is presented with individual disks which probably is not desired by the user, as most of the time RAID arrays are intentional.

[Test Case]

 * Create a VM with e.g. two disks assembled in a Linux RAID1 using mdadm and not otherwise partitioned / empty.

 * Start the d-i based installer

 * In the partitioning screen one should be presented with a raid device to partition, not individual disks.

[Regression Potential]

 * This is a regression in the bionic release versus Xenial behaviour

 * The udev rules as installed into the udeb package were not processed to substitute template variables for BINDIR location of the mdadm tools. Now the packaging was corrected to install identical udev rules into the deb and udeb package types.

[Other Info]

 * Original bug report:

It is not possible to install Ubuntu on RAID device with IMSM/DDF metadata. The installer asks if such arrays should be activated but fails to do it.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: mdadm 4.0-1
ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
Uname: Linux 4.10.0-26-generic x86_64
ApportVersion: 2.20.5-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jul 19 09:46:44 2017
InstallationDate: Installed on 2017-07-06 (12 days ago)
InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 (20170702)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MDadmExamine.dev.sda: Error: command ['/sbin/mdadm', '-E', '/dev/sda'] failed with exit code 1: mdadm: cannot open /dev/sda: Permission denied
MDadmExamine.dev.sda1: Error: command ['/sbin/mdadm', '-E', '/dev/sda1'] failed with exit code 1: mdadm: cannot open /dev/sda1: Permission denied
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-26-generic root=/dev/mapper/hostname--vg-root ro
ProcMDstat:
 Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
 unused devices: <none>
SourcePackage: mdadm
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
etc.blkid.tab: Error: [Errno 2] No such file or directory: '/etc/blkid.tab'

Tomasz Majchrzak (tmajchrzak) wrote :
Tomasz Majchrzak (tmajchrzak) wrote :

The problem is in the udev rules in the installer:

/lib/udev/rules.d/63-md-raid-array.rules
/lib/udev/rules.d/64-md-raid-assembly.rules

There is a wrong path to mdadm which contains "BINDIR" instead of "/sbin". The same rule files in the installed system are fine.

There is a workaround to the problem:

1. Wait for installer "Configure network" screen.

2. Switch to other console.

sed -i 's/BINDIR/\/sbin/g' /lib/udev/rules.d/*-md-*
udevadm control --reload

3. Continue the installation.

Tomasz Majchrzak (tmajchrzak) wrote :

Any chance to have it changed in artful?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mdadm (Ubuntu):
status: New → Confirmed
Pawel Baldysiak (pbaldysi) wrote :

Hi,
Intel is waiting for this issue to be resolved.
Could you tell us in which drop of ubuntu 18.04 it is going to be fixed?
This is a blocker for VROC.

Thanks
Pawel

Changed in mdadm (Ubuntu Cosmic):
importance: Undecided → Critical
Changed in mdadm (Ubuntu Bionic):
importance: Undecided → Critical
status: New → Confirmed
summary: - Cannot install Ubuntu on IMSM/DDF RAID device
+ invalid udev rules shipped in mdadm-udeb
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 4.1~rc1-2

---------------
mdadm (4.1~rc1-2) unstable; urgency=medium

  * Install identical udev rules into d-i installer udeb, as used in the
    installed system. Specifically, post-processed rules with full path to
    mdadm binary subsituted, instead of installing useless rules with the
    template variable BINDIR. LP: #1705215

 -- Dimitri John Ledkov <email address hidden> Tue, 22 May 2018 14:26:59 +0100

Changed in mdadm (Ubuntu Cosmic):
status: Confirmed → Fix Released
description: updated
Changed in mdadm (Ubuntu Bionic):
status: Confirmed → In Progress

Hello Tomasz, or anyone else affected,

Accepted mdadm into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mdadm/4.0-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mdadm (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Dimitri John Ledkov (xnox) wrote :

Booting with http://cdimage.ubuntu.com/ubuntu-server/bionic/daily/20180524/ which has /pool/main/m/mdadm/mdadm-udeb_4.0-2ubuntu1_amd64.udeb there are no symlinks present in /dev/md for my raid1 device.

Installing using http://cdimage.ubuntu.com/ubuntu-server/bionic/daily/20180525/ d-i server iso, I can see that raid1 is offered as an automatically partition drive. The text name of it, is a bit ugly, but it is there. Package version in use there is /pool/main/m/mdadm/mdadm-udeb_4.0-2ubuntu1.1_amd64.udeb and there are symlinks to the raid device present in /dev/md.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 4.0-2ubuntu1.1

---------------
mdadm (4.0-2ubuntu1.1) bionic; urgency=medium

  * Install identical udev rules into d-i installer udeb, as used in the
    installed system. Specifically, post-processed rules with full path to
    mdadm binary subsituted, instead of installing useless rules with the
    template variable BINDIR. LP: #1705215

 -- Dimitri John Ledkov <email address hidden> Thu, 24 May 2018 11:14:57 +0100

Changed in mdadm (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mdadm has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers