EXT4-fs (md0): bad geometry: block count

Bug #1378850 reported by gunfus on 2014-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

The problem:
---------------

I was running ubuntu-server version 14.04 and after doing a upgrade to 14.04.1, I now get problems related to mounting my raid system.

From dmesg I get:
---------------------

[ 10.404355] EXT4-fs (dm-0): re-mounted. Opts: errors=remount-ro
[ 10.554676] EXT4-fs (sdb1): mounting ext3 file system using the ext4 subsystem
[ 10.735497] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[ 10.745454] EXT4-fs (md0): mounting ext3 file system using the ext4 subsystem
[ 10.753795] EXT4-fs (md0): bad geometry: block count 122096646 exceeds size of device (122096624 blocks)

My 'lsb_release -rd':
-------------------------------
Description: Ubuntu 14.04.1 LTS
Release: 14.04

I read on askubuntu that there seems to be someone else having the same problem on this release too: google search "ask ubuntu 14.04 bad geometry"

gunfus (gunfus) wrote :

My '/proc/version_signature':
-------------------------------
Ubuntu 3.13.0-36.63-generic 3.13.11.6

gunfus (gunfus) wrote :
gunfus (gunfus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1378850/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
gunfus (gunfus) on 2014-10-08
affects: ubuntu → linux (Ubuntu)
affects: linux (Ubuntu) → mountall (Ubuntu)
Steve Langasek (vorlon) on 2014-10-08
affects: mountall (Ubuntu) → mdadm (Ubuntu)
gunfus (gunfus) wrote :

I was told in IRC to clarify the meaning of:

> google search "ask ubuntu 14.04 bad geometry"

so here is the direct link: http://askubuntu.com/questions/463395/cant-mount-raid-after-upgrade

i also have a e2image of md0.. just in case is needed.. but I am a little concern of some of the data that I can be posting to the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers