Activity log for bug #120375

Date Who What changed Old value New value Message
2007-06-14 10:25:35 peterh bug added bug
2007-08-18 07:16:07 Peter Haight bug added attachment 'failed-raid.patch' (Patch to boot after timeout using degraded RAID drives.)
2008-04-29 11:14:30 Jens mdadm: status New Confirmed
2008-06-03 19:05:04 Pete Hardman bug assigned to initramfs-tools
2008-06-03 21:49:31 Dustin Kirkland  initramfs-tools: status New Confirmed
2008-06-03 21:49:31 Dustin Kirkland  initramfs-tools: assignee kirkland
2008-06-03 21:52:07 Dustin Kirkland  mdadm: importance Undecided Medium
2008-06-03 21:52:07 Dustin Kirkland  mdadm: assignee kirkland
2008-06-03 21:52:07 Dustin Kirkland  mdadm: milestone ubuntu-8.10
2008-07-10 07:42:51 Alexander Dietrich bug added attachment 'initramfs-mdadm-assemble-scan.patch' (Patch for initramfs-tools as suggested by Ken on 2008-03-31)
2008-07-25 02:35:39 Dustin Kirkland  bug added attachment 'mdadm.120375.debdiff' (mdadm.120375.debdiff)
2008-07-25 02:36:08 Dustin Kirkland  bug added attachment 'initramfs-tools.120375.debdiff' (initramfs-tools.120375.debdiff)
2008-07-25 02:36:32 Dustin Kirkland  mdadm: status Confirmed Triaged
2008-07-25 22:36:48 Dustin Kirkland  bug added attachment 'initramfs-tools.120375.debdiff' (initramfs-tools.120375.debdiff)
2008-07-25 22:45:15 Dustin Kirkland  bug added attachment 'mdadm.120375.debdiff' (mdadm.120375.debdiff)
2008-07-25 22:46:36 Kees Cook initramfs-tools: status Confirmed In Progress
2008-07-25 22:47:07 Kees Cook mdadm: status Triaged In Progress
2008-07-25 22:47:25 Kees Cook bug assigned to initramfs-tools (Ubuntu)
2008-07-25 22:47:43 Kees Cook initramfs-tools: status New In Progress
2008-07-25 22:47:43 Kees Cook initramfs-tools: assignee kirkland
2008-07-25 22:48:58 Kees Cook initramfs-tools: status In Progress Confirmed
2008-07-25 22:48:58 Kees Cook initramfs-tools: assignee kirkland
2008-07-25 22:49:31 Kees Cook initramfs-tools: importance Undecided Medium
2008-07-25 22:49:31 Kees Cook initramfs-tools: milestone ubuntu-8.10
2008-07-28 20:20:08 Launchpad Janitor initramfs-tools: status In Progress Fix Released
2008-07-28 20:20:27 Launchpad Janitor mdadm: status In Progress Fix Released
2008-08-18 10:15:01 Dustin Kirkland  bug added attachment 'mdadm.boot_degraded_debconf.debdiff' (mdadm.boot_degraded_debconf.debdiff)
2008-08-18 10:17:49 Dustin Kirkland  bug added attachment 'mdadm.boot_degraded_debconf.debdiff' (mdadm.boot_degraded_debconf.debdiff)
2008-08-19 09:45:24 Dustin Kirkland  bug added attachment 'Screenshot.png' (Screenshot.png)
2008-08-19 10:20:52 Ace Suares bug added subscriber Ubuntu Stable Release Updates Team
2008-08-19 10:29:10 Ace Suares description Binary package hint: mdadm if i unplug one hd from raid1 i cannot successfully boot because raid starts only if all disks are available through : "${MD_DEGRADED_ARGS:= --no-degraded}" in /usr/share/initramfs-tools/scripts/local-top/mdadm my workaround is: /etc/initramfs-tools/hooks/startdegradedraid #!/bin/sh # # Copyright <C2><A9> 2006 Martin F. Krafft <madduck@debian.org> # based on the scripts in the initramfs-tools package. # released under the terms of the Artistic Licence. # # $Id: hook 281 2006-12-08 08:14:44Z madduck $ # set -eu PREREQ="udev" prereqs() { echo "$PREREQ" } case ${1:-} in prereqs) prereqs exit 0 ;; esac MDADM=$(command -v mdadm 2>/dev/null) || : [ -x $MDADM ] || exit 0 DESTCONFIG=$DESTDIR/conf/md.conf echo "MD_DEGRADED_ARGS=' '" >> $DESTCONFIG exit 0 The impact of the bug on users: Systems with root on a RAID array will not be able to boot if the array is degraded. Usrs affected by this will encounter an unusable system after a reboot (say, a kernel upgrade). Justification for backporting the fix to the stable release: Hardy is a LTS edition. It is expected that people will continue to use this version and not upgrade to Intrepid. People who have upgrade from Dapper LTS to Hardy LTS are affected too. TEST CASE Build a clean system with root on RAID, with Ubuntu 8.04 LTS. Degrade the root array. Reboot and shiver. A discussion of the regression potential of the patch and how users could get inadvertently effected. - the only users that could be affected, as fas as know, are the ones that already made a workaround and altered their system files accordingly. Binary package hint: mdadm if i unplug one hd from raid1 i cannot successfully boot because raid starts only if all disks are available through : "${MD_DEGRADED_ARGS:= --no-degraded}" in /usr/share/initramfs-tools/scripts/local-top/mdadm my workaround is: /etc/initramfs-tools/hooks/startdegradedraid #!/bin/sh # # Copyright <C2><A9> 2006 Martin F. Krafft <madduck@debian.org> # based on the scripts in the initramfs-tools package. # released under the terms of the Artistic Licence. # # $Id: hook 281 2006-12-08 08:14:44Z madduck $ # set -eu PREREQ="udev" prereqs() { echo "$PREREQ" } case ${1:-} in prereqs) prereqs exit 0 ;; esac MDADM=$(command -v mdadm 2>/dev/null) || : [ -x $MDADM ] || exit 0 DESTCONFIG=$DESTDIR/conf/md.conf echo "MD_DEGRADED_ARGS=' '" >> $DESTCONFIG exit 0
2008-10-10 00:56:25 Steve Langasek initramfs-tools: status New Confirmed
2008-10-10 00:56:25 Steve Langasek initramfs-tools: statusexplanation
2008-10-10 00:56:48 Steve Langasek mdadm: status New Confirmed
2008-10-10 00:56:48 Steve Langasek mdadm: importance Undecided Medium
2008-10-10 00:56:48 Steve Langasek mdadm: statusexplanation
2008-10-10 00:57:10 Steve Langasek initramfs-tools: importance Undecided Medium
2008-10-10 03:03:31 agent 8131 bug added subscriber Ubuntu Stable Release Updates Team
2008-10-10 06:02:35 Dustin Kirkland  initramfs-tools: assignee kirkland
2008-10-10 06:03:12 Dustin Kirkland  mdadm: assignee kirkland
2008-11-04 16:54:11 Dustin Kirkland  initramfs-tools: status Confirmed In Progress
2008-11-04 16:54:11 Dustin Kirkland  initramfs-tools: assignee kirkland
2008-11-04 16:54:40 Dustin Kirkland  mdadm: status Confirmed In Progress
2008-11-04 16:54:40 Dustin Kirkland  mdadm: assignee kirkland
2008-11-04 16:54:40 Dustin Kirkland  mdadm: milestone ubuntu-8.04.2
2008-11-04 16:55:30 Dustin Kirkland  initramfs-tools: milestone ubuntu-8.04.2
2008-11-04 16:55:57 Dustin Kirkland  bug assigned to grub (Ubuntu)
2008-11-04 16:56:30 Dustin Kirkland  grub: status New In Progress
2008-11-04 16:56:30 Dustin Kirkland  grub: assignee kirkland
2008-11-04 16:56:30 Dustin Kirkland  grub: importance Undecided Medium
2008-11-04 16:56:30 Dustin Kirkland  grub: statusexplanation
2008-11-04 16:56:30 Dustin Kirkland  grub: milestone ubuntu-8.04.2
2008-11-04 16:56:49 Dustin Kirkland  grub: status New Fix Released
2008-11-04 16:56:49 Dustin Kirkland  grub: statusexplanation
2008-12-15 14:49:13 Dustin Kirkland  grub: status In Progress Fix Released
2008-12-15 14:49:29 Dustin Kirkland  initramfs-tools: status In Progress Fix Released
2008-12-15 14:49:52 Dustin Kirkland  mdadm: status In Progress Fix Released
2009-07-08 18:05:11 Nerd_bloke removed subscriber Nerd_bloke
2009-08-15 20:39:53 Dustin Kirkland  initramfs-tools: status Confirmed Fix Released
2009-08-15 20:41:37 Dustin Kirkland  grub (Ubuntu Hardy): assignee Dustin Kirkland (kirkland)
2009-08-15 20:41:58 Dustin Kirkland  initramfs-tools (Ubuntu Hardy): assignee Dustin Kirkland (kirkland)
2009-08-15 20:42:20 Dustin Kirkland  mdadm (Ubuntu Hardy): assignee Dustin Kirkland (kirkland)
2009-12-05 06:48:20 Launchpad Janitor branch linked lp:ubuntu/initramfs-tools
2010-10-19 09:22:23 Launchpad Janitor branch linked lp:~csurbhi/+junk/mdadm.fixes
2011-04-02 16:59:32 Francis Mak bug added subscriber Francis Mak
2012-04-11 07:49:17 Launchpad Janitor branch linked lp:ubuntu/intrepid/mdadm
2012-05-21 23:18:17 Launchpad Janitor branch linked lp:~dmitrij.ledkov/ubuntu/natty/mdadm/natty-updates
2013-10-16 05:33:56 Raymond A. Meijer bug added subscriber Raymond A. Meijer
2013-10-21 18:01:34 Hans Deragon bug added subscriber Hans Deragon