[patch] mdadm - initramfs script doesn't wait for udev rules to complete

Bug #1005457 reported by Ynot on 2012-05-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

I have a system using software RAID that seems to take a long time for the on-boot udev rules to complete.
This means that mdadm incorrectly thinks the array had degraded, when in fact the component devices are not yet ready

Symptoms:
- System fails to boot correctly, and drops into the initramfs recovery prompt
- On exiting the initramfs recovery prompt, mdadm array not assembled
- Array has to be assembled manually

Altering the initramfs mdadm script to wait for udev to settle down seems to solve the issue

--- /usr/share/initramfs-tools/scripts/mdadm-functions 2012-05-28 10:45:28.068832673 +0100
+++ /usr/share/initramfs-tools/scripts/mdadm-functions-new 2012-05-28 10:45:19.156845003 +0100
@@ -3,6 +3,7 @@

 degraded_arrays()
 {
+ udevadm settle
  mdadm --misc --scan --detail --test >/dev/null 2>&1
  return $((! $?))
 }

then rebuilding the initramfs
# update-initramfs -u

Ynot (tatkinson321) on 2012-05-28
affects: initramfs-tools (Ubuntu) → mdadm (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mdadm (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers