Package dependencies need work

Bug #884908 reported by Peter Sankauskas on 2011-11-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mcollective (Ubuntu)
Medium
Marc Cluet
Oneiric
Medium
Marc Cluet
Precise
Medium
Marc Cluet

Bug Description

---- SRU Justification (Marc Cluet) ----

TEST CASE 1:
1. sudo apt-get install mcollective-middleware
2. mcollective is not installed - it should be as this package wraps mcollective and rabbitmq into a single installable unit.

TEST CASE 2:
1. sudo apt-get install mcollective-client
2. sudo mc-find-hosts - will fail with the following error message:

/usr/lib/ruby/1.8/mcollective.rb:1:in `require': no such file to load -- rubygems (LoadError)
    from /usr/lib/ruby/1.8/mcollective.rb:1
    from /usr/sbin/mc-find-hosts:3:in `require'
    from /usr/sbin/mc-find-hosts:3

REGRESSION POTENTIAL:
It's just adding missing dependencies, regression potential almost 0 since we don't incur in any other changes.

COURSE OF ACTION FOR ONEIRIC:
Add the missing dependencies.

1. Add mcollective in mcollective-middleware package so it installs the missing daemon
2. Add rubygems, libsystemu-ruby or ruby-json on mcollective-clients package in order to fullfil missing dependencies

---- SRU Justification ----

This is actually a bug report for mcollective, mcollective-middleware and mcollective-client.

The package dependencies need to be looked at because as they stand now on Ubuntu 11.10 oneiric, they are not correct.

What I have discovered so far is:

mcollective-middleware need to depend on mcollective, otherwise the directory /etc/mcollective is not created.

At least mcollective-client needs to depends on 'rubygems'. Without it you receive the following:
$ mc-find-hosts
/usr/lib/ruby/1.8/mcollective.rb:1:in `require': no such file to load -- rubygems (LoadError)
    from /usr/lib/ruby/1.8/mcollective.rb:1
    from /usr/sbin/mc-find-hosts:3:in `require'
    from /usr/sbin/mc-find-hosts:3

I believe mcollective-middleware also needs to depend on rubygems, because the above error was replaced with "silence" after installing rubygems. Once I restarted the mcollective service, silence was replaced with the correct functionality.

Please let me know if you need more information.

Peter

Marc Cluet (lynxman) wrote :

Thanks Peter for your bug report, I'll investigate the dependencies and get back to you shortly if I need more information.

Changed in mcollective (Ubuntu):
assignee: nobody → Marc Cluet (lynxman)
Changed in mcollective (Ubuntu):
importance: Undecided → Medium
Marc Cluet (lynxman) on 2011-11-10
Changed in mcollective (Ubuntu):
status: New → In Progress
Marc Cluet (lynxman) wrote :

Update to mcollective-1.2.1-0ubuntu3 that solves the dependency issues

description: updated
Marc Cluet (lynxman) on 2011-11-11
Changed in mcollective (Ubuntu):
status: In Progress → Fix Committed

The attachment "mcollective_1.2.1-0ubuntu3.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Marc Cluet (lynxman) on 2011-11-23
Changed in mcollective (Ubuntu Oneiric):
assignee: nobody → Marc Cluet (lynxman)
status: New → Fix Committed
James Page (james-page) on 2011-11-23
Changed in mcollective (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in mcollective (Ubuntu Oneiric):
status: Fix Committed → In Progress
importance: Undecided → Medium
Marc Cluet (lynxman) on 2011-11-23
description: updated
description: updated
Marc Cluet (lynxman) wrote :

New debdiff with improved dependencies

James Page (james-page) on 2011-11-24
description: updated
Marc Cluet (lynxman) wrote :

Revised debdiff with proper version numbering

Marc Cluet (lynxman) on 2011-11-29
Changed in mcollective (Ubuntu Oneiric):
status: In Progress → Fix Committed

Hello Peter, or anyone else affected,

Accepted mcollective into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Using the packages from the updates repository I was able to recreate both bug reports. I then installed the packages from -proposed and was no longer able to recreate the bugs.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mcollective - 1.2.1-0ubuntu2.1

---------------
mcollective (1.2.1-0ubuntu2.1) oneiric-proposed; urgency=low

  * debian/control (LP: #884908)
    - Added dependency on mcollective for mcollective-middleware package
    - Added dependency for rubygems, libsystemu-ruby, ruby-json for
      mcollective-common package
 -- Marc Cluet <email address hidden> Mon, 28 Nov 2011 21:09:22 -0800

Changed in mcollective (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers