MC does not colorize different file types

Bug #541988 reported by Sergii Pylypenko on 2010-03-19
96
This bug affects 21 people
Affects Status Importance Assigned to Milestone
mc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mc

Midnight Commander does not colorize different file types, the setting "Options->Layout->Highlight->File types" does not have any effect.
Ubuntu Lucid Alpha2, MC 3:4.7.0-1ubuntu2 (lucid)

I've downloaded MC GIT repository, did "./configure && make && sudo make install" and it works as expected (version 4.7.1-73-g8948061).
It was also working in Karmic.

Sergii Pylypenko (x-pelya-x) wrote :

Seems to be duplicate of bug 507216

Detlef Lechner (detlef-lechner) wrote :

I have got the same bug.
uname -a
Linux T42 2.6.32-16-generic #25-Ubuntu SMP Tue Mar 9 16:33:52 UTC 2010 i686 GNU/Linux

Detlef Lechner (detlef-lechner) wrote :

I cannot confirm that this bug is a duplicate of bug #507216: bug #507216 complains about a bad layout. I cannot complain about a bad layout.

Yury V. Zaytsev (zyv) wrote :

This has been fixed in Debian (hopefully). We are trying to get the package uploaded, but we have to face eventual delays as we're running into unexpected rpath issues.

Changed in mc (Ubuntu):
status: New → In Progress
crazybyte (vlzoltan) wrote :

I also have this problem. I'm running Lucid Beta 2.

Yury V. Zaytsev (zyv) wrote :

See comments above yours...

vuser1 (vuser1) wrote :

Upgraded to 10.04, not beta. The problem is still here. Still rpath issues?

vuser1 (vuser1) wrote :

For those who want MC colors in lucid - install MC from launchad. Follow instructions here: http://www.midnight-commander.org/wiki/Binaries

No rpath issues anymore! :)

Yury V. Zaytsev (zyv) wrote :

We didn't get the fixed package into Debian on time, but requesting sync would be too late anyway, so if you want to have it fixed use the package from my PPA. Hopefully we will be on time for the next release.

Ivan A. Kosarev (ik-unicals) wrote :

OK, there is a missed file in the Debian distribution, but shouldn't there be some note in mc.ini be placed about the [Colors] section (hinting that it is moved out to filehighlight.ini or anything) and shouldn't mc executable complain about the (deprecated?) "--color" command-line options together with changing the related man page file? If the option is not deprecated, it probably should be fixed, because as is in the Lucid package, the option seem to be not working as well. Thanks.

Yury V. Zaytsev (zyv) wrote :

What's wrong exactly with the --color option? It just does not affect the file colors, but otherwise it should work.

Hrotkó Gábor (roti-al) wrote :

still not updated in the repo ...

Yury V. Zaytsev (zyv) wrote :

Instead of commenting you'd rather vote for this bug:

https://bugs.launchpad.net/ubuntu/+source/mc/+bug/565826

Yury V. Zaytsev (zyv) on 2010-07-10
Changed in mc (Ubuntu):
status: In Progress → Fix Committed
Yury V. Zaytsev (zyv) on 2010-08-12
Changed in mc (Ubuntu):
status: Fix Committed → Fix Released
Hrotkó Gábor (roti-al) wrote :

I've upgraded to 10.04.1 from karmic yesterday. Still no colors.

Changed in mc (Ubuntu):
status: Fix Released → New
Artúr (ikartur) wrote :

I have also upgraded from Karmic to Lucid today, and I can confirm that the colors still not working.
The following command fixes the problem:

apt-get source mc; sudo cp mc-4.7.0/misc/filehighlight.ini /etc/mc

Yury V. Zaytsev (zyv) wrote :

It's in Maverick now. Upgrade or use the packages from my PPA.

Changed in mc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers