mc: Slows down desktop to a crawl when copying/moving data to external usb disk

Bug #431207 reported by malheum
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Midnight Commander
Fix Released
Unknown
mc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mc

Hello,

I was just copying about 20GB of data from the internal hard disk to an external one using mc (midnight commander). Using mc the desktop almost freezes, at least it takes 4 minutes until firefox starts. Thunderbird does not show any emails anymore. Mp3 playback becomes horribly interrupted. Switching between applications takes ages.

Using top on a text console, I saw that the %wa (iowait) entry in 'top' gets up to 85% to 90% percent. Stopping the data copy in mc restores the good behaviour of the desktop.

I then tried moving the data with mv. There is no iowait using mv, the desktop keeps responsive, only the %us (user space) entry in top shows some 80% percent, but that does not seem to slow down my desktop.

I think that mc should change it's behaviour when copying to that used by mv.

$ lsb_release -rd
Description: Ubuntu 8.04.3 LTS
Release: 8.04

$ apt-cache policy mc
mc:
  Installiert:1:4.6.1-8ubuntu1
  Mögliche Pakete:1:4.6.1-8ubuntu1
  Versions-Tabelle:
 *** 1:4.6.1-8ubuntu1 0
        500 http://de.archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

This is on a Pentium M 1200MHz.

This is the external usb disk:
Bus 004 Device 004: ID 0d49:5020 Maxtor

Revision history for this message
Yury V. Zaytsev (zyv) wrote :

What's the FS on the external drive? Can you try newer packages to see whether the issue is resolved? The version of mc bundled with Hardy is really ancient and buggy.

https://launchpad.net/~zyv/+archive/ppa/+packages

Revision history for this message
Selmi (selmi) wrote :

i noticed such problem on ordinary builin disk when filesystem is ntfs and file is long (~gigabytes)

Revision history for this message
Yury V. Zaytsev (zyv) wrote :

Actually THIS sounds like an NTFS-3G problem (or even fuse nice / ionice settings in general). I also have this issue if I just use cp on ntfs-3g mounted volume.

Revision history for this message
malheum (maxheise) wrote :

I have since upgraded to 10.04, both 64 and 32 bit. I haven't noticed the behaviour I described above since then. The mc in 10.04 really copies as fast as cp on the command line.

Regarding the filesystem type: I have all my external drives formated with ext3 and still mc on Ubuntu 8.04 used to copy data very slowly to external disk.

The problem with ntfs on older Linux boxes (I don't remember the versions anymore) happens when the ntfs cluster size != 4096, then things really are slooooooooooow. This is an ntfs driver problem I encountered while trying to backup the ntfs filesystem of a friend's computer to external usb disk. There are quite some descriptions of that bug if you search the web.

Revision history for this message
Yury V. Zaytsev (zyv) wrote :
Changed in mc:
status: Unknown → New
Changed in mc:
status: New → Confirmed
Changed in mc:
status: Confirmed → Fix Released
Revision history for this message
gf (gf-interlinks-deactivatedaccount) wrote :

Hello Malheum,
Thank you for submitting this bug and reporting a problem with Thunderbird.

You made this bug report in 2009 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
Or, if it is still a problem, could you run the following (only once):
apport-collect 431207

and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.

G

Changed in mc (Ubuntu):
status: New → Incomplete
Revision history for this message
Yury V. Zaytsev (zyv) wrote :

Hey gf, this was certainly a mistake...

Changed in mc (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
gf (gf-interlinks-deactivatedaccount) wrote :

Thanks for updating the ticket, Yury!
Have a great day!
:)
G

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.