MC (Midnight Commander) does not wish to work with zip archives

Bug #397505 reported by UGN on 2009-07-09
144
This bug affects 40 people
Affects Status Importance Assigned to Milestone
mc (Debian)
Fix Released
Unknown
mc (Ubuntu)
Medium
UGN

Bug Description

Binary package hint: mc

in Karmic if i try enter into zip archive
i see only ".." (parrent directory)!!!

Related branches

UGN (eugene-korneev) on 2009-07-09
Changed in mc (Ubuntu):
assignee: nobody → UGN (eugene-korneev)
Peter Adamka (malmo) wrote :

Same issue here.
MC doesn't list any zip-related package (.zip, .jar) .

Changed in mc (Ubuntu):
status: New → Confirmed

MC doesn't work with unzip 6.0-1.
Unzip 5.x from Jaunty work ok.

Changed in mc (Debian):
status: Unknown → Fix Released
Jaromir Obr (jaromir-obr) wrote :

Workaround for unzip is setting $op_has_zipinfo=1 in /usr/share/mc/extfs/uzip
Used SW: Ubuntu 9.10, mc 4.6.2, unzip 6.0

mflorea (zmeuldumy) wrote :

@Jaromir Obr: Thanks for the workaround! I'm wondering why it was set to 0 if the recommended value is 1.

delph (delph) wrote :

Jaromir Obr: thanx too

Nikolai Bochev (n-bochev) wrote :

The fix is working, thanks !

StefanF (stefan) wrote :

Works also for me. Thanks.

Ben Okopnik (ben-okopnik) wrote :

Hi:

The actual fix requires changing the regex that parses the output of 'unzip -qq -v' (which has changed), as well as the code that uses the results of that regex. Here's the diff:

41,43c41,43
< # 2891 Defl:N 1435 50% 03-30-00 21:19 50cbaaf8 ./edit.html
< # (size) (method) (zippedsize) (zipratio) (mm)(dd)(yy)(HH)(MM) (cksum) (fname)
< my $regex_nonzipinfo_line = qr"^\s*(\d+)\s+(\S+)\s+(\d+)\s+(-?\d+\%)\s+(\d?\d)-(\d?\d)-(\d\d)\s+(\d?\d):(\d\d)\s+([0-9a-f]+)\s\s(.*)$";
---
> # 2891 Defl:N 1435 50% 2000-03-30 21:19 50cbaaf8 ./edit.html
> # (size) (method) (zippedsize) (zipratio) (yyyy)(mm)(dd)(HH)(MM) (cksum) (fname)
> my $regex_nonzipinfo_line = qr"^\s*(\d+)\s+(\S+)\s+(\d+)\s+(-?\d+\%)\s+(\d{4})-(\d?\d)-(\d\d)\s+(\d?\d):(\d\d)\s+([0-9a-f]+)\s\s(.*)$";
265c265
< $match[6] + ($match[6] < 70 ? 2000 : 1900), $match[4], $match[5],
---
> $match[4], $match[5], $match[6],

Please let me know if this needs to be submitted in some other way.

Changed in mc (Ubuntu):
status: Confirmed → Triaged
tags: added: regression-release
Changed in mc (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (6.5 KiB)

This bug was fixed in the package mc - 3:4.7.0-1ubuntu1

---------------
mc (3:4.7.0-1ubuntu1) lucid; urgency=low

  * Merge from Debian unstable, remaining changes:
    + 11_unzip_needs_regex_update_lp397505.patch: Update regex for new
      output of "unzip -qq -v" and code using regex (LP: #397505).
      Thanks, Ben Okopnik!
    - mc-4.6.2-utf8.patch: No longer applicable; drop

mc (3:4.7.0-1) unstable; urgency=low

  [ Patrick Winnertz ]
  * Fix misleading description of mc and mc-dbg:
        SMB protocol is not further possible with mc, due to security
        issues. (Closes: #541267)
  * Added patch to fix codejump if there is a number in the function name
  * Added patch to fix the broken german date in the mc panels
    (Closes: #541104)
  * Added patch to enable .gem archives. (Closes: #541673)
  * Added several bugfixes for crashes or malbehaviour which are fixed in
    upstreams git for 4.7.0-pre2.
  * Added note about user-defined colors in README.Debian (Closes: #392262)

  [ Denis Briand ]
  * New upstream version.
    + (Closes: #544996)
    + (Closes: #390301)
    + (Closes: #562371)
  * Switch to the new source package formats "3.0 (quilt)".
  * Hack Debian watch file to fix issue with the new upstream repository.
  * Bump Standards-Version to 3.8.3.
  * Add debian/README.source file.
  * mime-support is now a Recommended package.
  * Use mailcap entry to choose pdf viewer (Closes: #544054).
  * Use mailcap entry to choose images viewer (Closes: #544058).
  * Change doc-base Document field into lower-case name.
  * Change doc-base Section field into `File Management'.
  * Escape few minus sign again into manpages.
  * Add ico files support (Closes: #546737).
  * Suggest gv package to read ps files into X.
  * Use catdvi instead of dvi2tty (Closes: #543202).
  * Suggest catdvi to preview dvi files on text-only devices.
  * Add djvu files support and suggest djvulibre-bin package (Closes: #543651).
  * Allow Debian Maintainers Uploads.
  * Use sensible-editor to edit files (Closes: #549202).
  * Downgrade imagemagick dependency to Suggests (Closes: #550234).
  * Use DEB_BUILD_OPTIONS to chose the number of building processes
    (Closes: #549658).
  * Add Yury V. Zaytsev into Uploaders field.
  * Add python, python-boto and python-tz into Suggests field,
    for vfs Amazon Web Services S3.

  [ Yury V. Zaytsev ]
  * Remove FTP chattr patch (upstream ticket #1708).
  * Remove symlink patch (upstream ticket #1828).
  * Remove upstreamed documentation patches (upstream ticket #1691).

mc (2:4.7.0-pre1-3) unstable; urgency=low

  [ Patrick Winnertz ]
  * Fix layout issue in the info page (Closes: #539958)
  * Fix escape of ~ in ~/Desk or something similar (Closes: #520026)
  * Mention in README.Debian that a different TERM on gnome-terminal
    prevents the cursor from vanishing in mcedit over tabs.
  * Add patch to make wildcards in copy/remove/move dialog work again
    (Closes: #540110)
  * shift-F3 doesn't unmark the selection after copying anymore
    (Closes: #302513)
  * Every fish operation is now placed within a if, so if there are errors
    because of permissions or something else, this is now reported
    (Closes: #4...

Read more...

Changed in mc (Ubuntu):
status: Triaged → Fix Released
Tomasz Czapiewski (xeros) wrote :

Why don't you backport the fixed package into Karmic? This fix is really needed and for now workaround needs to be done of every machine it's installed...

Tomasz Czapiewski (xeros) wrote :

In Karmic the patches posted here are not enough (I haven't tested Lucid package).
There's a problem with directories inside zip archives.
The files are listed in mc like:
| Directory\File.txt | 10 | 01.01.2008 |
and files could not be opened because of bad directory and file separator "\" where it should be "/".

Is it will be patch for 9.10 ubuntu or not?

Its very annoying that I can't list archive zip files content directly from mc.... Its simple neeeded for me and I think for many users which suprisingly see lack of this simple mc feature..

Yury V. Zaytsev (zyv) wrote :

No fix will be released for Ubuntu 9.10. If you need backports from Debian unstable use my unofficial PPA.

Hi Yury! I've just installed mc from your PPA tested and it's fixes my problem. Thanks! :-)

Lars (lars-taeuber) wrote :

Hi,

Ben Okopniks changes work for me too.

Thanks
Lars

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.