mc compare directories (thorough) thinks empty files are different

Bug #181034 reported by Marius Gedminas on 2008-01-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Midnight Commander
Fix Released
Unknown
mc (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: mc

Command -> Compare directories -> Thorough thinks two empty files with the same name are somehow different.

Steps to reproduce:

  mkdir /tmp/1 /tmp/2
  touch /tmp/1/empty /tmp/2/empty
  echo a > /tmp/1/nonempty
  echo a > /tmp/2/nonempty
  mc

go to /tmp/1 in one pane and /tmp/2 in another
press ctrl-x d t

Expected result: no files selected

Actual result: the files named 'empty' are selected

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in mc:
status: New → Incomplete
Marius Gedminas (mgedmin) wrote :

Yes.

Dimitrios Symeonidis (azimout) wrote :

confirmed also in jaunty
priority=low

Changed in mc (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Changed in mc:
status: Unknown → New
Changed in mc:
status: New → Confirmed
Changed in mc:
status: Confirmed → Fix Released
Dimitrios Symeonidis (azimout) wrote :

there seems to be a fix upstream, marking as fix committed

Changed in mc (Ubuntu):
status: Confirmed → Fix Committed
Przemek K. (azrael) wrote :

Fixed upstream but not fixed in Karmic.
Probably gotta wait for a new upstream release.

Yury V. Zaytsev (zyv) on 2010-08-12
Changed in mc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.