mbt version 3.2.5-3 failed to build on armel

Bug #791318 reported by Ricardo Salveti on 2011-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mbt (Debian)
Fix Released
Unknown
mbt (Ubuntu)
Undecided
Unassigned

Bug Description

mbt version 3.2.5-3 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+source/mbt/3.2.5-3/+build/2480226

Direct link to the build log: https://launchpad.net/ubuntu/+source/mbt/3.2.5-3/+build/2480226/+files/buildlog_ubuntu-oneiric-armel.mbt_3.2.5-3_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 643 lines into the build log:

/usr/lib/libtimbl.so: undefined reference to `omp_get_thread_num'
/usr/lib/libtimbl.so: undefined reference to `omp_get_num_threads'
/usr/lib/libtimbl.so: undefined reference to `GOMP_parallel_start'
/usr/lib/libtimbl.so: undefined reference to `GOMP_critical_start'
/usr/lib/libtimbl.so: undefined reference to `GOMP_parallel_end'
/usr/lib/libtimbl.so: undefined reference to `omp_set_num_threads'
collect2: ld returned 1 exit status
make[3]: *** [mbt] Error 1
make[3]: Leaving directory `/build/buildd/mbt-3.2.5/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/mbt-3.2.5'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/mbt-3.2.5'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110512-2202
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/mbt-3.2.5

Julian Taylor (jtaylor) wrote :

this should also be caused by the missing openmp linkage of timbl

Iulian Udrea (iulian) on 2011-07-05
Changed in mbt (Ubuntu):
status: New → Triaged
Changed in mbt (Debian):
status: Unknown → New
Ricardo Salveti (rsalveti) wrote :

3.2.5-3.1 built fine for armel.

Changed in mbt (Ubuntu):
status: Triaged → Fix Released
Changed in mbt (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.