ipython mayavi session - change of syntax

Bug #998718 reported by eldad on 2012-05-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mayavi2 (Ubuntu)
Undecided
Unassigned

Bug Description

This is not a true bug but there has been a change of syntax (starting with ubuntu 12.04)
which was not evident for me (and I could not find the full correct syntax anywhere else in the web).
Therefore I decided to put it here, hoping it would save others some time...

on previous ubuntu versions I used to use mayavi's module "mlab" within an ipython + pylab session, using the following command:

    ipython -wthread -pylab

After updating to ubuntu 12.04 this no longer works.
Searching the web I found that pylab should be called using --pylab (double dash instead of a single one)
and -wthread should be replaced with --gui=wx (again, a double dash is required).

trying:

    ipython --pylab --gui=wx

(as well as interchanging the order of the arguments) failed.
First due to python-gtkwx problem which I reported (and some solution is proposed) here: https://bugs.launchpad.net/ubuntu/+source/wxwidgets2.8/+bug/998716
Next there was a problem with the behaviour of the mayavi window, invoked in ipython using (for example):

    from mayavi import mlab
    mlab.points3d(0,0,0,color=(1,0,0))

The plot was unresponsive.
To make it interactive I had to run:

     mlab.show()

which turned the ipython session unresponsive till the mayavi window was closed.

Finally, I started the session using:

    ipython --gui=wx --pylab=wx

(so far, works also when omitting "--gui=wx")

For those who would like to run in the "notebook" flavour, inlining the pylab plots:

    ipython notebook --gui=wx --pylab inline

works nicely so far...
I hope this is useful for other users as well.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mayavi2 4.0.0-3build1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun May 13 13:23:08 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: mayavi2
UpgradeStatus: Upgraded to precise on 2012-04-29 (13 days ago)

eldad (eldad-a) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mayavi2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers