Imported VTK version (5.1) does not match the one used to build the TVTK classes (5.8).

Bug #1539224 reported by Kevin on 2016-01-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mayavi2 (Ubuntu)
Medium
Unassigned

Bug Description

If I use mayavi via from mayavi import mlab I get the following error message:

from mayavi import mlab
********************************************************************************
WARNING: Imported VTK version (5.1) does not match the one used
         to build the TVTK classes (5.8). This may cause problems.
         Please rebuild TVTK.
********************************************************************************

[einstein:06536] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file ess_singleton_module.c at line 231
[einstein:06536] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file ess_singleton_module.c at line 140
[einstein:06536] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file runtime/orte_init.c at line 128
--------------------------------------------------------------------------
Sorry! You were supposed to get help about:
    orte_init:startup:internal-failure
But I couldn't open the help file:
    /usr/share/openmpi/help-orte-runtime: No such file or directory. Sorry!
--------------------------------------------------------------------------
--------------------------------------------------------------------------
Sorry! You were supposed to get help about:
    mpi_init:startup:internal-failure
But I couldn't open the help file:
    /usr/share/openmpi/help-mpi-runtime: No such file or directory. Sorry!
--------------------------------------------------------------------------
--------------------------------------------------------------------------
Sorry! You were supposed to get help about:
    mpi_errors_are_fatal unknown handle
But I couldn't open the help file:
    /usr/share/openmpi/help-mpi-errors.txt: No such file or directory. Sorry!
--------------------------------------------------------------------------
--------------------------------------------------------------------------
Sorry! You were supposed to get help about:
    ompi mpi abort:cannot guarantee all killed
But I couldn't open the help file:
    /usr/share/openmpi/help-mpi-runtime.txt: No such file or directory. Sorry!

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: mayavi2 4.3.1-4.1
ProcVersionSignature: Ubuntu 4.2.0-27.32-generic 4.2.8-ckt1
Uname: Linux 4.2.0-27-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
Date: Thu Jan 28 20:13:13 2016
InstallationDate: Installed on 2013-11-22 (797 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: mayavi2
UpgradeStatus: Upgraded to wily on 2015-12-10 (48 days ago)

Kevin (kevin999) wrote :
Gael Varoquaux (gael-varoquaux) wrote :

Given that this echos messages about MPI, I wouldn't be surprised that it is the same bug as:

https://bugs.launchpad.net/bugs/1520306

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mayavi2 (Ubuntu):
status: New → Confirmed
Changed in mayavi2 (Ubuntu):
importance: Undecided → Medium
Kevin (kevin999) wrote :

Is there any workaround?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers