Sometimes app windows come up undecorated, unselectable, and not full screen

Bug #522858 reported by Paul Larson on 2010-02-16
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Maximus
High
Jason Smith
maximus (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: maximus

I'm currently running on the imx51 lucid armel UNE image. I'm seeing a strange effect, where sometimes I will open an application and it will not come up full screened by maximus, but it will be undecorated and I cannot select the window. For instance, in the case of gnome-terminal I can use the menu, but I cannot select the terminal area and type in it. I will attach a screen shot. I've also seen it happen with a few other applications, such as software center. It doesn't happen everytime, but frequently enough to say that I've been able to reproduce it 2 or 3 times today.

ProblemType: Bug
Architecture: armel
Date: Tue Feb 16 15:05:53 2010
DistroRelease: Ubuntu 10.04
GConfNonDefault:
 /apps/maximus/exclude_class=[Empathy,Totem,Gwibber,Gnome-language-selector,Gtk-recordMyDesktop]
 /apps/maximus/no_maximize=false
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha armel+imx51 (20100205)
Package: maximus 0.4.14-0ubuntu4
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-604.6-imx51
SourcePackage: maximus
Uname: Linux 2.6.31-604-imx51 armv7l

Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :

Still seeing this in current image, also saw it with ubiquity when trying to test install of beta 1 candidate on imx51

tags: added: iso-testing
Didier Roche (didrocks) wrote :

@Paul: it seems on the screenshot that you didn't have window pickler activated. This can be related. Did you remove it from the panel in the session, did it crash?

Steve Langasek (vorlon) on 2010-03-23
Changed in maximus (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2010-03-23
Changed in maximus:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
status: New → Triaged
Paul Larson (pwlars) wrote :

Argh, I didn't see that this got duped to an old bug that's been closed a while (bug #291013). @Didier, window picker applet was enabled, and did not crash, but things don't seem to get drawn right on the screen when this bug gets hit. I can't even interact with the window correctly, all I can do to try to recover from it is click on file->exit. So it has a pretty simple workaround, doesn't happen terribly frequently, but does still happen and is very annoying when it does.

Changed in maximus (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Paul Larson (pwlars) wrote :

I believe this is worth trying to fix for lucid if at all possible, or sru if not.

Didier Roche (didrocks) wrote :

@Paul, please ping asac. I've given him the info for his team (who is in charge on the 2D launcher) to get the same setting than the 3D one.

I still don't have that in the 3D launcher, so I really guess this is a missing configuration in the 2D session.

Steve Langasek (vorlon) on 2010-04-16
Changed in maximus (Ubuntu Lucid):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

reassign to Jamie after ack from asac (see my comment #7)

Tobin Davis (gruemaster) wrote :

Another issue that we (Paul Larson and I) see is that occasionally after launching gnome-terminal, the current working directory will be /usr/share/icons/Humanity/apps/48 as opposed to ~/. This happens ~ 20% of the time for me.

Steve Langasek (vorlon) wrote :

This seems never to have actually gotten assigned to Jamie? Doing so now

Changed in maximus (Ubuntu Lucid):
assignee: Didier Roche (didrocks) → Jamie Bennett (jamiebennett)
Alexander Sack (asac) wrote :

moved to lucid-updates.

Changed in maximus (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
Jamie Bennett (jamiebennett) wrote :

Reassign to mterry as he is looking after the 2D launcher now.

Changed in maximus (Ubuntu Lucid):
assignee: Jamie Bennett (jamiebennett) → Michael Terry (mterry)
Tobin Davis (gruemaster) on 2011-02-08
Changed in maximus (Ubuntu Lucid):
status: New → Won't Fix
status: Won't Fix → Confirmed
Changed in maximus (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2011-03-09
Changed in maximus (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Changed in maximus (Ubuntu Lucid):
assignee: Michael Terry (mterry) → nobody
gray380 (gray380) wrote :

Seems that I've registered the similar bug: Bug #878712

Tobin Davis (gruemaster) on 2012-03-09
Changed in maximus (Ubuntu Lucid):
status: Confirmed → Won't Fix
Changed in maximus (Ubuntu):
milestone: lucid-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers