maxima fails at launch at command line with said error message

Bug #1926362 reported by Kenneth Florek
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
maxima (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Fresh installation of Ubuntu desktop 21.04 from iso on flash drive. Maxima is definitely installed.
Desktop is standard (gnome). Same error whether ubuntu is started standard (wayland) or as xorg.

"The assertion realpath(s,o) on line 471 of main.c in function mbin failed: Invalid argumentAborted (core dumped)"

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: maxima 5.44.0-2
ProcVersionSignature: Ubuntu 5.11.0-16.17-generic 5.11.12
Uname: Linux 5.11.0-16-generic x86_64
ApportVersion: 2.20.11-0ubuntu65
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 27 16:42:17 2021
InstallationDate: Installed on 2021-04-24 (3 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Release amd64 (20210420)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: maxima
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Kenneth Florek (kflorek-newsguy) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maxima (Ubuntu):
status: New → Confirmed
Revision history for this message
Yves Roggeman (yrogge) wrote :

Same bug as 1926225 ?

Revision history for this message
Peter (peter-schmitteckert) wrote :

Yes, the same problem as 1926225.

Revision history for this message
Artur Schmitt (arturschmitt) wrote :

I have the same problem. The error message is: The assertion realpath(s,o) on line 471 of main.c in function mbin failed: Invalid argumentAbortado (`core' generado).

This seems also to be the problem why the wxmaxima (gui for maxima) is not working properly.

Revision history for this message
Yves Roggeman (yrogge) wrote :

It not linked to wxmaxima, but due to maxima itself.
If you launch maxima from terminal, you will have exactly the same error message.

Revision history for this message
Mohamed Ibrahim (mibrahim) wrote :

Same issue - failure to launch both maxima command line and wxmaxima. Freshly installed 21.04

Revision history for this message
buddyd16 (donnieb) wrote :

Same issue here as well.

The recommendation from here to grab the 21.10 package fixes it on my end:
https://askubuntu.com/questions/1345669/how-to-install-maxima-cas-on-ubuntu-21-04

Changed in maxima (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers