KnownFailure should not be registered as a global nose plugin

Bug #871176 reported by Fernando Perez on 2011-10-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
matplotlib (Ubuntu)
Low
Unassigned

Bug Description

Currently there's this in the ubuntu oneiric package:

amirbar[matplotlib-1.0.1.egg-info]> pwd
/usr/share/pyshared/matplotlib-1.0.1.egg-info
amirbar[matplotlib-1.0.1.egg-info]> cat entry_points.txt
[nose.plugins]
KnownFailure = matplotlib.testing.noseclasses:KnownFailure

this causes no end of trouble, such as the IPython test suite failing.

Please don't register this as a global nose plugin, it's really meant only for matplotlib use. In fact it was copied from numpy. We'll work in mpl to hide it further and only expose our copy if we can't find the numpy one, but the ubuntu package should NOT expose this as a global nose plugin AT ALL.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in matplotlib (Ubuntu):
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

this issue was fixed version 1.1.0-1 available in precise.

Changed in matplotlib (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → Low
Fernando Perez (fdo.perez) wrote :

Many thanks, @jtaylor!

Any chance the fix could be backported to 11.10? It's a trivial fix and means that right now, nobody can safely run the ipython test suite on 11.10... And it may also affect other packages that also try to use numpy's KnownFailure plugin. Given how tricky to debug the problem is if you get hit by it (in the ipython case, two expert developers independently wasted several hours each trying to sort it out), it would be great to see it fixed in the current ubuntu.

Julian Taylor (jtaylor) wrote :

the fix does look simple but matplotlib is a complicated package with many reverse dependencies. Even only rebuilding it could cause unforseeable issues which can get difficult and time consuming to resolve.
I think ensuring that matplotlib keeps working for regular users is preferable to resolving this issue for developers using this particular feature.
but should an more severe usability issue require a stable update this fix should be added too.

Fernando Perez (fdo.perez) wrote :

Fair enough, I understand such concerns. Thanks again for handling it so promptly!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers