[ftbfs] matita0.5.7-2 fails to build for i386 in karmic

Bug #384758 reported by Andrea Gasparini on 2009-06-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
matita (Debian)
Fix Released
Unknown
matita (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: matita

Matita fails to build in karmic, as you can see here:
http://launchpadlibrarian.net/27574114/buildlog_ubuntu-karmic-i386.matita_0.5.7-2~ppa1_FAILEDTOBUILD.txt.gz

'cause it attempts to download a file from docbook site while building.

Related branches

Andrea Gasparini (gaspa) on 2009-06-08
Changed in matita (Ubuntu):
assignee: nobody → Andrea Gasparini (gaspa)
status: New → In Progress
Changed in matita (Debian):
status: Unknown → New
Andrea Gasparini (gaspa) wrote :
Changed in matita (Ubuntu):
assignee: Andrea Gasparini (gaspa) → nobody
status: In Progress → Confirmed
Morten Kjeldgaard (mok0) wrote :

I still get FTBFS on the patched package. The build fails with a very strange error:

matitac demo/power_derivative.ma OK 0m08.60s 0m04.79s 0m00.05s
mv: cannot move `/dev/shm/matita.db.builder._build_mok-matita_0_5_7-2ubuntu1-amd64-j0N5Mn_matita-0_5_7-2ubuntu1_debian_tmp___usr_share_matita__matita.26767' to `/build/mok-matita_0.5.7-2ubuntu1-amd64-j0N5Mn/matita-0.5.7-2ubuntu1/debian/tmp///usr/share/matita/.matita/user.db': No such file or directory
destroy
Fatal error: out of memory.

My rig has 6Gb of RAM. This is weird.

Andrea Gasparini (gaspa) wrote :

what? Yep, really weird... what kind of builder are you using?!

Imho is more probably an issue of your builder, than the package... could you try with another one? perhaps somelike like pbuilder more than just ppa, given that I tried the latter.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package matita - 0.5.7-2ubuntu1

---------------
matita (0.5.7-2ubuntu1) karmic; urgency=low

  * Fix FTBFS: (LP: #384758)
    - debian/patches/nonet.dpatch: use --nonet calling xsltproc to generate
      docs
    - debian/control: added build-dependency to docbook-{xsl,xml} packages

 -- Andrea Gasparini <email address hidden> Sat, 06 Jun 2009 09:55:37 +0200

Changed in matita (Ubuntu):
status: Confirmed → Fix Released
Andrea Veri (av) wrote :

removing u-u-s. No sponsorship seems to be needed.

Changed in matita (Debian):
status: New → Fix Committed
Changed in matita (Debian):
status: Fix Committed → New
Changed in matita (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.