mate-screenshot crashed with SIGSEGV in gdk_property_get()

Bug #1615848 reported by ernsteiswuerfel on 2016-08-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mate-utils (Ubuntu)
Undecided
Unassigned

Bug Description

mate-screenshot always crashes when doing a 'grab the current window'-screenshot. Doing a screenshot of the whole desktop works. Tested on Yakketys daily iso on my PowerMac G5 7,3.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: mate-utils 1.14.0-1
ProcVersionSignature: Ubuntu 4.4.0-9134.53-powerpc64-smp 4.4.15
Uname: Linux 4.4.0-9134-powerpc64-smp ppc64
ApportVersion: 2.20.3-0ubuntu7
Architecture: powerpc
CasperVersion: 1.377
CurrentDesktop: MATE
Date: Mon Aug 22 22:39:07 2016
ExecutablePath: /usr/bin/mate-screenshot
LiveMediaBuild: Ubuntu-MATE 16.10 "Yakkety Yak" - Alpha powerpc (20160822)
ProcCmdline: mate-screenshot --interactive
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: mate-utils
StacktraceTop:
 gdk_property_get () from /usr/lib/powerpc-linux-gnu/libgdk-3.so.0
 screenshot_get_window_title ()
 ?? ()
 ?? ()
 ?? () from /lib/powerpc-linux-gnu/libglib-2.0.so.0
Title: mate-screenshot crashed with SIGSEGV in gdk_property_get()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

ernsteiswuerfel (erhard-f) wrote :
information type: Private → Public
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1615848

tags: added: iso-testing
ernsteiswuerfel (erhard-f) wrote :

Seems a PPC-specific problem. My amd64 box does not get hit by this bug.

StacktraceTop:
 ?? ()
 screenshot_get_window_title ()
 screenshot_get_window_title ()
 ?? ()
 ?? ()

Changed in mate-utils (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for libflac8

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-powerpc-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers