mate-tweak wrongly detects only 2 panel layouts - GNOME2 and OpenSuSE instead of many others

Bug #1894386 reported by Norbert on 2020-09-05
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
mate-tweak (Ubuntu)
High
Martin Wimpress

Bug Description

Steps to reproduce:
1a. Boot Ubuntu MATE 20.10 live session
1b. Have Ubuntu MATE 20.10 installed
2. Launch MATE Tweak
3. Switch to Panel tab
4. Click on *Select panel layout to change the user interface* dropdown menu

Expected results:
* many panel layouts are presented, use can switch to any of it

Actual results:
* only 2 panel layouts are shown - GNOME2 and OpenSuSE instead

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: mate-tweak 20.04.0-2
ProcVersionSignature: Ubuntu 5.8.0-18.19-generic 5.8.4
Uname: Linux 5.8.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu45
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.452
CurrentDesktop: MATE
Date: Sat Sep 5 16:38:38 2020
LiveMediaBuild: Ubuntu-MATE 20.10 "Groovy Gorilla" - Alpha amd64 (20200905)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mate-tweak
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

Some extra output from the live system:

```
$ dpkg -S .layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/familiar.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/mutiny.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/ubuntu-mate.layout
mate-panel: /usr/share/mate-panel/layouts/ubuntu.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/netbook.layout
mate-panel: /usr/share/mate-panel/layouts/opensuse.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/pantheon.layout
mate-panel: /usr/share/mate-panel/layouts/default.layout
mate-panel: /usr/share/mate-panel/layouts/mageia.layout
mate-panel: /usr/share/mate-panel/layouts/linuxmint.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/redmond.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/eleven.layout
ubuntu-mate-default-settings: /usr/share/mate-panel/layouts/contemporary.layout
mate-panel: /usr/share/mate-panel/layouts/fedora.layout

```

So the panel *layouts* are actually installed.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1894386

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-tweak (Ubuntu):
status: New → Confirmed
Sai Vinoba (saivinoba) on 2020-09-06
Changed in ubuntu-mate:
status: New → Confirmed
Sai Vinoba (saivinoba) wrote :

Layouts are accessible from 'Welcome' application and changeable as well. Only not showing in MATE Tweak.

Sai Vinoba (saivinoba) wrote :

The condition for `self.indicators_available = True` is not satisfied in `mate-tweak`. The only items listed, 'GNOME2' and 'OpenSUSE' have test `not self.indicators_available` set which is satisfied.

Installing `indicator-datetime` (if you had removed it) and `indicator-session` will get back the full panel list.

Since we are moving to ayatana-indicators the datetime and session conditions need to be updated.

Changed in ubuntu-mate:
status: Confirmed → Invalid
Changed in mate-tweak (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mate-tweak - 20.10.0-0ubuntu1

---------------
mate-tweak (20.10.0-0ubuntu1) groovy; urgency=medium

  * New upstream release. (LP: #1894386)
  * debian/patches:
    + Drop 1002_ensure_object_names_are_distinct.patch. Applied upstream.
    + Drop 1001_adhere_to_hig.patch. Applied upstream.
    + Drop 1000_avoid_killing_brisk_unnecessarily.patch. Applied upstream.

 -- Martin Wimpress <email address hidden> Sun, 20 Sep 2020 12:32:24 +0100

Changed in mate-tweak (Ubuntu):
status: Fix Committed → Fix Released
Norbert (nrbrtx) wrote :

Fixed in 20200921 ISO.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.