mate-screensaver SegFault when it autostarts. Prevents system from sleeping or exiting sleep

Bug #1947905 reported by Jonathan Polak
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
mate-menus (Ubuntu)
Confirmed
Undecided
Unassigned
mate-screensaver (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Expected behaviour
Upon reaching specified amount of time of no activity, screen-saver engages

Actual behaviour: Screensaver crashes with segFault. Black screen results, system cannot enter or exit sleep.

Steps to reproduce the behaviour: allow the screensaver timeout to elapse. Screensaver should turn on. Instead it gives black-screen and prevents sleep from starting

MATE general version 1.26

Package version: Starting with 1.26.0-0ubuntu / previous packages were ok

Linux Distribution: Ubuntu Mate 21.10

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: mate-screensaver 1.26.0-0ubuntu1
ProcVersionSignature: Ubuntu 5.13.0-20.20-generic 5.13.14
Uname: Linux 5.13.0-20-generic x86_64
ApportVersion: 2.20.11-0ubuntu70
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: MATE
Date: Wed Oct 20 13:10:14 2021
InstallationDate: Installed on 2021-02-05 (256 days ago)
InstallationMedia: Ubuntu-MATE 20.10 "Groovy Gorilla" - Release amd64 (20201022)
SourcePackage: mate-screensaver
UpgradeStatus: Upgraded to impish on 2021-10-15 (5 days ago)

Revision history for this message
Jonathan Polak (jpolak) wrote :
Revision history for this message
Jonathan Polak (jpolak) wrote :
summary: - mate-screensaver SegFault when the auto-start timer elapses
+ mate-screensaver SegFault when it autostarts. Prevents system from
+ sleeping or exiting sleep
Revision history for this message
Norbert (nrbrtx) wrote :

Do you see the same symptoms as in bug 1943369 ?

Revision history for this message
Jonathan Polak (jpolak) wrote :

I can't see their syslog, but, from the files they uploaded it shows that their crash involves both libmate-menu and mate-screensaver. I see from my journal that it also involves both of those. Moreover, the SegFaults started happening after update to IMPISH. There are no segFaults in these processes prior

HERE ARE THE journal entires FROM MATE-SCREENSAVER AND LIBMATE-MENU
(attached file) -- started on oct 15, after upgrade to 21.10

Revision history for this message
Jonathan Polak (jpolak) wrote :

This bug affects both AMD and Intel architecture. this bug is on AMD, the linked duplicate bug was on intel architecture.

Norbert (nrbrtx)
tags: added: jamm
removed: third-party-packages
tags: added: jammy
removed: jamm
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-screensaver (Ubuntu):
status: New → Confirmed
Revision history for this message
Adam Funk (a-funk) wrote :

I'm having this problem on a laptop that was installed with Ubuntu 21.04, just upgraded to 21.10. Excerpt from syslog attached.

When this happens, I can't figure out a way to get into the computer without shutting down (power button) and restarting. The virtual terminals are unavailable! A workaround would be greatly appreciated, even something hacky like detecting the crash and restarting the screensaver.

Revision history for this message
Adam Funk (a-funk) wrote :

Now I don't think the problem is in the mate-screensaver package itself. I reverted to version 1.24.2-0ubuntu1 for a week and still had it happen occasionally: I'd come back to the computer to find a black screen and no amount of typing or mouse-jiggling would bring up the unlock dialog. I have to ssh in and use 'sudo service lightdm restart' to fix it (losing whatever is running in the GUI).

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-menus (Ubuntu):
status: New → Confirmed
Revision history for this message
Dani Llewellyn (diddledani) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch from upstream PR #262 on mate-screensaver which purportedly fixes this issue" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1947905

tags: added: iso-testing
Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on Jammy. Should be fixed before final release.

Changed in mate-screensaver (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.