MATE screensaver doesn't unlock with unlock button

Bug #1471454 reported by Lyn Perrine on 2015-07-04
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
mate-screensaver (Ubuntu)
High
Martin Wimpress

Bug Description

On ubuntu-mate wiley amd 64 install to the entire disk. then reboot and get away from the keyboard for long enough for the screensaver to activate itself. Then the Ubuntu mate logo shows up as the screensaver. move the mouse to get to the unlock screen enter your password and press unlock. The screen will change then go back to to the screensaver and you can try to unlock again.
mate-screensaver:
  Installed: 1.8.1-2
  Candidate: 1.8.1-2
  Version table:
 *** 1.8.1-2 0
        500 http://us.archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

I expected after entering my password to unlock to have the screen unlock. Instead I got taken back to the lock screen until I selected switch user and then logged back into my session in lightdm. Logging in through switch user is a workaround for this problem.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: mate-screensaver 1.8.1-2
ProcVersionSignature: Ubuntu 3.19.0-22.22-generic 3.19.8-ckt1
Uname: Linux 3.19.0-22-generic x86_64
ApportVersion: 2.17.3-0ubuntu4
Architecture: amd64
CurrentDesktop: MATE
Date: Sat Jul 4 11:42:15 2015
InstallationDate: Installed on 2015-07-04 (0 days ago)
InstallationMedia: Ubuntu-MATE 15.10 "Wily Werewolf" - Alpha amd64 (20150704)
SourcePackage: mate-screensaver
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1471454

tags: added: iso-testing

Same problem here with mate under ubuntu-mate wily 15.10.

Temporary solution:
Log to a console and kill mate-screensaver.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-screensaver (Ubuntu):
status: New → Confirmed
gravy45 (gravy45) wrote :

Here also. Ubuntu MATE mini.iso install in a Virtualbox (5.0) guest amd64. All updates have been applied that were available as of 07/11/15 at 16:30 London time.

description: updated
summary: - mate screensaver doesn't unlock with unlcok button
+ MATE screensaver doesn't unlock with unlock button
Changed in mate-screensaver (Ubuntu):
importance: Undecided → High
Martin Wimpress (flexiondotorg) wrote :

The work around for now is to use Switch User and authenticate, this will "log you in" and preserve your desktop session. This bug is fixed in MATE 1.10 which will land in Ubuntu 15.10 soon.

Changed in mate-screensaver (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
Mikaela Suomalainen (mikaela) wrote :

The workaround is broken at least with sddm, with it I get a new TTY and entirely different session for the same user who already has session running in another TTY.

Martin Wimpress (flexiondotorg) wrote :

Fix released just moments ago when mate-screensaver 1.10 updates this issue should be resolved. This will also be included in Ubuntu MATE 15.10 beta 1.

Changed in mate-screensaver (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-mate:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers