[SRU] MATE Desktop 1.24.1 maint release

Bug #1891891 reported by Martin Wimpress on 2020-08-17
74
This bug affects 38 people
Affects Status Importance Assigned to Milestone
caja-extensions (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
engrampa (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
eom (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
libmatekbd (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
libmatemixer (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
libmateweather (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
marco (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-applets (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-calc (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-common (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-control-center (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-desktop (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-media (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-menus (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-notification-daemon (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-panel (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-power-manager (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-screensaver (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-sensors-applet (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-session-manager (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-settings-daemon (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-system-monitor (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
mate-terminal (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress
pluma (Ubuntu)
Undecided
Martin Wimpress
Focal
Undecided
Martin Wimpress

Bug Description

[Impact]

 * This is a roll-up of all maint fixes for MATE Desktop 1.24.1 and associated fixes in Ubuntu MATE. These upstream maint fixes address a number of issues for Ubuntu MATE 20.04 LTS users.

  * The principal issue addressed across all the package updates are broken translations and icons for many languages, the most impacted being Portuguese.

  * Other issues addressed include resolving memory leaks, segfaults and assorted papercuts; package-specific bugs are tagged in their respective package debian/changelog.

[Test Case]

 * Switching to a Portuguese locale will result in an entirely functional desktop environment, without these updates Portugues language strings and icons are broken in many applications.

[Regression Potential]

 * It is possible that there may be regressions in this roll-up, the most likely candidate being the port from libslab_handle_g_error to the built-in GLib logging framework in MATE Control Center.

 * That said, these fixes have been well tested by the Ubuntu MATE QA team using our testing PPA for Focal and via uploads to the Groovy archive; many issues are confirmed as fixed.

[Other Info]

 * All the upstream updates have successfully passed all test cases in the upstream CI/CD which includes Ubuntu Focal and Groovy as well as other prominent distributions.

 * All updates have already been uploaded to Debian unstable.

 * Some of the issues resolved have not resulted in an associated LP bug report and are being tracked upstream only.

description: updated
Changed in eom (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in eom (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmatekbd (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmatekbd (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmatemixer (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmatemixer (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmateweather (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in libmateweather (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in marco (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in marco (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-common (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-common (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-control-center (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-control-center (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-desktop (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-desktop (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-media (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-media (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-menus (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-menus (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-notification-daemon (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-notification-daemon (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-panel (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-panel (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-power-manager (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-power-manager (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-sensors-applet (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-sensors-applet (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-session-manager (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-session-manager (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-terminal (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-terminal (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in eom (Ubuntu):
status: New → Fix Released
Changed in libmatekbd (Ubuntu):
status: New → Fix Released
Changed in libmatemixer (Ubuntu):
status: New → Fix Released
Changed in libmateweather (Ubuntu):
status: New → Fix Released
Changed in marco (Ubuntu):
status: New → Fix Released
Changed in mate-common (Ubuntu):
status: New → Fix Released
Changed in mate-control-center (Ubuntu):
status: New → Fix Released
Changed in mate-desktop (Ubuntu):
status: New → Fix Released
Changed in mate-media (Ubuntu):
status: New → Fix Released
Changed in mate-menus (Ubuntu):
status: New → Fix Released
Changed in mate-notification-daemon (Ubuntu):
status: New → Fix Released
Changed in mate-panel (Ubuntu):
status: New → Fix Released
Changed in mate-power-manager (Ubuntu):
status: New → Fix Released
Changed in mate-sensors-applet (Ubuntu):
status: New → Fix Released
Changed in mate-session-manager (Ubuntu):
status: New → Fix Released
Changed in mate-terminal (Ubuntu):
status: New → Fix Released
Changed in mate-settings-daemon (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in caja-extensions (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in mate-calc (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in mate-calc (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated
Changed in mate-settings-daemon (Ubuntu):
status: In Progress → Fix Released
Changed in mate-applets (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in caja-extensions (Ubuntu):
status: In Progress → Fix Released
Changed in mate-applets (Ubuntu):
status: In Progress → Fix Released
Changed in caja-extensions (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → Fix Committed
Changed in eom (Ubuntu Focal):
status: New → Fix Committed
description: updated
Changed in libmatekbd (Ubuntu Focal):
status: New → Fix Committed
Changed in libmatemixer (Ubuntu Focal):
status: New → Fix Committed
Changed in libmateweather (Ubuntu Focal):
status: New → Fix Committed
description: updated
Changed in marco (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-applets (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-calc (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-common (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-control-center (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-desktop (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-media (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-menus (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-panel (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-notification-daemon (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-applets (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-calc (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-settings-daemon (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-power-manager (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-sensors-applet (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-session-manager (Ubuntu Focal):
status: New → Fix Committed
Changed in mate-settings-daemon (Ubuntu Focal):
status: New → Fix Committed
Changed in engrampa (Ubuntu):
status: New → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in engrampa (Ubuntu Focal):
status: New → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-terminal (Ubuntu Focal):
status: New → Fix Committed
Changed in engrampa (Ubuntu):
status: In Progress → Fix Released
Changed in engrampa (Ubuntu Focal):
status: In Progress → Fix Committed
description: updated
Changed in caja-extensions (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in engrampa (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in eom (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in libmatekbd (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in libmatemixer (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in libmateweather (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in marco (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-applets (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-calc (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-common (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-control-center (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-desktop (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-media (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-menus (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-notification-daemon (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-panel (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-power-manager (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-sensors-applet (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-session-manager (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-settings-daemon (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in mate-terminal (Ubuntu Focal):
status: Fix Committed → In Progress
summary: - [WIP] MATE Desktop 1.24.1 maint release
+ [SRU] MATE Desktop 1.24.1 maint release
tags: added: verification-needed-focal
Norbert (nrbrtx) wrote :

Added ppa:flexiondotorg/playground to the Ubuntu MATE 20.04 LTS.
Then tested both pt_BR and pt_PT - icons in Brisk menu are normal.

Bill (franksmcb) (franksmcb) wrote :

Testing on 20.04.1 Ubuntu MATE with Playground PPA does not show any regressions.

Brian Murray (brian-murray) wrote :

I haven't looked at these SRUs at all really but its curious that the version of mate-common in the unapproved queue is 1.24.2 not 1.24.1.

Martin Wimpress (flexiondotorg) wrote :

mate-common has had two upstream maint releases since 1.24.0, but mate-common 1.24.1 has previously been released in Ubuntu focal.

Martin Wimpress (flexiondotorg) wrote :

The above should read "but mate-common 1.24.1 has *not* previously been released in Ubuntu focal."

Changed in mate-screensaver (Ubuntu):
status: New → Fix Released
Changed in mate-screensaver (Ubuntu Focal):
status: New → In Progress
Changed in mate-system-monitor (Ubuntu):
status: New → Fix Released
Changed in mate-system-monitor (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in pluma (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → Fix Released
Changed in pluma (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: New → In Progress
Changed in mate-system-monitor (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-screensaver (Ubuntu Focal):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-screensaver (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)

Hello Martin, or anyone else affected,

Accepted pluma into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pluma/1.24.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in pluma (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Martin, or anyone else affected,

Accepted mate-system-monitor into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mate-system-monitor/1.24.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mate-system-monitor (Ubuntu Focal):
status: In Progress → Fix Committed
Chris Halse Rogers (raof) wrote :

Hm. It looks like mate-screensaver has UI changes and a feature addition - namely, the UI to select a picture file to use as the background of the lockscreen. That would not normally be an SRU candidate, and should certainly be called out explicitly if it *is* desired as an SRU.

Martin Wimpress (flexiondotorg) wrote :

After checking, the "new feature" in mate-screensaver is to address a feature regression due to refactoring between 1.22 and 1.24.

Vladimir (volnes88) wrote :

stupid question, but when this update arrive into 20.04?

Bert Van de Poel (bhack) wrote :

As I mentioned in #1891891 , I'm experiencing this bug with Dutch translations as well, largely in the menu. Is there any testing I can perform to help this fix along and get released?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers