FTBFS with current test suite

Bug #1964045 reported by Dan Bungert
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mariadb-10.6 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

mariadb-10.6 fails in autopkgtest. 10.6.7-3~exp1 resolves some of this, but test main.flush_logs_not_windows is flaky for me and is also skipped upstream.

Revision history for this message
Dan Bungert (dbungert) wrote :
description: updated
Revision history for this message
Dan Bungert (dbungert) wrote :

I ended up closing that MP, as I could not produce more than once the test failure that I had seen. I now propose syncing the -3 package when available.

Simon Chopin (schopin)
tags: added: transition-openssl3-jj
Revision history for this message
Dan Bungert (dbungert) wrote :

Debdiff starting from the mariadb-10.6_10.6.7-1.dsc package. This debdiff is lengthy because it includes the full change set for -2 and -3~exp1, along with my own changelog tweaks.

Revision history for this message
Dan Bungert (dbungert) wrote :

Debdiff starting from mariadb-10.6_10.6.7-3~exp1.dsc. The same content, but easier to read as it highlights that really only the changelog (and update-maintainer) changes are in place.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "mariadb-10.6-1_10.6.7-1_10.6.7-2ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Dan Bungert (dbungert)
Changed in mariadb-10.6 (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon)
Changed in mariadb-10.6 (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mariadb-10.6 - 1:10.6.7-2ubuntu1

---------------
mariadb-10.6 (1:10.6.7-2ubuntu1) jammy; urgency=medium

  * Pseudo-sync version 1:10.6.7-3~exp1 for the following fixes (LP: #1964045)
    [Otto Kekäläinen]
      * Fix syntax error in unstable tests lists
      * Forward patches upstream and update metadata for them
      * Bugfix: Include missing sql_parse.cc in ER_KILL_DENIED_ERROR patch
      * Fix mysql_install_db by reverting recent addition (MDEV-27980)
      * Fix htm use on PowerPC to fix build failure (might close #1006527)

 -- Dan Bungert <email address hidden> Thu, 10 Mar 2022 12:40:09 -0700

Changed in mariadb-10.6 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers