package mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1 failed to install/upgrade: conflicting packages - not installing mariadb-client-core-10.3

Bug #1930158 reported by Carlos Armelle FOTSING
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mariadb-10.3 (Ubuntu)
Undecided
Unassigned

Bug Description

bug

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1
ProcVersionSignature: Ubuntu 5.8.0-53.60~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-53-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.18
Architecture: amd64
CasperMD5CheckResult: skip
Date: Sun May 30 09:37:35 2021
ErrorMessage: conflicting packages - not installing mariadb-client-core-10.3
InstallationDate: Installed on 2021-05-30 (0 days ago)
InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 (20210209.1)
Logs.var.log.daemon.log:

MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
MySQLConf.etc.mysql.conf.d.mysqld_safe_syslog.cnf.dpkg-new:
 [mysqld_safe]
 skip_log_error
 syslog
MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
 [mysqldump]
 quick
 quote-names
 max_allowed_packet = 16M
MySQLVarLibDirListing: ['ib_buffer_pool', 'multi-master.info', 'mysql_upgrade_info', 'ibdata1', 'performance_schema', 'ibtmp1', 'ib_logfile1', 'ib_logfile0', 'mysql', 'phpmyadmin', 'debian-10.3.flag', 'tc.log', 'aria_log.00000001', 'aria_log_control']
ProcCmdline: BOOT_IMAGE=/vmlinuz-5.8.0-53-generic root=UUID=d8b87cf8-3c98-419f-aa9c-647073dfa766 ro quiet splash vt.handoff=7
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.5
SourcePackage: mariadb-10.3
Title: package mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1 failed to install/upgrade: conflicting packages - not installing mariadb-client-core-10.3
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Carlos Armelle FOTSING (ablack237) wrote :
Revision history for this message
Faustin (fauust) wrote :

Hi Carlos!
Thank you for your report and your help in making Ubuntu better.

Unfortunately, I can not work on your issue because you do not provide sufficient information. From the logs, I can only wonder if you did not install MySQL before MariaDB, in that case remember that they can not coexist on your system and are different DB maintained by different teams.

If I am wrong, I would need:

1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).

Thank you!

Changed in mariadb-10.3 (Ubuntu):
status: New → Incomplete
Revision history for this message
Carlos Armelle FOTSING (ablack237) wrote : Re: [Bug 1930158] Re: package mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1 failed to install/upgrade: conflicting packages - not installing mariadb-client-core-10.3

Thank you!

Le ven. 9 juil. 2021 à 3:05, Faustin <email address hidden> a écrit :

> Hi Carlos!
> Thank you for your report and your help in making Ubuntu better.
>
> Unfortunately, I can not work on your issue because you do not provide
> sufficient information. From the logs, I can only wonder if you did not
> install MySQL before MariaDB, in that case remember that they can not
> coexist on your system and are different DB maintained by different
> teams.
>
> If I am wrong, I would need:
>
> 1. The specific steps or actions you took that caused you to encounter the
> problem.
> 2. The behavior you expected.
> 3. The behavior you actually encountered (in as much detail as possible).
>
> Thank you!
>
> ** Changed in: mariadb-10.3 (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1930158
>
> Title:
> package mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1 failed to
> install/upgrade: conflicting packages - not installing mariadb-client-
> core-10.3
>
> Status in mariadb-10.3 package in Ubuntu:
> Incomplete
>
> Bug description:
> bug
>
> ProblemType: Package
> DistroRelease: Ubuntu 20.04
> Package: mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1
> ProcVersionSignature: Ubuntu 5.8.0-53.60~20.04.1-generic 5.8.18
> Uname: Linux 5.8.0-53-generic x86_64
> ApportVersion: 2.20.11-0ubuntu27.18
> Architecture: amd64
> CasperMD5CheckResult: skip
> Date: Sun May 30 09:37:35 2021
> ErrorMessage: conflicting packages - not installing
> mariadb-client-core-10.3
> InstallationDate: Installed on 2021-05-30 (0 days ago)
> InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64
> (20210209.1)
> Logs.var.log.daemon.log:
>
> MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
> MySQLConf.etc.mysql.conf.d.mysqld_safe_syslog.cnf.dpkg-new:
> [mysqld_safe]
> skip_log_error
> syslog
> MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
> [mysqldump]
> quick
> quote-names
> max_allowed_packet = 16M
> MySQLVarLibDirListing: ['ib_buffer_pool', 'multi-master.info',
> 'mysql_upgrade_info', 'ibdata1', 'performance_schema', 'ibtmp1',
> 'ib_logfile1', 'ib_logfile0', 'mysql', 'phpmyadmin', 'debian-10.3.flag',
> 'tc.log', 'aria_log.00000001', 'aria_log_control']
> ProcCmdline: BOOT_IMAGE=/vmlinuz-5.8.0-53-generic
> root=UUID=d8b87cf8-3c98-419f-aa9c-647073dfa766 ro quiet splash vt.handoff=7
> Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal,
> 3.8.2-0ubuntu2
> PythonDetails: N/A
> RelatedPackageVersions:
> dpkg 1.19.7ubuntu3
> apt 2.0.5
> SourcePackage: mariadb-10.3
> Title: package mariadb-client-core-10.3 1:10.3.29-0ubuntu0.20.04.1
> failed to install/upgrade: conflicting packages - not installing
> mariadb-client-core-10.3
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/mariadb-10.3/+bug/1930158/+subscriptions
>

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for mariadb-10.3 (Ubuntu) because there has been no activity for 60 days.]

Changed in mariadb-10.3 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.