Tile preview graphics glitch

Bug #1406344 reported by Adam Smith

This bug report will be marked for expiration in 11 days if no further activity occurs. (find out why)

10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Low
Unassigned
marco (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce bug:

1. Snap a window to the left of the screen
2. Snap a window to the right of the screen
3. Before the tile preview appears the background of the left of the screen appears very briefly (a fraction of a second) at the right of the screen
4. Snap a window to the left of the screen
5. A similar graphics glitch is observed on the left of the screen (i.e. the right hand side background is flashed on the left of the screen).

This is reproducable under 12.04 (precise) and 14.04 (trusty).

Marco version: 1.8.2+dfsg1-4~trusty1

This is on a big-endian machine (PowerPC), but I think the slowness of the machine is more significant.

Revision history for this message
Adam Smith (adamsmith) wrote :

The attached patch fixes the problem for me.

Adam Smith (adamsmith)
description: updated
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "tile-preview.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Adam Smith (adamsmith) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in marco (Ubuntu):
status: New → Confirmed
Revision history for this message
gravy45 (gravy45) wrote :

I'm seeing it also in marco 1.8.3+dfsg1-3.

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

This fix is committed in Marco 1.10.

Changed in marco (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

Marco 1.10 has just been uploaded to the Ubuntu MATE 15.10 archive and fixes this issue.

Changed in marco (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-mate:
status: New → Fix Released
Revision history for this message
Adam Smith (adamsmith) wrote :

Tried mate 1.12. This is not fixed.

Changed in ubuntu-mate:
status: Fix Released → Confirmed
Changed in marco (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-mate:
importance: Undecided → Low
summary: - Tile preview graphics glitch
+ Tile preview graphics glitch on PowerPC
Changed in ubuntu-mate:
status: Confirmed → Fix Released
Changed in marco (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Adam Smith (adamsmith) wrote : Re: Tile preview graphics glitch on PowerPC

Martin this is not fixed. I can't see a patch for it, and the code hasn't been changed from what I can tell. Apologies of I'm missing something.....

The patch I submitted explains the changes needed in comments. It just hasn't been implemented correctly.

Changed in marco (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Adam Smith (adamsmith) wrote :

Still present in Linux Mint 18 Mate edition. I can't believe nobody else has noticed this!

summary: - Tile preview graphics glitch on PowerPC
+ Tile preview graphics glitch
Revision history for this message
Adam Smith (adamsmith) wrote :

A similar glitch can be seen in Mutter. I bet they share a similar flawed logic.

Changed in ubuntu-mate:
status: Fix Released → Invalid
Revision history for this message
Norbert (nrbrtx) wrote :

Can you reproduce this bug with newer version of Ubuntu MATE?

Changed in marco (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers