Missing information in proc(5)

Bug #1071746 reported by roncsak
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
manpages (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

proc(5) only lists 44 fields in /proc/pid/stat, however there is more.

Here is what I get (52 fields counted):
3985 (eclipse) S 1 1513 1513 0 -1 4202496 82963 451290 481 284 26636 4125 1938 1267 20 0 22 0 974680 911331328 57317 4294967295 134512640 134526532 3215374240 3215370384 3078403108 0 4 4096 16796879 4294967295 0 0 17 1 0 0 1674 0 0 134532820 134533928 145444864 3215378654 3215378679 3215378679 3215380451 0

What are the additional 8 fields?

/proc/[pid]/stat says the information is defined in /usr/src/linux/fs/proc/array.c It is not there I have linux-headers-3.5.0-17 and linux-headers-3.5.0-17-generic and none of them has array.c in their fs/proc/ dir.

*UPDATE*
There is missing information in /proc/[pid]/status, as well. VmLck is followed by VmPin, which is not in the documentation and VmPTE is followed by VmSwap which is not documented, also.

Description: Ubuntu 12.10
Release: 12.10
Freshly updated from the latest LTS (12.04.1)

roncsak (tom-roncsak)
description: updated
roncsak (tom-roncsak)
description: updated
summary: - proc(5) /proc/[pid]/stat describes 44 fields however there is more
+ Missing information in proc(5)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in manpages (Ubuntu):
status: New → Confirmed
Revision history for this message
Pavel (altusensix) wrote :

Hi guys!
Any update on this ticket?

Revision history for this message
Michael Kerrisk (mtk-manpages) wrote :

Upstream maintainer here.

Regarding the /proc/PID/stat, you need to upgrade your man-pages. An update to man-pages in May 2014 added documentation for these fields.

Likewise VmSwap in /proc/PID/status is already documented in recent man-pages.

(See http://man7.org/linux/man-pages/man5/proc.5.html )

For VmPin, the documentation indeed was lacking, and I have added:

              * VmPin: Pinned memory size (since Linux 3.2). These
                are pages that can't be moved because something needs
                to directly access physical memory.

Thanks,

Michael

Revision history for this message
Stéphane Aulery (lkppo) wrote :

Fixed in manpages 3.82

See commit 157890398be84d22e53a222dce721914c3e533a3
Michael Kerrisk <email address hidden> 2015-03-02 16:22:26 (GMT)

https://git.kernel.org/cgit/docs/man-pages/man-pages.git/commit/man5/proc.5?id=157890398be84d22e53a222dce721914c3e533a3

Changed in manpages (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package manpages - 4.02-0ubuntu1

---------------
manpages (4.02-0ubuntu1) xenial; urgency=medium

  * New upstream version, including those changes:
    - random.4: Fix permissions shown for the devices (lp: #1397652)
    - resolv.conf.5: Document RES_SNGLKUPREOP (lp: #1110781)
    - proc.5: Document /proc/PID/status VmPin field (lp: #1071746)
  * debian/rules:
    - don't ship attr manpage to avoid conflict with that package

 -- Sebastien Bacher <email address hidden> Wed, 04 Nov 2015 16:05:28 +0100

Changed in manpages (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers