package man-db 2.5.7-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #695887 reported by Steven Collins on 2010-12-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt
man-db (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: man-db

I was in the process of installing Ubuntu and this warning appeared

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: man-db 2.5.7-4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Thu Dec 30 21:08:44 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 1
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
SourcePackage: man-db
Title: package man-db 2.5.7-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Steven Collins (stevenco-1966) wrote :
Michael Vogt (mvo) wrote :

Adding a apport task so that we can avoid reporting bugs with a empty DpkgTerminalLog.txt (like this one). Without information in the logs its impossible to diagnose what went wrong.

Martin Pitt (pitti) wrote :

Notes: Filter out in ubuntu package hook. Reject if ProblemType: package and DpkgTerminalLog only has empty lines and lines with "log started" and "log stopped".

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

Fixed apport side in bzr.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.17.2-0ubuntu1

---------------
apport (1.17.2-0ubuntu1) natty; urgency=low

  * New upstream bug fix release:
    - Be more Python 3 compatible (not fully working with Python 3 yet,
      though).
    - apt/dpkg backend: Drop support for pre-0.7.9 python-apt API.
    - Add --tag option to add extra tags to reports. (LP: #572504)
    - hookutils.py, attach_dmesg(): Do not overwrite already existing dmesg.
    - hookutils.py: Be more robust against file permission errors.
      (LP: #444678)
    - ui.py: Do not show all the options in --help when invoked as *-bug.
      (LP: #665953)
    - launchpad.py: Adapt test cases to current standard_title() behaviour.
  * debian/control: Bump python-apt dependency to >= 0.7.9 to ensure that we
    have the current API. Trunk dropped support for the old API.
  * data/general-hooks/ubuntu.py: Ignore obsolete packages when filing bugs
    against update-manager. (LP: #397519)
  * data/general-hooks/ubuntu.py: Do not file a package install failure if
    DpkgTerminalLog doesn't have any data. (LP: #695887)
  * Add debian/apport.postinst: Create /var/crash. This directory is required
    for package failures even if apport is disabled and thus the upstart job
    does not run. (LP: #683367)
 -- Martin Pitt <email address hidden> Fri, 04 Feb 2011 15:46:40 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping and helping to make Ubuntu better. Unfortunately, the package installation log attached to this bug report is empty. Could you check your system for a non-empty /var/log/apt/term.log and attach it to the report? Please set the status back to New if you do. Thanks in advance.

tags: added: empty-dpkg-terminal-log
Changed in man-db (Ubuntu):
status: New → Incomplete
Changed in man-db (Ubuntu):
status: Incomplete → New
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The version of update-initramfs that you likely have installed is unable to work on a persistent usb stick. You can resolve this issue by upgrading the version of casper on your system. This can be done via the commands:

sudo apt-get update; sudo apt-get install casper

Then performing the software update or installation that you were originally trying. If this does resolve your bug please set its status to Invalid. Thanks in advance!

Changed in apport (Ubuntu):
status: Fix Released → Incomplete
Changed in man-db (Ubuntu):
status: New → Incomplete
tags: added: needs-new-casper
Changed in apport (Ubuntu):
status: Incomplete → Fix Released
Colin Watson (cjwatson) wrote :

Without more details it's impossible to track this down further, and I don't think there's much value in leaving the man-db task on this bug open at this point. My guess is that this is either an automatically-misfiled consequence of some other bug, or a duplicate of bug 1372673 (for which I'm currently in the process of issuing updates).

Changed in man-db (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers