modprobe.conf man page has invalid symlink

Bug #411534 reported by Ryan on 2009-08-10
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
module-init-tools
Won't Fix
Undecided
Unassigned
man-db (Debian)
Fix Released
Unknown
man-db (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: module-init-tools

mandb -c
Processing manual pages under /usr/share/man...
...
Updating index cache for path `/usr/share/man/man5'. Wait...mandb: warning: /usr/share/man/man5/modprobe.d.5 is a dangling symlink
...

/usr/share/man/man5$ ls -l modprobe*
-rw-r--r-- 1 root root 2125 2009-08-07 09:26 modprobe.conf.5.gz
lrwxrwxrwx 1 root root 18 2009-08-07 11:41 modprobe.d.5 -> ../modprobe.conf.5
root@lt:/usr/share/man/man5# locate modprobe.conf.5
/usr/share/man/man5/modprobe.conf.5.gz
root@lt:/usr/share/man/man5# dpkg-query -S modprobe.d.5
module-init-tools: /usr/share/man/man5/modprobe.d.5

The symlink (if you want one) should be modprobe.d.5 -> modprobe.conf.5.gz (same directory)

apt-cache policy module-init-tools
module-init-tools:
  Installed: 3.10-2
  Candidate: 3.10-2
  Version table:
 *** 3.10-2 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

arky (arky) wrote :

Updating index cache for path `/usr/share/man/man5'. Wait...mandb: warning: /usr/share/man/man5/modprobe.d.5 is a dangling symlink

Changed in module-init-tools (Ubuntu):
status: New → Confirmed
arky (arky) wrote :

I'm pretty sure that your patch is incorrect, subscribing our resident "man" expert

Changed in module-init-tools (Ubuntu):
status: Confirmed → Incomplete
Colin Watson (cjwatson) wrote :

Prefixing with "man5/" is actually correct even though it looks weird; .so links are relative to the base of the manual page hierarchy. However, you don't need the trailing .gz on the .so link.

A correct patch would be:

-.so modprobe.conf.5
+.so man5/modprobe.conf.5

Changed in module-init-tools (Ubuntu):
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

(dh_compress will fix up the symlink correctly if you leave off the .gz)

arky (arky) wrote :

Thanks for the feedback, attaching the corrected patch

Changed in module-init-tools (Ubuntu):
importance: Undecided → Low
Colin Watson (cjwatson) wrote :

I'm upgrading this to High as I think it currently causes mandb to rebuild the database every time. See http://bugs.archlinux.org/task/14467 for details. I'd upload this right away except I think that Scott currently has module-init-tools changes pending in the ubuntu-boot PPA and I don't want to interfere with him.

Changed in module-init-tools (Ubuntu):
importance: Low → High

Will send this upstream next week when I see him.

After chatting with Colin, it turns out the the "other" man implementation (e.g. as used by Fedora) accepts .so links like this - so our man-db probably should too

Changed in module-init-tools:
status: New → Won't Fix
affects: module-init-tools (Ubuntu) → man-db (Ubuntu)
Adam Guthrie (therigu) wrote :

Marking as patch-rejected following Scott's comments above.

tags: added: patch patch-rejected
Colin Watson (cjwatson) wrote :

This should no longer cause repeated rescans as of man-db 2.5.8, so downgrading severity. The rest of this is essentially Debian #503472.

Changed in man-db (Ubuntu):
importance: High → Wishlist
status: Confirmed → Triaged
Changed in man-db (Debian):
status: Unknown → New
Colin Watson (cjwatson) wrote :

I've fixed this upstream; man-db 2.6.0 will have more complete support for .so search paths.

Changed in man-db (Ubuntu):
status: Triaged → Fix Committed
Changed in man-db (Debian):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package man-db - 2.6.0.2-1

---------------
man-db (2.6.0.2-1) unstable; urgency=low

  * New upstream release:
    - Fix a segfault when scanning links to empty pages (closes: #622104).
    - Once we've seen at least one record in a page's NAME section, ignore
      any further records that don't include a whatis description, as they
      tend to be noise.
  * Remove unnecessary .la files (closes: #622443).

man-db (2.6.0.1-1) unstable; urgency=low

  * New upstream release, fixing test failures in 2.6.0 (closes: #621867):
    - Ensure that the target of a symlink or .so chain is always recorded as
      a real page.
    - Read a user-specified configuration file even if HOME is unset.

man-db (2.6.0-1) unstable; urgency=low

  * New upstream release:
    - Search the full manpath when expanding .so directives in manual pages.
      As part of this, '.so name.1' should now work as well as '.so
      man1/name.1' (closes: #503472, LP: #411534).
    - Handle roff named glyphs and perldoc strings in NAME sections (closes:
      #601025).
    - Don't start a pager if stdout is not a tty.
    - Allow passing multiple sections to whatis and apropos (closes:
      #571285).
    - Provide byte positions in manconv errors (closes: #562789).
    - Make mandb error output neater when stderr is not a tty.
    - Fix failure to display manual pages in some encodings when installed
      setuid.
    - Don't ignore SIGPIPE while forking iconv (closes: #597756).
    - Remove obsolete subdirectories of cat directories (closes: #558804).
    - If mandb sees that A is a symlink to B, it should never store a whatis
      reference for B (closes: #204249).
    - Print commas in roman rather than bold (thanks, David Prévot; closes:
      #600002).
    - Consider .PD requests as paragraph breaks (closes: #611012).
    - Reset SIGPIPE to SIG_DFL on startup, to avoid noisy output in the
      event that mandb was started from a context where SIGPIPE was ignored.
    - SECTION entries in a user configuration file now override those in the
      system configuration file, rather than appending to them.
    - If the user asked for an explicit section, sort exact matches first.
    - Rewrite all remaining subprocess handling in terms of libpipeline,
      especially some crash-prone code in catman (LP: #27738).
    - The default less prompt now includes "(press h for help or q to quit)"
      to help novices find their way around
      (http://brainstorm.ubuntu.com/idea/25975).
    - Fix a segfault when 'man -K' tries to display certain pages.
    - Fix a segfault in some situations when processes are killed by SIGHUP,
      SIGINT, or SIGTERM (LP: #218336).
  * Avoid unnecessary metadata writes to /var/cache/man when doing recursive
    chown (thanks, Iustin Pop; closes: #619726).
 -- Ubuntu Archive Auto-Sync <email address hidden> Sat, 30 Apr 2011 13:16:26 +0000

Changed in man-db (Ubuntu):
status: Fix Committed → Fix Released
Changed in man-db (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.