Package makedumpfile 1:1.6.7-1ubuntu2(arm64) failed to makedumpfile:calculate_plat_config: PAGE SIZE 0x1000 and VA Bits 47 not supported

Bug #1879214 reported by chenrongwen
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
makedumpfile (Debian)
Fix Released
Unknown
makedumpfile (Ubuntu)
High
Ioanna Alifieraki
Bionic
High
Unassigned
Focal
High
Ioanna Alifieraki
Groovy
High
Ioanna Alifieraki
Hirsute
High
Ioanna Alifieraki

Bug Description

[Impact]

On arm64 and kernels 5.4+ makedumpfile fails.

Upstream patches solve this bug :

[PATCH 1/3] Use vmcoreinfo note in /proc/kcore for --mem-usage option
https://github.com/makedumpfile/makedumpfile/commit/d8b701796f0491f2ac4b06c7a5b795c29399efab

[PATCH 2/3] arm64: Make use of NUMBER(VA_BITS) in vmcoreinfo
https://github.com/makedumpfile/makedumpfile/commit/67d0e1d68f28c567a704fd6b9b8fd696ad3df183

[PATCH 3/3] arm64: support flipped VA and 52-bit kernel VA
https://github.com/makedumpfile/makedumpfile/commit/a0216b678a95f099a16172cc4a67ad5aa6a89583

[Test Case]

OS: Ubuntu 20.04 LTS
kernel: 5.4.0-21-generic
arch:arm64
Description:
When testing kdump on Ubuntu 20.04 LTS (arm64), makedumpfile fails. The test steps are as follows:
# echo 1> / proc / sys / kernel / sysrq
# echo c> / proc / sysrq-trigger
The error logs are as follows:
[ 26.599161] kdump-tools[653]: Starting kdump-tools:
[ 26.612761] kdump-tools[659]: Starting kdump-tools:
[ 26.628565] kdump-tools[659]: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/2020050
[ 26.648621] kdump-tools[676]: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/2020050
[ 26.668445] kdump-tools[676]: calculate_plat_config: PAGE SIZE 0x1000 and VA Bits 47 not supported
[ 26.678199] kdump-tools[676]: get_machdep_info_arm64
[ 26.692518] kdump-tools[659]: get_machdep_info_arm64
[ 26.852221] hns3 0000:7d:00.0: get link status cmd failed -16

[ 94.351303] kdump-tools[659]: * kdump-tools: makedumpfile failed, * kdump-tools: saved vmcore in /var/crash/202005061048
[ 94.435510] kdump-tools[659]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/202005061048/dmesg.202005061048
[ 94.457103] kdump-tools[688]: calculate_plat_config: PAGE SIZE 0x1000 and VA Bits 47 not supported
[ 94.476228] kdump-tools[688]: get_machdep_info_arm64: Can't determine platform config values
[ 94.485912] kdump-tools[688]: makedumpfile Failed.
[ 94.500760] kdump-tools[659]: * kdump-tools: makedumpfile --dump-dmesg failed. dmesg content will be unavailable
[ 94.520225] kdump-tools[659]: * kdump-tools: failed to save dmesg content in /var/crash/202005061048
[ 94.544205] kdump-tools[691]: Wed, 06 May 2020 10:49:42 -0400
[ 94.564597] kdump-tools[692]: Rebooting.
[ 94.678709] reboot: Restarting systemlpc uart init Done

[Regression Potential]

Patch 1 : [PATCH 1/3] Use vmcoreinfo note in /proc/kcore for --mem-usage option
removes get_elf_loads function this function was only used with --mem-usage option
, since kernel commit kernel commit 23c85094fe18 (kernel versions >4.19)
the information needed is in vmcoreinfo
Any regression potential would affect the --mem-usage only

Patch 2 : [PATCH 2/3] arm64: Make use of NUMBER(VA_BITS) in vmcoreinfo
arm64 only
make use of NUMBER(VA_BITS) in vmcoreinfo as the current way of guessing VA_BITS
does not work on Linux 5.4 and later.
Before this commit VA_BITS would be calculated in get_versiondep_info_arm64, however
this way of calculation breaks after 5.4. This commit gets the VA_BITS from vmcoreinfo
and as a safeguard it uses the old way of deriving VA_BITS only if reading from vmcoreinfo doesn't work.

From the kernel side VA_BITS is in vmcoreinfo since kernel 4.12, F and later use later kernel so not
great regression potentional and if any it would only affect arm64.

Patch 3 : [PATCH 3/3] arm64: support flipped VA and 52-bit kernel VA
arm64 only
Linux 5.4 and later kernels for arm64 changed the kernel VA space
arrangement and introduced 52-bit kernel VAs by merging branch
commit b333b0ba2346. Support 5.9+ kernels with vmcoreinfo entries
and 5.4+ kernels with best guessing.

This patch makes adjustemnt to properly calculate vabits_actual, max_physmem_bits, page_offset
Any regression potential would affect only arm64 and the calculation of the above variables.

[Other]

For H only the 3 commits are needed and they cherry-pick.

For G and F the 3rd commit does not apply and an extra commit is needed :

commit da0d25ffa585c9a1adb94562c815daa393b1ee5e
[PATCH] arm64: Add support for ARMv8.2-LPA (52-bit PA support)

This bug also affects Bionic when 5.4 hwe kernel is used.

Revision history for this message
chenrongwen (were0415) wrote :
Revision history for this message
chenrongwen (were0415) wrote :

Here is sosreport.

Revision history for this message
tonihu (13917547121-u) wrote :

same error

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Hi @chenrongwen and @tonihu, thanks for the reports! Could you please try makedumpfile version 1:1.6.7-1ubuntu2.1, available on -proposed pocket? There's an ARM64-specific fix there that might solve your problem.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Guilherme

Changed in makedumpfile (Ubuntu):
status: New → Confirmed
Revision history for this message
chenrongwen (were0415) wrote :

Hi Guilherme, I have tested makedumpfile version 1:1.6.7-1ubuntu2.1,but the issue is still not solved, the log information is the same as before.

Revision history for this message
tonihu (13917547121-u) wrote :

Hi Guilherme, I have tested makedumpfile_1.6.7-1ubuntu3_amd64.deb ,but the issue is still not solved, the log information is the same as before

Changed in makedumpfile (Ubuntu):
assignee: nobody → Ioanna Alifieraki (joalif)
tags: added: sts
description: updated
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for H.

description: updated
Changed in makedumpfile (Ubuntu Groovy):
status: New → Confirmed
Changed in makedumpfile (Ubuntu Focal):
status: New → Confirmed
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for H.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for G.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for F.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lp1879214_hirsute.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson)
Changed in makedumpfile (Ubuntu Focal):
importance: Undecided → High
Changed in makedumpfile (Ubuntu Groovy):
importance: Undecided → High
Changed in makedumpfile (Ubuntu Hirsute):
importance: Undecided → High
Revision history for this message
Ali Saidi (alisaidi) wrote :

Also impacts the bionic 18.04-aws kernel

Changed in makedumpfile (Ubuntu Groovy):
assignee: nobody → Ioanna Alifieraki (joalif)
Changed in makedumpfile (Ubuntu Focal):
assignee: nobody → Ioanna Alifieraki (joalif)
Changed in makedumpfile (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.8-4

---------------
makedumpfile (1:1.6.8-4) unstable; urgency=medium

  [ Ioanna Alifieraki ]
  * Fix failure of dmesg.<timestamp> creation on 5.10+ kernels.
    (Closes: #985896) (LP: #1921403).
  * Fix makedumpfile failure on arm64 with 5.4 kernels.
    (Closes: #986594) (LP: #1879214)

 -- dann frazier <email address hidden> Wed, 07 Apr 2021 16:32:38 -0600

Changed in makedumpfile (Ubuntu Hirsute):
status: Confirmed → Fix Released
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for Bionic.

Changed in makedumpfile (Ubuntu Bionic):
status: New → Confirmed
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

This bug also affects Bionic when 5.4 hwe kernel is used.

description: updated
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for Groovy V2.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for Focal V2.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

Debdiff for Bionic V2.

Revision history for this message
Dan Streetman (ddstreet) wrote :

i uploaded, but then saw dannf had already uploaded too a few hours ago...sorry for the duplicate uploads!

Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello chenrongwen, or anyone else affected,

Accepted makedumpfile into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.6.7-1ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in makedumpfile (Ubuntu Focal):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello chenrongwen, or anyone else affected,

Accepted makedumpfile into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.6.7-4ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in makedumpfile (Ubuntu Groovy):
status: Confirmed → Fix Committed
tags: added: verification-needed-groovy
Changed in makedumpfile (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello chenrongwen, or anyone else affected,

Accepted makedumpfile into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.6.5-1ubuntu1~18.04.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (makedumpfile/1:1.6.5-1ubuntu1~18.04.6)

All autopkgtests for the newly accepted makedumpfile (1:1.6.5-1ubuntu1~18.04.6) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

makedumpfile/1:1.6.5-1ubuntu1~18.04.6 (s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#makedumpfile

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

#VERIFICATION BIONIC

On an arm64 bionic vm running 5.4 kernel installed makedumpfile
from -proposed and triggered a crash.
Crashdump file is created without any problems :

[ 130.240270] kdump-tools[632]: Starting kdump-tools: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/202104261056/dump-incomplete
Copying data : [ 62.6 [2021-04-26T10:56:38.86529Copying data : [100.0 %] | eta: 0s
[ 143.377037] kdump-tools[632]: The kernel version is not supported.
[ 143.378979] kdump-tools[632]: The makedumpfile operation may be incomplete.
[ 143.383191] kdump-tools[632]: The dumpfile is saved to /var/crash/202104261056/dump-incomplete.
[ 143.385712] kdump-tools[632]: makedumpfile Completed.
[ 143.388291] kdump-tools[632]: * kdump-tools: saved vmcore in /var/crash/202104261056
[ 143.432646] kdump-tools[632]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/202104261056/dmesg.202104261056
[ 143.440986] kdump-tools[632]: The kernel version is not supported.
[ 143.442600] kdump-tools[632]: The makedumpfile operation may be incomplete.
[ 143.444345] kdump-tools[632]: The dmesg log is saved to /var/crash/202104261056/dmesg.202104261056.
[ 143.446879] kdump-tools[632]: makedumpfile Completed.
[ 143.448527] kdump-tools[632]: * kdump-tools: saved dmesg content in /var/crash/202104261056
[ 143.463805] kdump-tools[632]: Mon, 26 Apr 2021 10:56:38 +0000
[ 143.473132] kdump-tools[632]: Rebooting.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

#VERIFICATION FOCAL

On an arm64 focal vm installed makedumpfile from -proposed and triggered a crash.
Crashdump file is created without any problems :

[ 131.348948] kdump-tools[521]: Starting kdump-tools:
[ 131.350648] kdump-tools[527]: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/202104261059/dump-incomplete
[ OK ] Started Hostname Service.
Copying data : [100.0 %] | eta: 0s
[ 136.780294] kdump-tools[544]: The dumpfile is saved to /var/crash/202104261059/dump-incomplete.
[ 136.782771] kdump-tools[544]: makedumpfile Completed.
[ 136.787843] kdump-tools[527]: * kdump-tools: saved vmcore in /var/crash/202104261059
[ 136.909187] kdump-tools[527]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/202104261059/dmesg.202104261059
[ 136.917750] kdump-tools[549]: The dmesg log is saved to /var/crash/202104261059/dmesg.202104261059.
[ 136.919930] kdump-tools[549]: makedumpfile Completed.
[ 136.924282] kdump-tools[527]: * kdump-tools: saved dmesg content in /var/crash/202104261059
[ 136.938369] kdump-tools[552]: Mon, 26 Apr 2021 11:00:01 +0000
[ 136.947826] kdump-tools[553]: Rebooting.

Revision history for this message
Ioanna Alifieraki (joalif) wrote :

#VERIFICATION GROOVY

On an arm64 groovy vm installed makedumpfile from -proposed and triggered a crash.
Crashdump file is created without any problems :

[ 192.577224] kdump-tools[528]: Starting kdump-tools:
[ 192.579315] kdump-tools[534]: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/202104261101/dump-incomplete
[ OK ] Started Hostname Service.
Copying data : [100.0 %] \ eta: 0s
[ 198.320536] kdump-tools[551]: The kernel version is not supported.
[ 198.322120] kdump-tools[551]: The makedumpfile operation may be incomplete.
[ 198.323793] kdump-tools[551]: The dumpfile is saved to /var/crash/202104261101/dump-incomplete.
[ 198.325900] kdump-tools[551]: makedumpfile Completed.
[ 198.333425] kdump-tools[534]: * kdump-tools: saved vmcore in /var/crash/202104261101
[ 198.424133] kdump-tools[534]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/202104261101/dmesg.202104261101
[ 198.433298] kdump-tools[555]: The kernel version is not supported.
[ 198.434926] kdump-tools[555]: The makedumpfile operation may be incomplete.
[ 198.436644] kdump-tools[555]: The dmesg log is saved to /var/crash/202104261101/dmesg.202104261101.
[ 198.438770] kdump-tools[555]: makedumpfile Completed.
[ 198.440651] kdump-tools[534]: * kdump-tools: saved dmesg content in /var/crash/202104261101
[ 198.454465] kdump-tools[558]: Mon, 26 Apr 2021 11:01:48 +0000
[ 198.464208] kdump-tools[559]: Rebooting.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-groovy
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (makedumpfile/1:1.6.7-4ubuntu1.1)

All autopkgtests for the newly accepted makedumpfile (1:1.6.7-4ubuntu1.1) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

makedumpfile/1:1.6.7-4ubuntu1.1 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#makedumpfile

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (makedumpfile/1:1.6.7-1ubuntu2.2)

All autopkgtests for the newly accepted makedumpfile (1:1.6.7-1ubuntu2.2) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

makedumpfile/1:1.6.7-1ubuntu2.2 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#makedumpfile

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Mathew Hodson (mhodson)
Changed in makedumpfile (Ubuntu Bionic):
importance: Undecided → High
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

I see makedumpfile ppc64el ADT tests failing, but those have been broken since always. Bumping the hint o/

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.7-4ubuntu1.1

---------------
makedumpfile (1:1.6.7-4ubuntu1.1) groovy; urgency=medium

  * Fix makedumpfile failure on arm64 with 5.4 kernels (LP: #1879214)
    -d/p/0004-PATCH-arm64-Add-support-for-ARMv8.2-LPA-52-bit-PA-su.patch
    -d/p/0005-PATCH-1-3-Use-vmcoreinfo-note-in-proc-kcore-for-mem-.patch
    -d/p/0006-PATCH-2-3-arm64-Make-use-of-NUMBER-VA_BITS-in-vmcore.patch
    -d/p/0007-PATCH-3-3-arm64-support-flipped-VA-and-52-bit-kernel.patch

 -- Ioanna Alifieraki <email address hidden> Thu, 15 Apr 2021 22:48:25 +0300

Changed in makedumpfile (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for makedumpfile has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.7-1ubuntu2.2

---------------
makedumpfile (1:1.6.7-1ubuntu2.2) focal; urgency=medium

  * Fix makedumpfile failure on arm64 with 5.4 kernels (LP: #1879214)
    -d/p/0004-PATCH-arm64-Add-support-for-ARMv8.2-LPA-52-bit-PA-su.patch
    -d/p/0005-PATCH-1-3-Use-vmcoreinfo-note-in-proc-kcore-for-mem-.patch
    -d/p/0006-PATCH-2-3-arm64-Make-use-of-NUMBER-VA_BITS-in-vmcore.patch
    -d/p/0007-PATCH-3-3-arm64-support-flipped-VA-and-52-bit-kernel.patch

 -- Ioanna Alifieraki <email address hidden> Thu, 15 Apr 2021 22:42:25 +0300

Changed in makedumpfile (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.5-1ubuntu1~18.04.6

---------------
makedumpfile (1:1.6.5-1ubuntu1~18.04.6) bionic; urgency=medium

  * Fix makedumpfile failure on arm64 with 5.4 kernels (LP: #1879214)
    -d/p/0007-PATCH-arm64-Add-support-for-ARMv8.2-LPA-52-bit-PA-su.patch
    -d/p/0008-PATCH-1-3-Use-vmcoreinfo-note-in-proc-kcore-for-mem-.patch
    -d/p/0009-PATCH-2-3-arm64-Make-use-of-NUMBER-VA_BITS-in-vmcore.patch
    -d/p/0010-PATCH-3-3-arm64-support-flipped-VA-and-52-bit-kernel.patch

 -- Ioanna Alifieraki <email address hidden> Thu, 15 Apr 2021 22:27:56 +0300

Changed in makedumpfile (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.